package libmysqlclient-dev None [modified: /var/lib/dpkg/info/libmysqlclient-dev.list] failed to install/upgrade: trying to overwrite `/usr/include/mysql/decimal.h', which is also in package libmysqlclient15-dev

Bug #316280 reported by Fabio Colombo on 2009-01-12
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-dfsg-5.0 (Ubuntu)
High
Mathias Gug
mysql-dfsg-5.1 (Ubuntu)
High
Unassigned

Bug Description

This happens with the last upgrade of today testing Jaunty 386.

Bye and thanks

ProblemType: Package
Architecture: i386
Dependencies:

DistroRelease: Ubuntu 9.04
ErrorMessage: trying to overwrite `/usr/include/mysql/decimal.h', which is also in package libmysqlclient15-dev
Package: libmysqlclient-dev None [modified: /var/lib/dpkg/info/libmysqlclient-dev.list]
SourcePackage: mysql-dfsg-5.1
Title: package libmysqlclient-dev None [modified: /var/lib/dpkg/info/libmysqlclient-dev.list] failed to install/upgrade: trying to overwrite `/usr/include/mysql/decimal.h', which is also in package libmysqlclient15-dev
Uname: Linux 2.6.27-7-generic i686

Chris Cheney (ccheney) on 2009-01-12
Changed in mysql-dfsg-5.1:
importance: Undecided → High
milestone: none → jaunty-alpha-3
status: New → Confirmed
Mathias Gug (mathiaz) wrote :

mysql-dfsg-5.1 provided a transitional package named libmysqlclient15-dev and introduced a new binary package libmysqlclient-dev. However mysql 5.0 is the one currently in main and should be the version used to build packages.

Changed in mysql-dfsg-5.0:
assignee: nobody → mathiaz
importance: Undecided → High
milestone: none → jaunty-alpha-3
status: New → Confirmed
Changed in mysql-dfsg-5.1:
milestone: jaunty-alpha-3 → none
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mysql-dfsg-5.0 - 5.1.30really5.0.75-0ubuntu1

---------------
mysql-dfsg-5.0 (5.1.30really5.0.75-0ubuntu1) jaunty; urgency=low

  * No change upload. Rebuild so that libmysqlclient15-dev is again available
    in jaunty. mysql-dfsg-5.1_5.1.30-2ubuntu1 provided a libmysqlclient15-dev
    transitional package. -2ubuntu2 doesn't provide libmysqlclient15-dev
    anymore. (LP: #316280).

 -- Mathias Gug <email address hidden> Tue, 13 Jan 2009 13:24:13 -0500

Changed in mysql-dfsg-5.0:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mysql-dfsg-5.1 - 5.1.30-2ubuntu2

---------------
mysql-dfsg-5.1 (5.1.30-2ubuntu2) jaunty; urgency=low

  * debian/control:
    + Don't build mysql-server, mysql-client, mysql-common and
      libmysqlclient15-dev binary packages since they're still provided
      by mysql-dfsg-5.0.
    + Rename libmysqlclient-dev package to libmysqlclient16-dev (LP: #316280).
      Make it conflict with libmysqlclient15-dev.

 -- Mathias Gug <email address hidden> Tue, 13 Jan 2009 13:34:50 -0500

Changed in mysql-dfsg-5.1:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers