auto-install-tester can not install/remove this package: trying to overwrite '/usr/bin/my_print_defaults', which is also in package mysql-server-core-5.1 0:5.1.41-3ubuntu12

Bug #576528 reported by Michael Vogt on 2010-05-06
164
This bug affects 24 people
Affects Status Importance Assigned to Milestone
mysql-cluster-7.0 (Ubuntu)
High
Clint Byrum

Bug Description

During a automatic intall/remove of the package the following problems were found from the package auto-install-tester on current lucid:
The following extra packages will be installed:
  libhtml-template-perl mysql-cluster-client-5.1
Suggested packages:
  libipc-sharedcache-perl libdbi-perl libdbd-mysql-perl tinyca
The following NEW packages will be installed
  libhtml-template-perl mysql-cluster-client-5.1 mysql-cluster-server-5.1
0 upgraded, 3 newly installed, 0 to remove and 146 not upgraded.
Need to get 34.9MB of archives.
After this operation, 80.5MB of additional disk space will be used.
Get: 1 http://archive.ubuntu.com/ubuntu/ lucid/universe mysql-cluster-client-5.1 7.0.9-1ubuntu7 [4,415kB]
Get: 2 http://archive.ubuntu.com/ubuntu/ lucid/universe mysql-cluster-server-5.1 7.0.9-1ubuntu7 [30.4MB]
Get: 3 http://archive.ubuntu.com/ubuntu/ lucid/main libhtml-template-perl 2.9-1 [65.8kB]
Fetched 34.9MB in 1min 23s (419kB/s)
Preconfiguring packages ...
Selecting previously deselected package mysql-cluster-client-5.1.
(Reading database ...
erver(Reading database ... 416097 files and directories currently installed.)
Unpacking mysql-cluster-client-5.1 (from .../mysql-cluster-client-5.1_7.0.9-1ubuntu7_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/mysql-cluster-client-5.1_7.0.9-1ubuntu7_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/mysql', which is also in package mysql-client-core-5.1 0:5.1.41-3ubuntu12
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Selecting previously deselected package mysql-cluster-server-5.1.
Unpacking mysql-cluster-server-5.1 (from .../mysql-cluster-server-5.1_7.0.9-1ubuntu7_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/mysql-cluster-server-5.1_7.0.9-1ubuntu7_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/my_print_defaults', which is also in package mysql-server-core-5.1 0:5.1.41-3ubuntu12
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Selecting previously deselected package libhtml-template-perl.
Unpacking libhtml-template-perl (from .../libhtml-template-perl_2.9-1_all.deb) ...
Processing triggers for ureadahead ...
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/mysql-cluster-client-5.1_7.0.9-1ubuntu7_amd64.deb
 /var/cache/apt/archives/mysql-cluster-server-5.1_7.0.9-1ubuntu7_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Michael Vogt (mvo) on 2010-05-06
Changed in mysql-cluster-7.0 (Ubuntu):
status: New → Confirmed
importance: Undecided → High
summary: - auto-install-tester can not install/remove this package
+ auto-install-tester can not install/remove this package: trying to
+ overwrite '/usr/bin/my_print_defaults', which is also in package mysql-
+ server-core-5.1 0:5.1.41-3ubuntu12
Thierry Carrez (ttx) wrote :

Chuck, could you have a look into this ?

Changed in mysql-cluster-7.0 (Ubuntu):
assignee: nobody → Chuck Short (zulcss)
Changed in mysql-cluster-7.0 (Ubuntu):
assignee: Chuck Short (zulcss) → Clint Byrum (clint-fewbar)
status: Confirmed → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers