error when i save a file

Bug #657052 reported by Andrea Azzarone on 2010-10-08
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
myspell (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gedit

When I save a file (also an empty file) i get this error on the console (but the file is saved):
error: line 3: bad flagvector
error: line 7: bad flagvector
error: line 10: bad flagvector
error: line 12: bad flagvector
error: line 14: bad flagvector
error: line 16: bad flagvector
error: line 21: bad flagvector
error: line 26: bad flagvector

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gedit 2.30.3-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
Architecture: amd64
Date: Fri Oct 8 22:06:26 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate amd64 (20100928)
ProcEnviron:
 LANG=it_IT.utf8
 SHELL=/bin/bash
SourcePackage: gedit

Andrea Azzarone (azzar1) wrote :
Andrea Azzarone (azzar1) wrote :

Sorry, I just found out that have the same problem with other apps such as openoffice.org then this is not an error of gedit.

Andrea Azzarone (azzar1) on 2010-10-10
description: updated
Andrea Azzarone (azzar1) wrote :

I 'resolved' the problem with:
sudo apt-get purge myspell-it

Muflone (il-muflone) wrote :

this is no strictly related to gedit but seems to affect the programs which use myspell

affects: gedit (Ubuntu) → myspell (Ubuntu)
Muflone (il-muflone) wrote :

it could be also related to previous #583911, even if the error message is slightly different
https://bugs.launchpad.net/ubuntu/+source/gedit/+bug/583911

Andrea Azzarone (azzar1) wrote :

This is a part of the strace:

open("/usr/share/myspell/dicts/it_IT.dic", O_RDONLY) = 22
fstat(22, {st_mode=S_IFREG|0644, st_size=1290961, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f9dd0020000
read(22, "95221\n/ Dizionario italiano\n/\n/ "..., 4096) = 4096
write(2, "error: line 3: bad flagvector\n", 30) = 30
write(2, "error: line 7: bad flagvector\n", 30) = 30
write(2, "error: line 10: bad flagvector\n", 31) = 31
write(2, "error: line 12: bad flagvector\n", 31) = 31
write(2, "error: line 14: bad flagvector\n", 31) = 31
write(2, "error: line 16: bad flagvector\n", 31) = 31
write(2, "error: line 21: bad flagvector\n", 31) = 31
write(2, "error: line 26: bad flagvector\n", 31) = 31

Andrea Azzarone (azzar1) wrote :

Probably the problem regards the empty comments, the rows 3, 7, 10, 12, 14, 16, 21, 26.
In fatc, if I delete the empty comments the problem disappeared.
This is the comment that probably generates the problem:

95221
/ Dizionario italiano
/
/ Copyright (C) 2001, 2002 Gianluca Turconi
/ Copyright (C) 2002, 2003, 2004 Gianluca Turconi and Davide Prina
/ Copyright (C) 2004, 2005, 2006, 2007 Davide Prina
/
/ E-Mail: DavidePrina(CHIOCCIOLA)yahoo(PUNTO)com
/ home: http://linguistico.sf.net/wiki
/
/ Version 2.4 (01/09/2007) (DD/MM/YYYY)
/
/ This file is distributed under GPL license.
/
/ This file is part of the "dizionario italiano".
/
/ The "dizionario italiano" is free software; you can redistribute it and/or
/ modify it under the terms of the GNU General Public License as published
/ by the Free Software Foundation; either version 3 of the License, or
/ (at your option) any later version.
/
/ The "dizionario italiano" is distributed in the hope that it will be
/ useful, but WITHOUT ANY WARRANTY; without even the implied warranty of
/ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
/ GNU General Public License for more details.
/
/ You should have received a copy of the GNU General Public
/ License along with the "dizionario italiano",
/ if not, see <http://www.gnu.org/licenses/>.

I have removed some of the / from nb_NO.dic, and i see that im getting error because of them.. Why are / separating words? Like.. 'ABCene/R'. This should be a critical error, making gedit and other applications unstable. And we need myspell_nb ;-)

*Going back to 10.04 where no errors like this occured

bruno.rod (bruno-rod) wrote :

It seems I solved - in Italian dict - removing the lines with ONLY a leading "/" in the header of the file.
They are present only in Italian dictionary , not in other languages installed in my /usr/share/myspell/dicts ..
And the "offending" line numbers are those in the error message..
So the bug can appear or not, depending from the used language(s).

Donatella (yayfall) wrote :

The same errors appear to me after saving a file by root with gedit.
I modified the file "/usr/share/myspell/dicts/it_IT.dic" removing the lines with only a leading "/" in the header of the file, but I get this error:
(gedit:6391): Gtk-CRITICAL **: IA__gtk_progress_set_percentage: assertion `percentage >= 0 && percentage <= 1.0' failed
(I am new in Ubuntu and in this forum, I hope this comment isn't improper!)

camillo (condorillo) wrote :

with Ubuntu 10.10 I had the same problem with openoffice write. In writing a word, the writer crashed (with error bad flagvector). I disabled the options for "automatic corrections" of words and the problem was solved

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers