Ubuntu

[ffe] Please merge mypaint 0.8.2-1 (universe) from Debian testing (main).

Reported by Ken Phillis Jr on 2010-01-31
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
mypaint (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: mypaint

Just a lot of fixes, however, a key change is improved international support... for details look at the copy of the change log below...
Version 0.8.0 Changelog:
- many new brushes contributed by various artists
- brushes organized into groups
- straight lines are possible (hold shift)
- basic layer dialog
- select brush from a stroke on the canvas
- improved color picker, show color while picking
- tools stay at top, only one taskbar entry (depending on your wm)
- faster zoomed-out view (30x speedup in some cases)
- i18n support added, translations in several languages
- new and revised color selectors
- big background patterns are possible (with limitations)
- can save all layers as numbered PNGs
- some drag&drop support
- many other minor enhancements and bugfixes

Related branches

Jon Nordby (jonnor) wrote :

0.8.0 just got accepted for Debian Unstable:
http://packages.qa.debian.org/m/mypaint.html

Hoping you will sync this. That would also solve bug #493366
https://bugs.launchpad.net/ubuntu/+source/mypaint/+bug/493366

naught101 (naught101) wrote :

Those packages might need to be repackaged for ubuntu - I think numpy might be installed in a different place on debian, and I'm getting this:
ImportError: No module named numpy.core.multiarray

python-numpy is installed fine, the ubuntu version of mypain works fine.

naught101 (naught101) wrote :

Importing numpy.core.multiarray from python works fine, here's the traceback:

naught101@naught-laptop:~$ mypaint
ImportError: No module named numpy.core.multiarray

We are not correctly installed or compiled!
script: "/usr/bin/mypaint"
deduced prefix: "/usr"
lib_shared: "/usr/share/mypaint/"
lib_compiled: "/usr/lib/mypaint/"

Traceback (most recent call last):
  File "/usr/bin/mypaint", line 98, in <module>
    datapath, confpath, localepath = get_paths()
  File "/usr/bin/mypaint", line 55, in get_paths
    from lib import mypaintlib
  File "/usr/share/mypaint/lib/mypaintlib.py", line 28, in <module>
    import _mypaintlib
ImportError: numpy.core.multiarray failed to import

We have to merge the Debian package, because 0.8.0-2 still hardcodes the Python dependencies.

We are past the feature freeze. Therefore we need an exception for merging Debian's version. Please follow the freeze exception process [1] and provide the required information.

[1] https://wiki.ubuntu.com/FreezeExceptionProcess

summary: - Update MyPaint to v0.8.0 in Lucid
+ Please merge mypaint 0.8.0-2 (universe) from Debian testing (main).
foobar (gagarin) wrote :

debian's got version 0.8.2-1 now, i guess it's best if you take that version?

Benjamin Drung (bdrung) on 2010-03-10
summary: - Please merge mypaint 0.8.0-2 (universe) from Debian testing (main).
+ Please merge mypaint 0.8.2-1 (universe) from Debian testing (main).
Daniel Hahler (blueyed) on 2010-03-27
summary: - Please merge mypaint 0.8.2-1 (universe) from Debian testing (main).
+ [ffe] Please merge mypaint 0.8.2-1 (universe) from Debian testing
+ (main).
Changed in mypaint (Ubuntu):
importance: Undecided → Wishlist
Daniel Hahler (blueyed) wrote :
Daniel Hahler (blueyed) wrote :
Daniel Hahler (blueyed) wrote :

Testing:
I've started mypaint, painted some (using a normal mouse) and exited the app.
I've not used the application before and therefore cannot test it really, apart from that it's not completely broken.

Install log:
$ sudo dpkg -i mypaint_0.8.2-1ubuntu1_i386.deb mypaint-data_0.8.2-1ubuntu1_all.deb
Wähle vormals abgewähltes Paket mypaint.
(Lese Datenbank ... 338615 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacke mypaint (aus mypaint_0.8.2-1ubuntu1_i386.deb) ...
Wähle vormals abgewähltes Paket mypaint-data.
Entpacke mypaint-data (aus mypaint-data_0.8.2-1ubuntu1_all.deb) ...
Richte mypaint-data ein (0.8.2-1ubuntu1) ...
Richte mypaint ein (0.8.2-1ubuntu1) ...

Verarbeite Trigger für menu ...
Verarbeite Trigger für man-db ...
Verarbeite Trigger für hicolor-icon-theme ...
Verarbeite Trigger für python-gmenu ...
Rebuilding /usr/share/applications/desktop.de_DE.utf8.cache...
Verarbeite Trigger für desktop-file-utils ...
Verarbeite Trigger für python-support ...

Daniel Hahler (blueyed) wrote :
StefanPotyra (sistpoty) wrote :

ACK, FFe granted.

two tiny notes:
* please revisit your changelog entry, you got the bug number twice ;)
* looking at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=570685: can you tighten the python-protobuf version in depends as suggested there?

Thanks,
  Stefan.

Changed in mypaint (Ubuntu):
status: New → Confirmed
Jon Nordby (jonnor) wrote :

I just made a comment regarding python-protobuf version issue in Debian:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=570685#37

Daniel Hahler (blueyed) wrote :

Stefan, re point 2:
are you saying it should depend on python-protobuf >= 2.2.0a-0.1 ?

StefanPotyra (sistpoty) wrote :

Daniel, I'm saying that debian #570685 suggests that a depends on python-protobof >= 2.2.0a-0.1 might be in order.
@Jon, there's no package named protobuf... are your referring to something embedded within mypaint?

Jon Nordby (jonnor) wrote :

Sorry about that, I was referring to protobuf-compiler.

StefanPotyra (sistpoty) wrote :

Jon, thanks, that clears things up!

Since mypaint (0.8.2-1) build-depends on protobuf-compiler and depends on python-protobuf, I assume that adding the version to python-protobuf in the dependencies would be the right thing (even better if there were an automatic way to get the dependency sorted from the build-dependency, but I guess that's just whishful thinking)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mypaint - 0.8.2-1ubuntu1

---------------
mypaint (0.8.2-1ubuntu1) lucid; urgency=low

  * Merge from debian testing. (LP: #515016) Remaining changes:
    - debian/control: Don't hardcode python dependencies.
  * debian/control: Add versioned dependency on python-protobuf
    (>= 2.2.0a-0.1) (LP: #515016, Closes: #570685)

mypaint (0.8.2-1) unstable; urgency=low

  * New upstream version.
  * Added watch file.
  * Add missing dependency to python-gtk2. (Closes: #571600)
  * Switch to dpkg-source 3.0 (quilt) format to avoid repackaging.

mypaint (0.8.0-2) unstable; urgency=low

  * Bump standards version.
  * debian/cntrol: add depends for python-protobuf. (Closes: #568958)
  * Add debian/manpages so the manual page gets installed.

mypaint (0.8.0-1) unstable; urgency=low

  * New upstream version.
  * debian/changelog: Updated copyright year.
  * debian/control: Add build-depends for protobuf-compiler.
  * debian/control: Add depends for python-numpy. (Closes: #551322)
 -- Daniel Hahler <email address hidden> Mon, 12 Apr 2010 00:18:23 +0200

Changed in mypaint (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.