Ctrl+Alt+T doesn't open the terminal in GNOME Shell

Bug #952223 reported by Lucas David-Roesler on 2012-03-11
46
This bug affects 13 people
Affects Status Importance Assigned to Milestone
mutter (Ubuntu)
Undecided
Unassigned

Bug Description

As the title says, Ctrl+Alt+T will not open a terminal. Other keybindings seem to work, for instance Ctl+Alt+L does lock the screen. But, other keybindings seem broken as well, Toggle Maximization State (Ctrl+Alt+5), Maximize window (Super+up), Restore window (Super+down), and Toggle shaded state (Ctrl+Alt+S) do not seem to work either. The other I can personally live without, I didn't really know that the existed until now, but I used to use the binding for the terminal all of the time.

I am using
  Description: Ubuntu precise (development branch)
  Release: 12.04

The one thing I have changed from the default install is that I switched to gnome-shell. Is it possible that this has created a conflict?

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-terminal 3.3.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Sun Mar 11 08:50:09 2012
ExecutablePath: /usr/bin/gnome-terminal
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-terminal
UpgradeStatus: Upgraded to precise on 2012-03-10 (0 days ago)

Lucas David-Roesler (theaxer) wrote :
Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in gnome-control-center.

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://help.ubuntu.com/community/ReportingBugs.

affects: ubuntu → gnome-control-center (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2012-04-02
summary: - Ctrl+Alt+T is not opening a terminal
+ Ctrl+Alt+T doesn't open the terminal in GNOME Shell
affects: gnome-control-center (Ubuntu) → gsettings-desktop-schemas (Ubuntu)
Richard Eames (naddiseo) wrote :

What would one have to do in order to fix this bug? If I knew where to start looking, I might be able to submit a patch.

Jeremy Bicha (jbicha) wrote :

Richard, here's a short (probably too short) overview of how I was planning to fix it.

1. Go into System Settings>Keyboard. Switch to the Shortcuts tab and add a new custom shortcut for open the terminal. (From my testing, it looks like with the switch to gsettings, there isn't a ready made shortcut that works for opening the terminal).
2. Go into dconf-editor and figure out where that custom value is set.
3. Then in the Debian packaging, we need to add a .gsettings-override file with those values. You can see other overrides by looking at the 10_ files in /usr/share/glib-2.0/schemas

Jeremy Bicha (jbicha) wrote :

Ah, I forgot a step:

0. Use gnome-control-center/gnome-settings-daemon without the Ubuntu patches to revert the gsettings migration. You can do that by running Arch Linux, Fedora 17, or by rebuilding the Ubuntu packages without those patches.

I'm also unmarking this as a duplicate of bug 965921 as neither of these two bugs will be automatically fixed. when the other is fixed.

Jeremy Bicha (jbicha) wrote :

Below I've posted what I'd like to put in a gsettings override, but I see that the support for gsettings custom shortcuts was reverted for Precise. Because of the need to continue to support gconf keyboard settings for Precise, this looks like it won't be possible to fix this bug until Q.

[org.gnome.settings-daemon.plugins.media-keys]
custom-keybindings = "['/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/terminal/','/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/trash/']"

[org.gnome.settings-daemon.plugins.media-keys.custom-keybindings.terminal]
binding = "<Primary><Alt>t"
command = "gnome-terminal"
name = "Launch Terminal"

[org.gnome.settings-daemon.plugins.media-keys.custom-keybindings.trash]
binding = "<Super>t"
command = "gvfs-open trash:///"

(I'm not sure if the Trash shortcut would work or not but that custom terminal shortcut works fine in Fedora 17).
name = "Open Trash"

affects: gsettings-desktop-schemas (Ubuntu) → gnome-settings-daemon (Ubuntu)
Jeremy Bicha (jbicha) wrote :

Ah, it looks like GNOME Shell can still use gconf custom keyboard shortcuts with Ubuntu 12.04's patched gnome-settings-daemon.

I'll go ahead and upload the default custom keyboard shortcut then. I've tested this and it works in Unity, Unity 2D, GNOME Classic, GNOME Classic (No Effects), and GNOME Shell.

affects: gnome-settings-daemon (Ubuntu) → metacity (Ubuntu)
Martin Pitt (pitti) wrote :

This patch replaces the current translated "Launch Terminal" with an untranslatable string. Is it possible in any way to only apply this to gnome shell?

Adam Conrad (adconrad) wrote :

This patch also replaces run_command_terminal with gnome-terminal, meaning that people who've selected a custom terminal launch command will see changed behaviour. That seems suboptimal. Based on this and pitti's translation objection, I'm rejecting the upload for now, this needs further discussion (or localisation to just gnome-shell for now).

Jeremy Bicha (jbicha) wrote :

Ok, I guess if I use x-terminal-emulator, it should open the right terminal, right?

I don't see an easy way to make the "Launch Terminal" string translatable. Part of the problem I believe is that when the switch to gsettings happened, GNOME dropped the run_command_terminal option so only a custom command will work. What about if I moved the custom keyboard shortcut to gnome-shell.gconf-defaults instead?

Jeremy Bicha (jbicha) wrote :

Ok, I've tested this with making the change in a mutter gconf defaults and the shortcut works for all of the GNOME & Unity desktops.

Since mutter isn't translated by LP, the string "Launch Terminal" visible in the Custom Keyboard Shortcuts part of System Settings won't be translated at all for GNOME Shell users. Of course, by having the shortcut in metacity as originally proposed, it wouldn't be translated either by release date and this way at least less people are affected by the untranslated string.

affects: metacity (Ubuntu) → mutter (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.4.1-0ubuntu1

---------------
mutter (3.4.1-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - API change: the meta_display_add_keybinding() function added in 3.4
      wasn't usable from a GNOME Shell extension, so has been changed to take
      a GSettings object rather than the name of a schema
    - Fix a crash in the default plugin (not used in GNOME)
    - Make the <Super> key work when set as the mouse button modifier
    - Don't try to automaximize non-maximizable windows, fixes misaligned
      wallpaper (LP: #964796)
  * mutter-common.gconf-defaults:
    - Restore Ctrl+Alt+T shortcut for opening the terminal in GNOME
      Shell (LP: #952223)
  * mutter-common.gsettings-overrides:
    - Add Ctrl+Super+Left/Right shortcut for semi-maximizing windows
      (LP: #982719, LP: #969235)
 -- Jeremy Bicha <email address hidden> Tue, 17 Apr 2012 21:05:15 -0400

Changed in mutter (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers