Reintroduce headless mode in GNOME Shell

Bug #1725153 reported by Didier Roche on 2017-10-20
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
High
gnome-shell (Ubuntu)
Undecided
Unassigned
Artful
Undecided
Unassigned
mutter (Ubuntu)
Undecided
Unassigned
Artful
Undecided
Unassigned

Bug Description

[Impact]

 * I day before the 17.10 release, we had to revert some commits in GNOME Shell due to https://bugs.launchpad.net/gnome-shell/+bug/1723577 which was a release blocker (GNOME Shell not displaying anything on multiple config).

 * Pinging upstream, they debugged it and found the real issue in mutter, and so fixed it, which will enable us to align again with upstream's repo.

 * This should mostly be a no visible-effect for previously impacted users, but GNOME Shell shouldn't crash anymore in GDM (reverting then to Xorg), triggering apport on logging, and the users can then use Wayland instead of Xorg.

[Test Case]

 * Install both mutter and gnome-shell to their latest version in -proposed
 * Reboot
 * Ensure you have an UI in GDM
 * Log in into your session, check that you have an UI and everything is showing up as expected

[Regression Potential]

 * Impact is a regression in GNOME Shell (showing up your entire UI) and not being able to log in. However, some of us (not impated by the bug) are already running latest version and don't see any issue. I have also asked 3 people being impacted by the bug and fixed by the revert to test upstream commits (prepared a package for them in a PPA), and they are running on it since yesterday, confirming Wayland is available.

 * The regressions are quite straightfoward to see: either you have an UI in GDM or none.

Changed in gnome-shell:
importance: Unknown → High
status: Unknown → Fix Released

Hello Didier, or anyone else affected,

Accepted mutter into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mutter/3.26.1-2ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mutter (Ubuntu Artful):
status: New → Fix Committed
tags: added: verification-needed verification-needed-artful
Changed in gnome-shell (Ubuntu Artful):
status: New → Fix Committed
Andy Whitcroft (apw) wrote :

Hello Didier, or anyone else affected,

Accepted gnome-shell into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell/3.26.1-0ubuntu5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

frenchy82 (cartes) wrote :

I've tested these packages from proposed, boot is fine now. I can choose xork or Wayland from gdm
Thanks a lot

apt policy gnome-shell
gnome-shell:
  Installé : 3.26.1-0ubuntu5
  Candidat : 3.26.1-0ubuntu5
 Table de version :
 *** 3.26.1-0ubuntu5 500
        500 http://archive.ubuntu.com/ubuntu artful-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     3.26.1-0ubuntu4 500
        500 http://archive.ubuntu.com/ubuntu artful/main amd64 Packages

apt policy mutter
mutter:
  Installé : 3.26.1-2ubuntu2
  Candidat : 3.26.1-2ubuntu2
 Table de version :
 *** 3.26.1-2ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu artful-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     3.26.1-2ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu artful/main amd64 Packages

Xavier Guillot (valeryan-24) wrote :

Hi,

I also confirm that upstream correction uploaded in artful-proposed works for me, boot and login on Wayland are OK (see 'Proposed' file to have the details).

It seems bug is resolved !

tags: added: verification-done-artful
removed: verification-needed-artful

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of gnome-shell from artful-proposed was performed and bug 1726821 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and add the tag "bot-stop-nagging" to bug 1726821 (not this bug). Thanks!

tags: added: verification-failed
Jeremy Bicha (jbicha) on 2017-10-25
tags: added: verification-done
removed: verification-failed verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.26.1-0ubuntu5

---------------
gnome-shell (3.26.1-0ubuntu5) artful; urgency=medium

  [ Didier Roche ]
  * Reenable headless patches and cherry-pick now that the gdm fix
    is in mutter. (LP: #1725153)
  * Add dep on latest mutter to ensure people don't end up in a non working
    UI state again.

  [ Jeremy Bicha ]
  * Restore dependency on gir1.2-gdm-1.0 (LP: #1725288)

 -- Didier Roche <email address hidden> Thu, 19 Oct 2017 08:38:31 +0200

Changed in gnome-shell (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.26.1-2ubuntu2

---------------
mutter (3.26.1-2ubuntu2) artful; urgency=medium

  * Cherry-pick gdm crasher from gnome-3-26 branch: (LP: #1725153)
    - git_12381d57d1c9256bb1f5206a403c1272bf2af34e.patch
    - git_4ad8c4b86bab938e20e37f47781025911d5ff419.patch

 -- Didier Roche <email address hidden> Thu, 19 Oct 2017 08:42:04 +0200

Changed in mutter (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.26.1-0ubuntu5

---------------
gnome-shell (3.26.1-0ubuntu5) artful; urgency=medium

  [ Didier Roche ]
  * Reenable headless patches and cherry-pick now that the gdm fix
    is in mutter. (LP: #1725153)
  * Add dep on latest mutter to ensure people don't end up in a non working
    UI state again.

  [ Jeremy Bicha ]
  * Restore dependency on gir1.2-gdm-1.0 (LP: #1725288)

 -- Didier Roche <email address hidden> Thu, 19 Oct 2017 08:38:31 +0200

Changed in gnome-shell (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-shell has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.26.1-2ubuntu2

---------------
mutter (3.26.1-2ubuntu2) artful; urgency=medium

  * Cherry-pick gdm crasher from gnome-3-26 branch: (LP: #1725153)
    - git_12381d57d1c9256bb1f5206a403c1272bf2af34e.patch
    - git_4ad8c4b86bab938e20e37f47781025911d5ff419.patch

 -- Didier Roche <email address hidden> Thu, 19 Oct 2017 08:42:04 +0200

Changed in mutter (Ubuntu Artful):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.