Giant terminal icon is blocking out the Terminal window buttons

Bug #1718238 reported by Ínitu Castilhos da Rosa on 2017-09-19
106
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Mutter
Fix Released
Unknown
gnome-shell (Ubuntu)
Medium
Unassigned
mutter (Ubuntu)
Medium
Unassigned

Bug Description

Upstream: https://gitlab.gnome.org/GNOME/mutter/issues/23

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: light-themes 16.10+17.10.20170918-0ubuntu1
ProcVersionSignature: Ubuntu 4.12.0-13.14-generic 4.12.10
Uname: Linux 4.12.0-13-generic x86_64
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Tue Sep 19 12:47:51 2017
InstallationDate: Installed on 2017-09-19 (0 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170917)
PackageArchitecture: all
SourcePackage: ubuntu-themes
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Ínitu Castilhos da Rosa (initu-icr) wrote :
summary: - Problema do ícones do menu no terminal na sessão Xorg
+ Giant terminal icon is blocking own the Terminal window buttons
summary: - Giant terminal icon is blocking own the Terminal window buttons
+ Giant terminal icon is blocking out the Terminal window buttons
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in ubuntu-themes (Ubuntu):
status: New → Confirmed
tags: added: visual-quality
Revision history for this message
Egmont Koblinger (egmont-gmail) wrote :

Please see the duplicate bug 1724250 for some hopefully precious investigation I've done so far.

Revision history for this message
Egmont Koblinger (egmont-gmail) wrote :

(Daniel, may I please kindly recommend that next time when one of the bugs contains all the information present in the other plus much-much more then mark it as duplicate the other way around, even if chronologically incorrect? IMO that's much more useful for continuing to work on it and hopefully getting it fixed eventually. Thanks!)

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Yes we do do that sometimes. However there was an additional reason to keep this one other than its age; the title is much more helpful and specific. By comparison "gnome-terminal graphic artifact" could refer to any number of different problems.

An accurate title is crucial in helping people to find existing bugs and avoid logging more duplicates. And so it brings more people together faster, leading to speedier resolutions, hopefully.

Revision history for this message
Egmont Koblinger (egmont-gmail) wrote :

Well, the title can be changed :) Anyway, it's not worth further discussing, rather than working on the actual bug. Let's get back to business...

Revision history for this message
Egmont Koblinger (egmont-gmail) wrote :

I have found that the presence of the counterpart "utilities-terminal.png" icons under /usr/share/icons/gnome fixes the use of the Humanity one (even though the ones under the "gnome" folder are unused), while removing them breaks it.

Could you guys please confirm if this is the same for you?

sudo apt install gnome-icon-theme # fixes
sudo apt purge gnome-icon-theme # breaks

It's not even required to restart anything, just open a new gnome-terminal window, the icon updates for me to the correct/buggy size accordingly.

Revision history for this message
Egmont Koblinger (egmont-gmail) wrote :

In the buggy case, xprop only reports one icon of size 48.

In the correct case, xprop reports 6 icons of sizes 22, 16, 48, 24, 32 and finally 48 again, all looking like taken from Humanity. (This isn't what I saw here a couple of days ago in the dup bugreport, I've no idea about the cause of this difference.)

Apart from these, the only differences in xprop's output are "bitmap id # to use for icon", "bitmap id # of mask for icon" and "_NET_WM_USER_TIME(CARDINAL)".

Just as the visible icon itself, xprop's output is also not updated immediately when installing/removing gnome-icon-theme, only on certain operatons such as opening a new gnome-terminal tab or window (including Find, Preferences, About windows), or opening its Terminal menu. This makes me still heavily suspect that the icon is indeed taken from the "_NET_WM_ICON(CARDINAL)" X property. But then how do the files shipped by gnome-icon-theme come into the game???

I've double checked that gnome-terminal only performs the "gtk_window_set_default_icon_name (GNOME_TERMINAL_ICON_NAME)" once at startup, so it's not this call setting the X properties directly, but probably GTK+ doing it sometimes under the hood.

This xprop thingy seems to be a dead end for investigation. We'd need to locate the exact piece of software displaying that icon (gnome-shell? mutter?) and start debugging that.

Revision history for this message
Egmont Koblinger (egmont-gmail) wrote :

Here's a fix to mutter.

_NET_WM_ICON is read into mini_icon unscaled (so its documentation is incorrect), preferably at size 16, but if that's not available (as in the buggy case) then in whichever size is available (48 in our case).

Then when scaling is due to happen (the icon gets painted), the reciprocal of the desired factor is applied. So instead of scaling by 1/3 (to downscale from the actual 48 to the desired 16), it's scaled by 3, resulting in 144.

Plus, the position is also incorrectly computed according to the pre-scaled size rather than the scaled size.

---

The icon still looks somewhat different based on the presence/absence of the supposedly irrelevant gnome-icon-theme package. This should need further investigation, probably in GTK+ itself, but is no longer a huge usability problem.

---

Could someone please figure out for me how to file an upstream Mutter bug? This component is no longer present in GNOME bugzilla, even though there were bugs filed just two weeks ago. Manually rewriting the URL redirects me to gitlab.gnome.org. Trying to register there gives a 500.

Revision history for this message
Egmont Koblinger (egmont-gmail) wrote :

Daniel (or anyone else),

Could you please take care of applying this fix for Bionic?

The bug is X11 only which will be the default of Bionic, plus it's LTS, so it'll affect magnitudes more users than on Artful. And it's a big fat look-n-usability no-go.

Thanks in advance!

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "Mutter fix" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mutter (Ubuntu):
status: New → Confirmed
Revision history for this message
Egmont Koblinger (egmont-gmail) wrote :
Changed in mutter (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
description: updated
Revision history for this message
Egmont Koblinger (egmont-gmail) wrote :

It has been fixed upstream, the fix should appear in mutter 3.27.92 / 3.28.

Jeremy Bicha (jbicha) on 2018-03-03
Changed in mutter (Ubuntu):
status: Triaged → Fix Committed
Changed in gnome-shell (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-themes (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.27.92-1

---------------
mutter (3.27.92-1) experimental; urgency=medium

  * New upstream release candidate (LP: #1752123, LP: #1718238)
  * Bump minimum wayland-protocols to 1.12
  * Drop bump-api.patch: Applied in new release

 -- Jeremy Bicha <email address hidden> Mon, 05 Mar 2018 20:38:24 -0500

Changed in mutter (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Brad Figg (brad-figg) wrote :

I still have this problem and I am running mutter 3.27.92-1.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Brad, sounds like you should tell upstream:
https://gitlab.gnome.org/GNOME/mutter/issues/23

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Confirmed by Brad and duplicate bug 1765704 that this bug is not fixed.

Changed in mutter (Ubuntu):
status: Fix Released → Confirmed
Changed in gnome-shell (Ubuntu):
status: Invalid → Confirmed
tags: added: bionic
Revision history for this message
Justin Beitz (jdbeitz) wrote :

Issue remains for me as well 18.04 - 3.28.1

Revision history for this message
Egmont Koblinger (egmont-gmail) wrote :

For those who still see this issue in 18.04:

Is the icon really giant (144x144) for you, as attached to this bug; or is it somewhat smaller (48x48), as attached to bug 1765704?

Does installing/removing gnome-icon-theme, as per comment 8, do anything for you?

If you execute xprop from gnome-terminal, then click on gnome-terminal's window, and scroll back, in what size(s) is/are the icon(s) shown there?

Revision history for this message
guido (rds1944) wrote :

Found this problem *again* in 18.04 with vim (not gvim) running in the gnome-terminal using default .desktop file.

Revision history for this message
Simone Bordet (simone-bordet) wrote :

I am on 18.04, and I see the smaller 48x48 icon as reported in 1765704 and by xprop.

Revision history for this message
Andrew Enderson (ande-e) wrote :

I upgraded from 17.10 to 18.04 today, and I still have this problem as well.
In response to comment 21:

Is the icon really giant (144x144) or smaller (48x48)?
It is smaller after the upgrade to 18.04.

Does installing/removing gnome-icon-them do anything for you?
Yes, installing the gnome-icon-them as per comment 8 appears to fix the issue; uninstalling the gnome-icon-them causes the issue to return.

What size is the icon reported as when executing xprop from gnome-terminal and clicking on the gnome-terminal window?
When the issue is present, xprop reports: _NET_WM_ICON(CARDINAL) = Icon (48 x 48):

Revision history for this message
Egmont Koblinger (egmont-gmail) wrote :

Silly me, instead of asking questions I should have tried it myself.

Whereas the previous fix definitely fixed it (at least for me) on 17.10, it's indeed broken (again, in a somewhat different way: it's smaller now, 48x48) for me too on 18.04.

I'll try to take yet another look.

Revision history for this message
guido (rds1944) wrote :

2018 May 7. Obscuring icon remains. Did fresh install last night with all updates. There is a patch on gitHub for this about 3 days ago. Has it been incorporated by Ubuntu? Does it fix the issue?

Revision history for this message
Egmont Koblinger (egmont-gmail) wrote :

> There is a patch on gitHub for this about 3 days ago.

Where exactly?

Revision history for this message
guido (rds1944) wrote : Re: [Bug 1718238] Re: Giant terminal icon is blocking out the Terminal window buttons

I can not find it; wish I had saved it.

On Mon, May 7, 2018 at 12:27 PM, Egmont Koblinger <email address hidden> wrote:

> > There is a patch on gitHub for this about 3 days ago.
>
> Where exactly?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1748785).
> https://bugs.launchpad.net/bugs/1718238
>
> Title:
> Giant terminal icon is blocking out the Terminal window buttons
>
> Status in gnome-shell package in Ubuntu:
> Confirmed
> Status in mutter package in Ubuntu:
> Confirmed
> Status in ubuntu-themes package in Ubuntu:
> Invalid
>
> Bug description:
> Upstream: https://gitlab.gnome.org/GNOME/mutter/issues/23
>
> ProblemType: Bug
> DistroRelease: Ubuntu 17.10
> Package: light-themes 16.10+17.10.20170918-0ubuntu1
> ProcVersionSignature: Ubuntu 4.12.0-13.14-generic 4.12.10
> Uname: Linux 4.12.0-13-generic x86_64
> ApportVersion: 2.20.7-0ubuntu1
> Architecture: amd64
> CurrentDesktop: ubuntu:GNOME
> Date: Tue Sep 19 12:47:51 2017
> InstallationDate: Installed on 2017-09-19 (0 days ago)
> InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64
> (20170917)
> PackageArchitecture: all
> SourcePackage: ubuntu-themes
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+
> bug/1718238/+subscriptions
>

Revision history for this message
guido (rds1944) wrote :

Wait. Try this from Christian Persch. Commit from 5 days ago.

https://github.com/GNOME/gnome-terminal/commit/887c8128d7c528660afa53fad9ae46e72ca7297c

On Mon, May 7, 2018 at 12:27 PM, Egmont Koblinger <email address hidden> wrote:

> > There is a patch on gitHub for this about 3 days ago.
>
> Where exactly?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1748785).
> https://bugs.launchpad.net/bugs/1718238
>
> Title:
> Giant terminal icon is blocking out the Terminal window buttons
>
> Status in gnome-shell package in Ubuntu:
> Confirmed
> Status in mutter package in Ubuntu:
> Confirmed
> Status in ubuntu-themes package in Ubuntu:
> Invalid
>
> Bug description:
> Upstream: https://gitlab.gnome.org/GNOME/mutter/issues/23
>
> ProblemType: Bug
> DistroRelease: Ubuntu 17.10
> Package: light-themes 16.10+17.10.20170918-0ubuntu1
> ProcVersionSignature: Ubuntu 4.12.0-13.14-generic 4.12.10
> Uname: Linux 4.12.0-13-generic x86_64
> ApportVersion: 2.20.7-0ubuntu1
> Architecture: amd64
> CurrentDesktop: ubuntu:GNOME
> Date: Tue Sep 19 12:47:51 2017
> InstallationDate: Installed on 2017-09-19 (0 days ago)
> InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64
> (20170917)
> PackageArchitecture: all
> SourcePackage: ubuntu-themes
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+
> bug/1718238/+subscriptions
>

Revision history for this message
Egmont Koblinger (egmont-gmail) wrote :

@guido Oh, I guess I found it, I guess you meant this:

https://gitlab.gnome.org/GNOME/mutter/merge_requests/62

I made a comment over there. This patch is buggy, this is the one that breaks my previous fix.

The patch is shipped by Ubuntu, named theme-use-gtk_render_icon_suface-to-paint-button-icon.patch (intended to fix LP #1764558) inside mutter_3.28.1-1ubuntu1.debian.tar.xz. Ubuntu should drop (or fix) this broken patch to fix this problem.

Revision history for this message
Egmont Koblinger (egmont-gmail) wrote :

@guido Nope, that one is irrelevant (that icon title is something completely different, it's a legacy concept: the title of the window whenever it's iconified; plus the change is in gnome-terminal's current development series which won't appear in Bionic).

Anyway, I managed to locate the bug, see my previous comment. Now it's Ubuntu's turn to apply the fix.

Revision history for this message
guido (rds1944) wrote :

I'm confused. Are my URL & yours the same?

Anyway, it seems that Ubuntu has not fixed it.

Terminal seems to work OK, so far; but, it certainly is an eyesore.

Revision history for this message
Jeremy Bicha (jbicha) wrote :

Egmont, by the way, that mutter patch is in Debian also since mutter is currently in sync between Debian and Ubuntu.

Revision history for this message
Egmont Koblinger (egmont-gmail) wrote :

Continued in bug 1770507.

tags: added: cosmic
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

The upstream bug notes that it is an Ubuntu patch causing this bug.

https://gitlab.gnome.org/GNOME/mutter/issues/23#note_115241

tags: removed: artful
Changed in mutter (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-shell (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
no longer affects: ubuntu-themes (Ubuntu)
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Comment #30 notes the same thing ;)

Changed in mutter:
status: Unknown → Fix Released
tags: removed: cosmic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.