Muon Updater does not show package name, version information

Bug #924364 reported by Georg Müller on 2012-01-31
58
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Muon
Fix Released
Wishlist
muon (Ubuntu)
Wishlist
Unassigned

Bug Description

I cannot see the name of the package or the version change (from, to) in the table.

Version step is somehow visible via changelog, but package name is completely missing. Sometimes the descriptions are useless.
Example for these descriptions (and only these are shown in the table):
1. "scalable distributed version control system"
2. "fast, scalable, distributed revision control system"
3. "easy to use distributed version control system"
4. "distributed, interactive, smart revision control system"

These are the descriptions shown for four different DVCS. Now guess what is what ;)

Found in "update manager for KDE" version 1.2.80, 1.2.95

Upstream bug report:
https://bugs.kde.org/show_bug.cgi?id=288902

Related branches

Version: unspecified
OS: Linux

It would be nice to show the version number of the applications and packages that can be updated.
So not only depend on the changelog files to indicate to which version the users update their packages.

Reproducible: Didn't try

Expected Results:
Show version of the updates in listview

Especially usefull for Debian Testing/Unstable users as the changelog files on debian server don't get updated very quickly.

Not only this, the name of the package is also missing (muon 1.2.80). Sometimes it is not possible to guess the name of a package from it's description. muon itself only shows "update manager for KDE", which could also be another update manager.

So columns containing package name, old version, new version would be very useful. I like the details I get from aptitude and their summary before installing.

Changed in muon (Ubuntu):
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in muon (Ubuntu):
status: New → Confirmed
summary: - muon does not show package name, version information
+ Muon Updater does not show package name, version information
Reuben Firmin (reubenf) wrote :

Please bump this out of wishlist. It is a bug, not a "desired feature". As configured, I can't tell what is going to be installed on my system when I accept an update.

"Utilities to configure the GNOME desktop" - great, what is that? Try googling for that and finding me the project page. Where can I see the source code? Where can I see the new commits that are included in this version?

or

"Open source social networking client for GNOME"
"event logging framework"
"System sound indicator"

I get that this feature is supposed to make the update notifier more friendly for non technical users, but until packages have consistently useful descriptions the display absolutely needs to include the package name in a third column; without it the updater is missing critical functionality. Until then I will rely on apt for updates.

Whoa, this was reported 5 months ago already. Who would think this is such a difficult feature to implement... ;) I just started using Muon, now that the authentication issue has been fixed, but I think I am going to go back to synaptic. This bug makes it totally impossible to use.

I am also frustrated by this bug. It does not seem to be something difficult to fix, but it has been there for 6 months already. Can't use Muon in those conditions. Why is it unconfirmed anyway?

Changed in muon:
importance: Unknown → Wishlist
status: Unknown → New

Git commit 53765f4c0e3ee1386768393e721dcfb14c7cf0aa by Jonathan Thomas.
Committed on 10/07/2012 at 23:54.
Pushed by jmthomas into branch 'master'.

Add a version column to the updater.
FIXED-IN:1.4

M +13 -0 updater/UpdateModel/UpdateItem.cpp
M +1 -0 updater/UpdateModel/UpdateItem.h
M +12 -9 updater/UpdateModel/UpdateModel.cpp
M +6 -0 updater/UpdateModel/UpdateModel.h
M +1 -0 updater/UpdaterWidget.cpp

http://commits.kde.org/muon/53765f4c0e3ee1386768393e721dcfb14c7cf0aa

Changed in muon:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package muon - 1.3.95-0ubuntu1

---------------
muon (1.3.95-0ubuntu1) quantal; urgency=low

  * New upstream release candidate (LP: #924364)
    - Update muon-discover.install for new files
  * Change dependency on update-manager-kde to ubuntu-release-upgrader-qt
    (LP: #1020631)
 -- Jonathan Thomas <email address hidden> Sun, 15 Jul 2012 13:23:27 -0400

Changed in muon (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.