[sru] Muon: missing dependency on software-properties-kde

Bug #1612392 reported by Carlo Vanini on 2016-08-11
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Muon
Fix Released
High
muon (Ubuntu)
Low
Unassigned
Xenial
Low
Mattia Rizzolo
Yakkety
Low
Mattia Rizzolo
Zesty
Low
Unassigned

Bug Description

[Impact]

It is not possible to edit software sources through Muon because software-properties-kde is not installed by default.

[Test Case]

* Open Muon.
* Click the menu Settings -> Configure Software Sources.
* You are asked for your password, insert it.
* The window to configure sources opens.

[Regression Potential]

* Low, this adds an already existing program which is not installed by default.
* Before the split of plasma-discover, s-p-k was installed because Muon did depend on libmuon, which did depend on software-properties-kde.
* This still assumes that `kdesu` is available.

The software sources editor won't open.

Reproducible: Always

Steps to Reproduce:
Settings -> Configure Software Sources

Actual Results:
The password prompt informs that the following command is about to be executed:

"--attach 105854757 --dont-update

Some typo in the code must have broken the full command.

Muon 5.6.0
KDE Neon 5.7 (user edition)

Thanks for reporting, please install the package software-properties-kde.

@Carlo installing it solved the problem. Thank you.

Are you going to add that package as a dependency?

This must be fixed in packaging. Reported here: https://bugs.launchpad.net/ubuntu/+source/muon/+bug/1612392

I will consider adding a message in Muon when software-properties-kde is not found.

Carlo Vanini (silhusk) wrote :

The attachment "muon_5.6.0-0ubuntu1.1.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Changed in muon (Ubuntu):
importance: Undecided → Low
tags: added: packaging
tags: added: kubuntu xenial
Changed in muon:
importance: Unknown → High

Git commit ca1379c2f8041f775625255018463a25f9c782b9 by Carlo Vanini.
Committed on 20/08/2016 at 20:23.
Pushed by vanini into branch 'master'.

show error message if software-properties-kde cannot be found

Settings -> "Configure Software Sources" invokes the external program
software-properties-kde, if it is not found show an error message.

M +12 -0 src/muonapt/QAptActions.cpp

http://commits.kde.org/muon/ca1379c2f8041f775625255018463a25f9c782b9

Changed in muon:
status: Unknown → Fix Released

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in muon (Ubuntu):
status: New → Confirmed
Carlo Vanini (silhusk) wrote :

Muon now (in git master) shows a message box when it doesn't find s-p-kde. So a Recommends could be sufficient.

Mattia Rizzolo (mapreri) wrote :

That's in git master indeed; but until that's also released and packaged it should be a dependency.
I'm uploading your debdiff after doing s/UNRELEASED/zesty/.

Mattia Rizzolo (mapreri) wrote :

and also using a proper versioning for non-SRU uploads.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package muon - 4:5.6.0-0ubuntu2

---------------
muon (4:5.6.0-0ubuntu2) zesty; urgency=medium

  * Add software-properties-kde dependency. (LP: #1612392)

 -- Carlo Vanini <email address hidden> Thu, 11 Aug 2016 18:46:57 +0200

Changed in muon (Ubuntu):
status: Confirmed → Fix Released

Looks to me like this needs some fixing in lower no.releases too:

http://packages.ubuntu.com/yakkety/muon

http://packages.ubuntu.com/xenial/muon

Probably it's possible to proceed in the same instance of bug-reporting level?

OR open a new bug-report wt SRU-request?

Mattia Rizzolo (mapreri) wrote :

It can be done here. I added appropriate tasks.
If anybody wants to tackle it, feel free to.
Once ready (including the description of the bug to follow the SRU rules, and be ready to test the package from proposed once uploaded&accepted) please subscribe ubuntu-sponsors.

Changed in muon (Ubuntu Xenial):
importance: Undecided → Low
Changed in muon (Ubuntu Yakkety):
importance: Undecided → Low
Changed in muon (Ubuntu Yakkety):
status: New → Confirmed
Changed in muon (Ubuntu Xenial):
status: New → Confirmed

@ Mattio: Completely forgot to say: "Thank you!"

summary: - missing dependency on software-properties-kde
+ [sru] Muon: missing dependency on software-properties-kde

I'm using KDE 5.8.5 and experiencing same problem here. The software sources dialog never opens!

I'm using Ubuntu 16.04 with Kubuntu-backports ppa.

Mattia Rizzolo (mapreri) wrote :

Change uploaded to xenial and yakkety too.

Changed in muon (Ubuntu Xenial):
status: Confirmed → In Progress
Changed in muon (Ubuntu Yakkety):
assignee: nobody → Mattia Rizzolo (mapreri)
status: Confirmed → In Progress
Changed in muon (Ubuntu Xenial):
assignee: nobody → Mattia Rizzolo (mapreri)
Łukasz Zemczak (sil2100) wrote :

Please update the bug to include the required SRU information as per the bug template: https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template . Thank you!

Brian Murray (brian-murray) wrote :

While the SRU information isn't explicitly spelled out, the test case seems rather self explanatory - its not possible to edit sources because software-properties-kde isn't installed by default.

I'll go ahead an accept this but expect the description to be updated to include a detailed test case which is followed when verifying the SRU.

Changed in muon (Ubuntu Yakkety):
status: In Progress → Fix Committed
tags: added: verification-needed

Hello Carlo, or anyone else affected,

Accepted muon into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/muon/4:5.6.0-0ubuntu1.16.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in muon (Ubuntu Xenial):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Carlo, or anyone else affected,

Accepted muon into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/muon/4:5.6.0-0ubuntu1.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Carlo Vanini (silhusk) on 2017-05-05
description: updated
Carlo Vanini (silhusk) wrote :

I notice now that software-properties-kde is included in the kubuntu desktop seed for both xenial and yakkety. Also included in the seed is apturl-kde, which depends on s-p-k. Therefore, s-p-k should already be there on a clean install. It may make sense to remove it before installing proposed for verification.

Carlo Vanini (silhusk) wrote :

The packages in -proposed work for me.
In Xenial muon 4:5.6.0-0ubuntu1.16.04.1
In Yakkety muon 4:5.6.0-0ubuntu1.16.10.1

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for muon has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package muon - 4:5.6.0-0ubuntu1.16.10.1

---------------
muon (4:5.6.0-0ubuntu1.16.10.1) yakkety; urgency=medium

  * Add software-properties-kde dependency. (LP: #1612392)

 -- Mattia Rizzolo <email address hidden> Tue, 18 Apr 2017 22:05:20 +0200

Changed in muon (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package muon - 4:5.6.0-0ubuntu1.16.04.1

---------------
muon (4:5.6.0-0ubuntu1.16.04.1) xenial; urgency=medium

  * Add software-properties-kde dependency. (LP: #1612392)

 -- Mattia Rizzolo <email address hidden> Tue, 18 Apr 2017 22:14:59 +0200

Changed in muon (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.