Content doesn't refresh when viewed in desktop file manager

Bug #1295086 reported by Alan Pope 🍺🐧🐱 πŸ¦„ on 2014-03-20
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
mtp (Ubuntu)
Wishlist
Mathieu Trudel-Lapierre

Bug Description

Add files to Ubuntu mobile device (drag and drop via nautilus for example)
Later.. remove files from ubuntu device (adb shell rm /home/phablet/Videos/*)
Note that the nautilus file manager does not update. Copying files to the device erroneously reports out of space when there's plenty.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: mtp-server 0.0.2+14.04.20140307-0ubuntu1
Uname: Linux 3.4.0-5-mako armv7l
ApportVersion: 2.13.3-0ubuntu1
Architecture: armhf
Date: Thu Mar 20 11:25:25 2014
InstallationDate: Installed on 2014-03-20 (0 days ago)
InstallationMedia: Ubuntu Trusty Tahr (development branch) - armhf (20140320)
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 SHELL=/bin/bash
SourcePackage: mtp
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mtp (Ubuntu):
status: New → Confirmed
Dave Morley (davmor2) wrote :

Hitting reload on the nautilus window doesn't modify the file not being there nor does unmounting and remounting the device.

However if you remove the device and reconnect it is then removed.

It seems as if mtp is somehow keeping a log of files and nautilus is reading from that rather that the actual phone system maybe.

Dave Morley (davmor2) wrote :

Tested the same thing on Android and the Video was instantly removed from the movies folder on nautilus. So it looks like we are not updating mtp on the fly.

It renders essential features or functionality of the package (or a dependent one) broken.

Changed in mtp (Ubuntu):
importance: Undecided → High

Indeed, we're not updating on the fly. This is a wishlist bug we'll fix very soon.

Changed in mtp (Ubuntu):
status: Confirmed → Triaged
importance: High → Wishlist
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)

AFAIK we've fixed this with the current version of MTP in the archive and on the images. Maybe this should be closed Fix Released now?

Dave Morley (davmor2) on 2014-07-30
tags: added: qa-daily-testing rtm14
shankao (shankao) wrote :

It still seems broken:

1. Access a MTP folder in nautilus
2. Delete some files inside that folder from the phone
3. Nautilus keeps showing the deleted files

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers