Comment 8 for bug 343069

jcornwall (jay-jcornwall) wrote :

Ah, sorry. I dropped that patch in for the maintainer and omitted an explanation of how to apply it for users to experiment with.

You need to do this:

sudo apt-get install dpkg-dev fakeroot
sudo apt-get build-dep mt-daapd
apt-get source mt-daapd [no sudo on this one]
cd mt-daapd-0.9~r1696.dfsg
cp /path/to/downloaded/13_avahi_fix_and_handle_restart.dpatch debian/patches
dpkg-buildpackage -rfakeroot
sudo dpkg -i ../*.deb

After installing the new package you might find that 'apt-get upgrade' will want to reinstall the old version. You can either not install the new package and just copy the mt-daapd binary (bad but it'll work) or you can increment the package version number (bad because you might miss a real update). For the latter, do this before 'dpkg-buildpackage -rfakeroot':

sudo apt-get install devscripts
dch -i