msttcorefonts cannot install behind authenticating proxy

Bug #220070 reported by drtomc on 2008-04-21
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
msttcorefonts (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: msttcorefonts

This problem is similar to #56880, but I believe it is a distinct problem.

This is occurring with gutsy, msttcorefonts 2.2.

I operate behind an authenticating proxy. I have set http_proxy to an appropriate value of the form http://username:password@hostname:port/. For most things this seems to work okay - apt-get works, in particular.

For msttcorefonts (and some other packages), installation fails during the setup phase. The problem is in the postinstall script. In particular, wget is not parsing the http_proxy variable correctly:

conway@antisense:~$ wget http://www.abc.net.au/news/
Error parsing proxy URL http://conway:<email address hidden>:7000/: Bad port number.
conway@antisense:~$

So, it looks like either a bug in the postinstall script, which fails to take into account the limitations of wget, or a bug in wget which fails to parse the value of http_proxy correctly.

Steve Langasek (vorlon) wrote :

This should be fixed now in precise, which uses update-notifier and python's urllib with apt proxy settings instead of wget.

Changed in msttcorefonts (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers