[server] package ttf-mscorefonts-installer 3.4+nmu1ubuntu2 fails to install/upgrade

Bug #1371783 reported by VinDSL on 2014-09-19
486
This bug affects 105 people
Affects Status Importance Assigned to Milestone
msttcorefonts (Ubuntu)
High
Unassigned

Bug Description

I've been trying to upgrade/update 'ttf-mscorefonts-installer' for the past week, but the install/upgrade fails with a 'andale32.exe Hash Sum mismatch" error:

<SNIP>

ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/andale32.exe
Get:1 http://downloads.sourceforge.net/corefonts/andale32.exe
Fetched 552 B in 11s (47 B/s)

E: Failed to fetch http://downloads.sourceforge.net/corefonts/andale32.exe Hash Sum mismatch

E: Download Failed
Setting up ttf-mscorefonts-installer (3.4+nmu1ubuntu2) ...

<SNIP>

'lsb_release -rd':
Description: Ubuntu Utopic Unicorn (development branch)
Release: 14.10

apt-cache policy ttf-mscorefonts-installer
ttf-mscorefonts-installer:
  Installed: 3.4+nmu1ubuntu2
  Candidate: 3.4+nmu1ubuntu2
  Version table:
 *** 3.4+nmu1ubuntu2 0
        500 http://mirror.hmc.edu/ubuntu/ utopic/multiverse i386 Packages
        100 /var/lib/dpkg/status

I expect it to complete the install/upgrade, but it constantly chokes on 'andale32.exe', and generates a notification after each boot.

VinDSL (perfect-pecker) wrote :

Correction: 'andale32.exe' is reporting a "Hash Sum mismatch" as indicated above, not a "checksum mismatch" as I posted.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in msttcorefonts (Ubuntu):
status: New → Confirmed
VinDSL (perfect-pecker) on 2014-09-19
description: updated
VinDSL (perfect-pecker) wrote :
dino99 (9d9) wrote :

Looks like a 'update-notifier' issue, not able to get the required 'EULA' popup to validate the installation. So the server used may have some restrictions or misconfiguration.
Some users have suggested, as a workaround, to try with different DNS.

Myself have had such issue; but i've made a fresh installation (due to some not related troubles) and now the whining popup is gone. That is, so the 'EULA' problem can also be an user borked configuration.

VinDSL (perfect-pecker) wrote :

Hi Dino,

Your idea sounded plausible, so I checked. It shows that I agreed to the 'EULA':

sudo debconf-get-selections | grep 'msttcorefonts/accepted-mscorefonts-eula'

ttf-mscorefonts-installer msttcorefonts/accepted-mscorefonts-eula boolean true

VinDSL (perfect-pecker) wrote :

I decided to do a 'wash, rinse, and restyle' ( very careful to accept the 'EULA' ) ...

sudo apt-get purge ttf-mscorefonts-installer
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  ttf-mscorefonts-installer*
0 upgraded, 0 newly installed, 1 to remove and 3 not upgraded.
After this operation, 134 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 191787 files and directories currently installed.)
Removing ttf-mscorefonts-installer (3.4+nmu1ubuntu2) ...
Purging configuration files for ttf-mscorefonts-installer (3.4+nmu1ubuntu2) ...
Processing triggers for update-notifier-common (3.156) ...

Now, it's failing on 'arial32.exe' ...

<SNIP>

ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/andale32.exe
Get:1 http://downloads.sourceforge.net/corefonts/andale32.exe [198 kB]
Fetched 198 kB in 12s (15.8 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/arial32.exe
Get:1 http://downloads.sourceforge.net/corefonts/arial32.exe
Fetched 552 B in 11s (47 B/s)

E: Failed to fetch http://downloads.sourceforge.net/corefonts/arial32.exe Hash Sum mismatch

E: Download Failed
Setting up ttf-mscorefonts-installer (3.4+nmu1ubuntu2) ...

<SNIP>

VinDSL (perfect-pecker) wrote :

Tried a different DNS...

ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/andale32.exe
Err http://downloads.sourceforge.net/corefonts/andale32.exe
  The HTTP server sent an invalid Content-Range header

E: Failed to fetch http://downloads.sourceforge.net/corefonts/andale32.exe The HTTP server sent an invalid Content-Range header

E: Download Failed
Setting up ttf-mscorefonts-installer (3.4+nmu1ubuntu2) ...

VinDSL (perfect-pecker) wrote :

Tried yet another DNS:

ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/andale32.exe
Get:1 http://downloads.sourceforge.net/corefonts/andale32.exe [198 kB]
Fetched 198 kB in 12s (16.4 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/arial32.exe
Get:1 http://downloads.sourceforge.net/corefonts/arial32.exe [554 kB]
Fetched 554 kB in 15s (35.4 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/arialb32.exe
Err http://downloads.sourceforge.net/corefonts/arialb32.exe
  The HTTP server sent an invalid Content-Range header

E: Failed to fetch http://downloads.sourceforge.net/corefonts/arialb32.exe The HTTP server sent an invalid Content-Range header

E: Download Failed
Setting up ttf-mscorefonts-installer (3.4+nmu1ubuntu2) ...

VinDSL (perfect-pecker) wrote :

Strike 3. Guess we can give up on the DNS theory...

ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/andale32.exe
Err http://downloads.sourceforge.net/corefonts/andale32.exe
  The HTTP server sent an invalid Content-Range header

E: Failed to fetch http://downloads.sourceforge.net/corefonts/andale32.exe The HTTP server sent an invalid Content-Range header

E: Download Failed
Setting up ttf-mscorefonts-installer (3.4+nmu1ubuntu2) ...

VinDSL (perfect-pecker) on 2014-09-20
summary: - package ttf-mscorefonts-installer 3.4 fails to install/upgrade
+ package ttf-mscorefonts-installer 3.4+nmu1ubuntu2 (utopic) fails to
+ install/upgrade
VinDSL (perfect-pecker) on 2014-09-21
tags: added: utopic
removed: andale32.exe
Download full text (3.3 KiB)

sudo apt-get install ttf-mscorefonts-installer
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  ttf-mscorefonts-installer
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/29.5 kB of archives.
After this operation, 134 kB of additional disk space will be used.
Preconfiguring packages ...
Selecting previously unselected package ttf-mscorefonts-installer.
(Reading database ... 172111 files and directories currently installed.)
Preparing to unpack .../ttf-mscorefonts-installer_3.4+nmu1ubuntu2_all.deb ...
Unpacking ttf-mscorefonts-installer (3.4+nmu1ubuntu2) ...
Processing triggers for fontconfig (2.11.1-0ubuntu3) ...
Processing triggers for update-notifier-common (3.157) ...
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/andale32.exe
Get:1 http://downloads.sourceforge.net/corefonts/andale32.exe [198 kB]
Fetched 198 kB in 3s (54.3 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/arial32.exe
Get:1 http://downloads.sourceforge.net/corefonts/arial32.exe [554 kB]
Fetched 554 kB in 6s (88.5 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/arialb32.exe
Get:1 http://downloads.sourceforge.net/corefonts/arialb32.exe [168 kB]
Fetched 168 kB in 2s (60.4 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/comic32.exe
Get:1 http://downloads.sourceforge.net/corefonts/comic32.exe [246 kB]
Fetched 246 kB in 3s (78.0 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/courie32.exe
Get:1 http://downloads.sourceforge.net/corefonts/courie32.exe [646 kB]
Fetched 646 kB in 4s (133 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/georgi32.exe
Get:1 http://downloads.sourceforge.net/corefonts/georgi32.exe [392 kB]
Fetched 392 kB in 3s (105 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/impact32.exe
Get:1 http://downloads.sourceforge.net/corefonts/impact32.exe [173 kB]
Fetched 173 kB in 2s (61.0 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/times32.exe
Get:1 http://downloads.sourceforge.net/corefonts/times32.exe [662 kB]
Fetched 662 kB in 4s (133 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/trebuc32.exe
Get:1 http://downloads.sourceforge.net/corefonts/trebuc32.exe [357 kB]
Fetched 357 kB in 3s (94.3 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/verdan32.exe
Err http://downloads.sourceforge.net/corefonts/verdan32.exe
  Connection failed
E: Failed ...

Read more...

Paulo Molina (polochamps2004) wrote :

sudo apt-get install ttf-mscorefonts-installer
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  ttf-mscorefonts-installer
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/29.5 kB of archives.
After this operation, 134 kB of additional disk space will be used.
Preconfiguring packages ...
Selecting previously unselected package ttf-mscorefonts-installer.
(Reading database ... 172111 files and directories currently installed.)
Preparing to unpack .../ttf-mscorefonts-installer_3.4+nmu1ubuntu2_all.deb ...
Unpacking ttf-mscorefonts-installer (3.4+nmu1ubuntu2) ...
Processing triggers for fontconfig (2.11.1-0ubuntu3) ...
Processing triggers for update-notifier-common (3.157) ...
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/andale32.exe
Get:1 http://downloads.sourceforge.net/corefonts/andale32.exe [969 B]
Fetched 969 B in 2s (398 B/s)
E: Failed to fetch http://downloads.sourceforge.net/corefonts/andale32.exe Hash Sum mismatch

E: Download Failed
Setting up ttf-mscorefonts-installer (3.4+nmu1ubuntu2) ...

Mark Fraser (launchpad-mfraz) wrote :

This would explain why I've had 2 upgrades from 14.04 to 14.10 fail at upgrading ttf-mscorefonts-installer.

Changed in msttcorefonts (Ubuntu):
importance: Undecided → High
Guitar-robot (guitar-robot) wrote :

I think the SourceForge servers are too smart for their own good. When I did an HTTP 0.9 request (no protocol specified in the GET), I got an HTML page saying the page didn't exist. When I did an HTTP 1.1 request (below) I got a 'bad request' error. When I fetched it with wget I got multiple redirects which eventually led to downloading the file.

$ telnet download.sourceforge.net 80
Trying 216.34.181.59...
Connected to downloads.sourceforge.net.
Escape character is '^]'.
GET /corefonts/andale32.exe HTTP/1.1

HTTP/1.1 400 Bad Request
Server: nginx
Date: Tue, 09 Dec 2014 16:23:28 GMT
Content-Type: text/html
Content-Length: 166
Connection: close

<html>
<head><title>400 Bad Request</title></head>
<body bgcolor="white">
<center><h1>400 Bad Request</h1></center>
<hr><center>nginx</center>
</body>
</html>
Connection closed by foreign host.

Guitar-robot (guitar-robot) wrote :

Here's a work-around until the package is fixed:

TMP=`mktemp -d`
cd $TMP
grep Url: /usr/share/package-data-downloads/ttf-mscorefonts-installer | awk '{print $2}' | xargs -n 1 wget
sudo /usr/lib/msttcorefonts/update-ms-fonts $TMP/*
cd -
rm -rf $TMP

Note that this does skip the hash sum check, but they're just fonts, It's not like someone's going to hijack the download.sourceforge.net DNS and use it to distribute invalid files. The files aren't being executed: the update-ms-fonts script uses cabextract to pull the TTF files out of each exe.

Anyway, hope this helps.

Tuomo Sipola (tuomosipola) wrote :

Guitar-robot's method works but I still keep getting the annoying update notifier popup about failed download.

i did this:

fabricio@fabricio-HP-G42-Notebook-PC:~$ sudo apt-get install -f
E: O dpkg foi interrompido, para corrigir o problema tem de correr manualmente 'sudo dpkg --configure -a'
fabricio@fabricio-HP-G42-Notebook-PC:~$ sudo dpkg -r ttf-mscorefonts-installer
(Lendo banco de dados ... 156571 ficheiros e directórios actualmente instalados.)
Removendo ttf-mscorefonts-installer ...
Processando gatilhos para fontconfig ...

problem seems to have ended

dino99 (9d9) wrote :

Utopic support has now ended; and update-notifier rarely pop up. By the way its a cosmetic trouble that only need to be silenced

Changed in msttcorefonts (Ubuntu):
status: Confirmed → Invalid
aveem ashfaq (aveemashfaq) wrote :

Guys, I have the same bug in Kubuntu 15.04 as described above.

Linus (linusfolke) wrote :

This bug persists in 15.04 and it's not just cosmetic since it does not download the fonts. The bug should not be marked as invalid unless the reason is that a new bug has to be filed with the word (vivid) in the title.

Czikus (czikus-gmail) wrote :

Bug still present in Ubuntu 15.10

Czikus (czikus-gmail) wrote :

I mean 15.10 Alpha 1, and it is certainly NOT cosmetic since fonts are not installed. This should NOT be marked as invalid!

Czikus (czikus-gmail) wrote :

The workaround is to go to:
/var/lib/update-notifier/package-data-downloads/partial
delete all files and try installing the fonts again. If you're luck and you get all of them downloaded right, they will install. If not, delete the partial files again and try installing the fonts until you succeed.

@Czikus, good luck though I tried that about 30 times and never did get them all to download. Each time it fails on different file.

This happened to me a BUNCH of times on Ubuntu 15.04. I basically kept running this and eventually it worked:
sudo apt-get remove --purge ttf-mscorefonts-installer && sudo apt-get install ttf-mscorefonts-installer

Bill Martin (wlm2048) wrote :

This is hardly invalid. I've been getting this on 15.04 every X launch. Trying @aaroncampbell's solution is getting me closer, but it's still failing at random fonts with "Hash Sum mismatch"

ehpc (ehpc) wrote :

I've had this bug in 15.04 and fixed it by manually downloading sourceforge files and placing them in an appropriate directory with "sudo cp ~/Downloads/andale32.exe /var/lib/update-notifier/package-data-downloads/partial/andale32.exe".

René Simon (m1il) wrote :

+1 it is not invalid
Can't the hashsum be fixed?

+1, i get only the "HTTP server sent an invalid Content-Range header" error...

Don Davis (dondavis-reglue) wrote :

+1 not invalid, still getting these messages

Marcus Bitzl (marcus-bitzl) wrote :

+1, when running

sudo apt-get remove --purge ttf-mscorefonts-installer && sudo apt-get install ttf-mscorefonts-installer

again and again, I get either "HTTP server sent an invalid Content-Range header" or hashsum error (seems random).

Changed in msttcorefonts (Ubuntu):
status: Invalid → Confirmed
Andy Idol (andyidol) wrote :

I have the same issue on Xubuntu 15.10, any luck fixing it?

John Freed (oklp) wrote :

Guitar-robot's Comment #14 solves the problem for me, and his concern about the hash checks isn't really warranted, as the /usr/lib/msttcorefonts/update-ms-fonts file contains the correct SHA256 checksums and verifies them.

John Freed (oklp) wrote :

After some further investigating, I have some more information.

-- Comment #14 does indeed complete the installation but does not silence the popup. The similar method in Comment #26 does silence the popup.
-- It is right to be concerned that the font files could be corrupted, because they are hosted on SourceForge, which recently decided to wrap sleazeware around others' software (even though this is specifically prohibited in the fonts' EULA). See http://www.infoworld.com/article/2929732/open-source-software/sourceforge-commits-reputational-suicide.html
-- It might be best for someone else (GitHub? Ubuntu?) to host these files to make sure SourceForge doesn't corrupt them. It is possible that this (or the SourceForge "cookies" popup) is the root cause of this problem, though I have not pursued that. Also, I am often routed to the NetAssist mirror, which appears to have been taken down (it's online but empty).
-- In any case, the Ubuntu installer does verify the SHA256 hashes AFTER the download.

So this method should work (riffing off comments #14 and #26, along with a solution offered in http://askubuntu.com/questions/317765/how-do-i-stop-failure-to-download-extra-data-files-error-with-pepflashpluginin) ...

cd /var/lib/update-notifier/package-data-downloads/partial
grep Url: /usr/share/package-data-downloads/ttf-mscorefonts-installer | awk '{print $2}' | sudo xargs -n 1 'wget'
cd -
sudo /usr/lib/msttcorefonts/update-ms-fonts /var/lib/update-notifier/package-data-downloads/partial/*
sudo rm -f /var/lib/update-notifier/package-data-downloads/partial/*
sudo mv /var/lib/update-notifier/package-data-downloads/ttf-mscorefonts-installer.FAILED /var/lib/update-notifier/package-data-downloads/ttf-mscorefonts-installer

John Freed (oklp) wrote :

Hah! another file needs to go away ...

sudo rm /var/lib/update-notifier/user.d/data-downloads-failed

George Prowse (torqueing) wrote :

This is incredibly annoying. The individual packages are here: http://sourceforge.net/projects/corefonts/files/the%20fonts/final/

j-stuffer (j-stuffer) wrote :

I have this problem on a fresh install of Ubuntu 15.10. Tried it about 20-30 times (different approachs: with a klick on the the popup window, via terminal, with purge, without purge etc.) , the installation always fails, the fonts at which it fails are different though.

John Freed (oklp) wrote :

Did you follow the instructions in Comments #33 and #34 precisely?

j-stuffer (j-stuffer) wrote :

Not yet. I installed Playonlinux and got this error. When installing Steam via Playonlinux (for Quake Live), it also promted that it needs these files. It downloaded (or said it downloads) the files and I could start Steam. But 1 day later the popup came again. I wanted to try 2 more things: 1) Installing wine, perhaps wine fetches the fonts correctly (I read that somewhere) 2) copying the files from my installation on my laptop. Do you know, which files exactly I need and where are they?
Now I am on my laptop, tomorrow I will have access to my desktop again.
It's not too big of a deal anyways, as Playonlinux and Steam via Playonlinux (and thus Quake Live) run without problems. It's just annoying at the moment.

j-stuffer (j-stuffer) wrote :

John Freed:
I tried the instructions in #33 and #34 but it did not work, I still get the error.

j-stuffer (j-stuffer) wrote :

sudo mv /var/lib/update-notifier/package-data-downloads/ttf-mscorefonts-installer.FAILED /var/lib/update-notifier/package-data-downloads/ttf-mscorefonts-installer
mv: Aufruf von stat für »/var/lib/update-notifier/package-data-downloads/ttf-mscorefonts-installer.FAILED“ nicht möglich: Datei oder Verzeichnis nicht gefunden

rough translation:
mv: call for stat for [...] not possible: data or folder not found

j-stuffer (j-stuffer) wrote :

Well okay, "ttf-mscorefonts-installer.FAILED" must be "ttf-mscorefonts-installer.failed" as ".FAILED" does not exist, but ".failed" does. I tried it with "ttf-mscorefonts-installer.failed" now.

James_pic (james-pic) wrote :

Looks like the failure is because some of the Sourceforge mirrors are flaky, and when a mirror flakes out, SourceForge redirects clients to a HTML page with Javascript that makes it try again - which is of course no good for headless downloads.

I stuck a copy of the files onto GitHub pages, and threw together a PPA with a modified version of the package, that downloads from GitHub instead (https://code.launchpad.net/~james-pic/+archive/ubuntu/msttcorefonts). Can we come up with a long term solution that gets around the Sourceforce dependency?

Jason Haar (jhaar-launchpad) wrote :

It's also happening for Ubuntu-16.04. Wow - two years....

I'm not even sure what the fonts are for - I've removed the corrupt package and will see if I can live without it

If you want to work around this because the prompt is annoying, here's how:

Download the .exe files from here and put them in your Downloads folder:

https://sourceforge.net/projects/corefonts/files/the%20fonts/final/

Afterwards, run the following two commands:

sudo cp ~/Downloads/*.exe /var/lib/update-notifier/package-data-downloads/partial/
gksudo /usr/lib/update-notifier/package-data-downloader

That should work and the prompt will go away.

yas (sayazyi) wrote :

I've sorted this in 16.04 with the solution proposed here:
http://askubuntu.com/questions/543673/mscorefonts-problems

Manually installing the version 3.6 directly downloaded from debian repos:

$ wget http://ftp.de.debian.org/debian/pool/contrib/m/msttcorefonts/ttf-mscorefonts-installer_3.6_all.deb
$ sudo dpkg -i ttf-mscorefonts-installer_3.6_all.deb

It gets the files from:
http://downloads.sourceforge.net/project/corefonts/the%20fonts/final/

instead of 3.4 version that uses:
http://downloads.sourceforge.net/corefonts/

Ian Cheetham (ian-cheetham) wrote :

Halleluja! Thank you so much yas, this has been irritating me for months but your solution (#45) has sorted it finally!

Giacomo Fabris (giaco-fabris) wrote :

Also affects 16.04
#45 no more solution (at least, to me) - same failure as installing directly from Ubuntu repo.
Workaround:
1) Download .exe from sourceforge (http://sourceforge.net/projects/corefonts/files/the%20fonts/final/)

2) Purge & reinstall ttf-mscorefonts-installer (let it fail)
3) dpkg-reconfigure ttf-mscorefonts-installer
4) The command line will prompt for an optional path where the fonts have already been downloaded - if any. Type in the path where you downloaded the fonts from sourceforge and there you are!

John Freed (oklp) wrote :

The problem with #45 (and #47, and all the other proposed solutions) is SourceForge, and nothing else. If SourceForge tries to direct you to a nonexistent mirror, all solutions fail. If you try to download from SourceForge and you get an advertising page instead of the file you want, all the automated solutions fail.

The solution in #33 / #34 is fully automated but fails in the case where SourceForge misbehaves.

As james-pic notes in #42 and I have noted, the only solution that will always work requires that someone create a non-SourceForge repo for the fonts. (And no, it makes no difference whatsoever which link you use. http://sourceforge.net/projects/corefonts/files/the%20fonts/final/ and http://downloads.sourceforge.net/corefonts/ point to the same location.)

Since james-pic has created such a non-SF repo (thanks!), his solution should always work. It would be nice to see Ubuntu incorporate it.

Arup (arup-chowdhury) wrote :

16.04 I have the same issue, in fact even with ARCH AUR its the same issue. Sourceforge has been in some serious server troubles. This needs to be repackaged via ppa for now as done in #34 but the ppa is for wily. #47 worked fine here but for mass deployment its hell. msfonts are linked to ubuntu-restricted-extras and wine installation.

dino99 (9d9) on 2016-07-13
tags: removed: utopic
dino99 (9d9) wrote :

That issue should not be met on a fresh and/or clean installation:
- be sure to always 'purge' when uninstalling a package
- often use gtkorphan to purge unneeded package/version
- also clean/autoclean/autoremove can be used

Changed in msttcorefonts (Ubuntu):
status: Confirmed → Incomplete
Arup (arup-chowdhury) wrote :

The issue is happening with clean installation, its a server issue.

dino99 (9d9) on 2016-07-13
Changed in msttcorefonts (Ubuntu):
status: Incomplete → Confirmed
summary: - package ttf-mscorefonts-installer 3.4+nmu1ubuntu2 (utopic) fails to
+ [server] package ttf-mscorefonts-installer 3.4+nmu1ubuntu2 fails to
install/upgrade
Robin (robingape) wrote :

A new bug, based on comment 45, has been raised asking for ttf-mscorefonts-installer to be updated to version 3.6 from Debian since, as of July 2016, the network locations of the font files have been changed. (That was not the original bug.) Thus version 3.4 will never successfully download the core font files. The bug to add heat to is 1607535: https://bugs.launchpad.net/ubuntu/+bug/1607535

R.

information type: Public → Public Security
information type: Public Security → Public
Tor Klingberg (tor-klingberg) wrote :

I got it working with:

sudo apt-get purge ttf-mscorefonts-installer
sudo rm -rf /var/lib/update-notifier/package-data-downloads/partial
sudo mkdir /var/lib/update-notifier/package-data-downloads/partial
sudo apt-get install ttf-mscorefonts-installer
(accept the EULA)

Matthew Kiprovski (mattkip) wrote :

I basically did the same thing as in #53 and it worked for me. This was probably lucky, though, since it really does seem to be a server issue.

Jason Stephenson (jstephenson) wrote :

Comment #14 worked for me just now.

Andrew Elia (amigasoc) wrote :

I've pulled the package apart because I wasn't having much luck with any of the workarounds here. The issue seems to stem from the fact that Sourceforge redirects to another URL to force the use of a mirror. Because it appears that libcurl isn't maintaining cookies between requests, the download of each font is subject to a potential change of mirror. This seems to confuse the process and ends up with a combination of spurious errors such as HTTP range checks, HTTPS not being compiled in, and hash mismatches. From what I can see, if a cookie could be maintained between requests, this would potentially solve the issue. Potentially.

The solution which ultimately worked for me was to pull the following file out of the deb archive...

   /usr/share/package-data-downloads/ttf-mscorefonts-installer

...and bypass the Sourceforge address completely. For example, change the andale32.exe URL to the following:

http://ftp.mirrorservice.org/sites/downloads.sourceforge.net/c/co/corefonts/the fonts/final/andale32.exe

Once the deb was rebuilt, the installation worked consistently every time. Clearly, this is a bodge which works for me in my location but it does appear to prove where the issue is.

nerv (nervgh) wrote :

I have same issue on Ubuntu 16.04

Ivan Anishchuk (anishchuk-ia) wrote :

16.04, same issue here. I could't make #14 work for me (404s and hash mismatches) so I just downloaded all the files and served them with local http server, replacing urls in the /usr/share/package-data-downloads/ttf-mscorefonts-installer I probably could've chosen a better mirror but this was easier.

maurizio de santis (izietto) wrote :

Couldn't be a not escaped space in the URL issue?

~> sudo apt install ttf-mscorefonts-installer
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti NUOVI saranno installati:
  ttf-mscorefonts-installer
0 aggiornati, 1 installati, 0 da rimuovere e 0 non aggiornati.
È necessario scaricare 29,5 kB di archivi.
Dopo quest'operazione, verranno occupati 134 kB di spazio su disco.
Scaricamento di:1 http://archive.ubuntu.com/ubuntu xenial/multiverse amd64 ttf-mscorefonts-installer all 3.4+nmu1ubuntu2 [29,5 kB]
Recuperati 29,5 kB in 20s (1.448 B/s)
Preconfigurazione dei pacchetti in corso
Selezionato il pacchetto ttf-mscorefonts-installer non precedentemente selezionato.
(Lettura del database... 227401 file e directory attualmente installati.)
Preparativi per estrarre .../ttf-mscorefonts-installer_3.4+nmu1ubuntu2_all.deb...
Estrazione di ttf-mscorefonts-installer (3.4+nmu1ubuntu2)...
Elaborazione dei trigger per fontconfig (2.11.94-0ubuntu1.1)...
Elaborazione dei trigger per update-notifier-common (3.168.2)...
ttf-mscorefonts-installer: processing...
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/andale32.exe
Err:1 http://downloads.sourceforge.net/corefonts/andale32.exe
  Protocol "http" not supported or disabled in libcurl
E: Impossibile recuperare https://kent.dl.sourceforge.net/project/corefonts/the fonts/final/andale32.exe Protocol "http" not supported or disabled in libcurl

E: Scaricamento non riuscito
Configurazione di ttf-mscorefonts-installer (3.4+nmu1ubuntu2)...

N1kolay (shayahmetov) wrote :

I have also bug like maurizio de santis (izietto).

E: Failed to fetch https://kent.dl.sourceforge.net/project/corefonts/the fonts/final/andale32.exe Protocol "http" not supported or disabled in libcurl

E: Ошибка при скачивании (Error downloading)

Ben (benmctee) wrote :

Comment #33 worked for me except I did not need to execute:

sudo mv /var/lib/update-notifier/package-data-downloads/ttf-mscorefonts-installer.FAILED /var/lib/update-notifier/package-data-downloads/ttf-mscorefonts-installer

because, due to previous troubleshooting, I did not have any .FAILED (or .failed) files in that directory.

I'm using Xubuntu. lsb_release -a data:

Distributor ID: Ubuntu
Description: Ubuntu 16.04.1 LTS
Release: 16.04
Codename: xenial

Comment 45 worked for me finally. This has been bugging me because a playonlinux install keeps looking for one of these fonts and won't work right until it gets them.

So in two years no one has found a suitable home for the fonts other than sourceforge? >.<

Konrad Hofer (konrad.hofer) wrote :

Commnent 45 worked for me. Why not move ttf-mscorefonts-installer to a "better" place?

ComputeroBz (computerobz) wrote :

#45 worked for me, thanks @sayazyi

I ended up putting it in my article on how to solve this problem for future reference...
https://computerobz.wordpress.com/2016/12/15/ttf-mscorefonts-installer-fails-to-installupgrade/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers