upgrade mplayer package to version 1.0rc2

Bug #150925 reported by Roman Polach on 2007-10-09
4
Affects Status Importance Assigned to Milestone
mplayer (Ubuntu)
Wishlist
William Grant

Bug Description

Please upgrade mplayer package to version 1.0 rc2

Related branches

Niels Abspoel (aboe) wrote :

I would love to see mplayer 1.0 rc2 within ubuntu gutsy, as a exception because of the many updates and fixes.

William Grant (wgrant) wrote :

Not a chance. Approximately 1/3 of the codebase has been modifed, with several hundreds of thousands of lines of diff. mplayer's interpretation of `release candidate' is so incredibly skewed I've no idea what they think they're doing. I almost got it building a couple of nights back, and will upload it to Hardy when it opens. It can be backported once it's there.

Changed in mplayer:
assignee: nobody → fujitsu
importance: Undecided → Wishlist
status: New → Confirmed
William Grant (wgrant) on 2007-10-29
Changed in mplayer:
status: Confirmed → In Progress
Mario Limonciello (superm1) wrote :

William, I haven't seen any activity here from you for a while. Do you mind if I grab this update? I've already started, and can probably have things ready in a few days (i'm adding a few bugs to get fixed in the process too).

I updated the upstream-ubuntu branch already, and i'm pushing my changes to the new "ubuntu" branch.

Mario Limonciello (superm1) wrote :

mplayer (2:1.0~rc2-0ubuntu1) hardy; urgency=low

  * New upstream version.
    - Packaging (LP: #150925)
    - MP3 Distortion (LP: #85751)
    - Aspect ratio fixes (LP: #103038, #153543)
    - Samba support (LP: #85052)
  * Move 01_default_config.dpatch into bzr.
  * Drop dpatch from build-depends and debian/rules
  * Add liblzo2-dev, libdvdnav-dev, libopenal-dev,
    libjack-dev, libtwolame-dev, libsvga1-dev to build dependencies.
  * debian/rules:
    - Build with radio interface support
    - Build with OpenAL, Jack audio support. (LP: #122042)
    - Let Xvid support be autodetected for proper linking.
    - Let Faac support be autodetected for proper linking.
    - Let fontconfig support be autodetected for proper linking.
    - Let LIVE555 support be autodetected for proper linking.
    - Drop DOCS/zh from dh_installdocs
    - Build with dvdnav support.
    - Adjust changelog that gets installed.
  * Add polish translation for .desktop file (LP: #93382)
  * Adjust configure script to properly link dbus-glib and pulse audio.
  * Disable joystick by default (LP: #75925)
  * Adjust configure script to call dvdnav-config properly.

 -- Mario Limonciello <email address hidden> Sat, 03 Nov 2007 09:26:21 -0400

Changed in mplayer:
status: In Progress → Fix Released
Martin Vysny (vyzivus) wrote :

I'd love to see mplayer 1.0rc2 in gutsy aswell - the h264 codec is faster (by 10% I guess), which makes 720p (even some 1080p!) h264 movies playable on average cpus

John Dong (jdong) wrote :

https://bugs.edge.launchpad.net/gutsy-backports/+bug/162768

Gutsy users, see this backport request.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers