Ubuntu

mousepad window takes a lot of time to close itself

Reported by Bremm on 2010-03-04
58
This bug affects 7 people
Affects Status Importance Assigned to Milestone
xfce4-settings
Unknown
Unknown
mousepad (Debian)
Fix Released
Unknown
mousepad (Ubuntu)
Medium
Unassigned
xfce4-settings (Ubuntu)
Undecided
Lionel Le Folgoc

Bug Description

Binary package hint: mousepad

Sometimes it happens with Geany and other GTK apps. But it's the 1st time I catched the error on console.

$ sudo mousepad /etc/apt/preferences

(mousepad:23257): Gtk-CRITICAL **: gtk_main_quit: assertion `main_loops != NULL' failed

It doesn't matter if I use sudo, gksudo or open the app as an ordinary user, by console, menu or alt+f2 shortcut. By the way, it does happen seldon (but since Ubuntu 9.04 or even before).

ProblemType: Bug
Architecture: amd64
Date: Thu Mar 4 00:32:00 2010
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: mousepad 0.2.16-2ubuntu2 [modified: usr/bin/mousepad]
ProcEnviron:
 LANGUAGE=pt_BR.UTF-8
 PATH=(custom, no user)
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-19.56-generic
SourcePackage: mousepad
Uname: Linux 2.6.31-19-generic x86_64

Related branches

Bremm (bremm) wrote :
Lionel Le Folgoc (mrpouit) wrote :

I can confirm that, when a clipman is running, or when I hit ctrl+c to copy some text, then clipman is very long to quit.

Changed in mousepad (Ubuntu):
status: New → Confirmed
Lionel Le Folgoc (mrpouit) wrote :

> then clipman is very long to quit.
mousepad, of course, not clipman

Changed in mousepad (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in mousepad (Debian):
status: Unknown → Confirmed
AsstZD (eskaer-spamsink) wrote :

Also happens on i386.

tags: added: karmic lucid
Forest (foresto) wrote :

Workaround until an updated xfce4-settings is available: Use parcellite instead of clipman.

Lionel Le Folgoc (mrpouit) wrote :

Should be fixed in oneiric.

Changed in xfce4-settings (Ubuntu):
assignee: nobody → Lionel Le Folgoc (mrpouit)
status: New → Fix Released
Forest (foresto) wrote :

I spoke too soon about the workaround. After upgrading to Natty, I found that the problem appears even without clipman. Looks like Natty users need an updated xfce4-settings after all.

daniele80 (daniele80) wrote :

As a temporary workaround,
I'm using leafpad as the default text editor on Xubuntu 11.04.

It's pretty identical to mousepad,
but I don't get this annoying bug.

Changed in mousepad (Debian):
status: Confirmed → Fix Released
Nikola M (nikolam) wrote :

I am using Xubuntu 10.04 LTS 64-bit
and this mousepad closing thing is not yet fixed oin any update.

Changed in mousepad (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mousepad - 0.3.0-1ubuntu1

---------------
mousepad (0.3.0-1ubuntu1) raring; urgency=low

  * Merge from Debian experimental, remaining Ubuntu change:
    - debian/control: drop xfprint4 recommendation, unneeded.
  * debian/patches/02_mru-on-save.patch: dropped, obsolete.
  * Bugs closed by this new release:
    - Mousepad Find dialog always opens with "Match case" checked lp: #714252
    - mousepad window takes a lot of time to close itself. lp: #531704

mousepad (0.3.0-1) experimental; urgency=low

  * New upstream release.
    - properly handle “file modified” status. closes: #508119
    - properly handle modified files when opening recent ones. closes: #587667
    - properly handle “search & replace”. closes: #612005
    - “match case” setting is remembered. closes: #524963
  * debian/patches:
    - 02_fix-typos-in-test, 01_fix-first-replace,
      00_resensitize-find-button dropped, included upstream.
  * debian/control:
    - drop build-dep on libxfcegui4-dev.
    - add build-dep on libgtksourceview2.0-dev and libdbus-glib-1-dev.
    - update debhelper build-dep to 9.
  * debian/compat bumped to 9.
  * debian/rules:
    - use debhelper 9 hardening support.
    - use --fail-missing in dh_install.
    - no need to ignore files in .pc anymore.
 -- Lionel Le Folgoc <email address hidden> Mon, 31 Dec 2012 14:24:28 +0100

Changed in mousepad (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.