recovery boot does not load OS

Bug #458060 reported by Daniel Stone on 2009-10-22
24
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mountall (Ubuntu)
Medium
Scott James Remnant (Canonical)
Karmic
Medium
Scott James Remnant (Canonical)

Bug Description

Binary package hint: grub

When loading from recovery from grub
then choose boot normally system does not load
system does not recognise user password and times out
does not load x or gnome-session
if option not not picked and grub choice recovery not picked system OS loads fine

Basically recovery option boot normally leads to a system maintenance prompt that will not load OS

ProblemType: Bug
Architecture: amd64
Date: Thu Oct 22 05:23:31 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: grub (not installed)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: grub
Uname: Linux 2.6.31-14-generic x86_64
XsessionErrors:
 (gnome-settings-daemon:1696): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:1799): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-panel:1786): Gdk-CRITICAL **: gdk_x11_colormap_foreign_new: assertion `GDK_IS_VISUAL (visual)' failed
 (nautilus:1787): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

Daniel Stone (danielstone) wrote :

this happens when option recovery from grub for current kernel is chosen
checked for broken packages worked fine
upgraded 14 packages mainly compiz but one was mountall? and all that seemed normal
updated grub boot loader no issue
then when option BOOT normal is chosen it comes to a system maintenance prompt that does not recognise user and password and also times out after 60 seconds
This is the Beta grub I believe??

Steve Langasek (vorlon) on 2009-10-22
affects: grub (Ubuntu) → mountall (Ubuntu)
Changed in mountall (Ubuntu):
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Scott James Remnant (scott)
milestone: none → ubuntu-9.10
Daniel Stone (danielstone) wrote :

bug 860830 is a similar issue that may have resulted from this fix

Daniel Stone (danielstone) wrote :

correction the bug 460830 is the issue that may be a result of this fix

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mountall - 1.0

---------------
mountall (1.0) karmic; urgency=low

  [ Kees Cook ]
  * Call out to restorecon after mounting tmpfs filesystems. LP: #456942.

  [ Johan Kiviniemi ]
  * Fix a bug introduced by the 0.2.6 change. In certain situations, we’d
    quit even though we’re still waiting for some filesystems to be
    mounted. LP: #456806.

  [ Scott James Remnant ]
  * Don't clear the splash screen when we're waiting for filesystems,
    instead just output following whatever else is there. In non-verbose
    mode this won't look any different, but it means we don't clear previous
    verbose mode text. LP: #458389.
  * Only update the "waiting for one or more mounts" text if there's actually
    a change in the set we're waiting for; this removes the need for a CLEAR
    this case anyway.
  * Don't say we're waiting for mounts we're, in fact, not waiting
    for. LP: #459859.
  * Stop mountall (normally) when entering recovery mode. LP: #458060.

  * Clean up source tarball. LP: #460348.

 -- Scott James Remnant <email address hidden> Mon, 26 Oct 2009 09:30:41 +0000

Changed in mountall (Ubuntu Karmic):
status: Fix Committed → Fix Released
emarkay (mrk) wrote :

If this is as wide ranging as the tertiary dupes indicate, fine, but, even after this afternoon's updates, it's COMPLETELY corrupted. I hope this does not make it into the final Karmic release!

Daniel Stone (danielstone) wrote :

I will test again in an hour but my sentiment is the same what it seems like is that x is not loaded properly in this because I can get to all the functions again but the first time that menu loads is has some printed on boot normally option

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers