Please merge mongodb 1.4.3-1 (universe) from Debian unstable (main)

Bug #589566 reported by Clint Byrum on 2010-06-04
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mongodb (Ubuntu)
Wishlist
Mathias Gug

Bug Description

Binary package hint: mongodb

only the upstart file must be merged, the rest of the delta has been incorporated upstream

Related branches

Changed in mongodb (Ubuntu):
status: New → In Progress
assignee: nobody → Clint Byrum (clint-fewbar)
Clint Byrum (clint-fewbar) wrote :

as the description states, only the upstart file needs to be re-added, and the package builds.

Tested the build on maverick with pbuilder, all looks well.

This patch is from the debian 1.4.3-1 -> 1.4.3-1ubuntu1, and just adds the upstart file.

Clint Byrum (clint-fewbar) wrote :

Here is the full patch from 1.2.2-1ubuntu1 to 1.4.3-1ubuntu1

Changed in mongodb (Ubuntu):
status: In Progress → Confirmed
assignee: Clint Byrum (clint-fewbar) → nobody
Clint Byrum (clint-fewbar) wrote :

Please note that this bug is related to a work item for an approved spec, and needs to be completed by alpha2:

https://blueprints.launchpad.net/ubuntu/+spec/server-maverick-cloud-datastores

Thanks.

Adam Nelson (adam-varud) wrote :

Is it possible to port this to lucid-updates as well? Mongo hasn't recommended using 1.2 for months now (even before 1.4 they were recommending 1.3 betas above 1.2.x).

Mathias Gug (mathiaz) on 2010-06-11
Changed in mongodb (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Mathias Gug (mathiaz)
importance: Undecided → Wishlist
Mathias Gug (mathiaz) wrote :

I've looked at the deb2maverick.patch and run into a couple of issues:

1. The upstart job is actually not included in the binary packages: there is a line in the debian/rules file that deletes the upstart file in the clean target.
2. There is a missing dependency on libmozjs.so:

  mathiaz@t-mongodb:~$ sudo start-stop-daemon --start --pidfile /var/run/mongodb.pid --make-pidfile --chuid mongodb --exec /usr/bin/mongod -- --dbpath /var/lib/mongodb --logpath /var/log/mongodb/mongodb.log --config /etc/mongodb.conf run/usr/bin/mongod: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory

I'd suggest to also install the binary packages in a base install to make sure they work correctly. Testing upgrade is also important by installing the current version from the archive and trying to upgrade to the newly build packages.

3. The latest version of Debian is 1.4.3-2 (a minor update).

Un-subscribing the sponsor team for now. Once the issues above have been addressed re-subscribe the sponsor team.

Changed in mongodb (Ubuntu):
status: In Progress → Triaged

On Jun 10, 2010, at 7:14 PM, Mathias Gug wrote:

> I've looked at the deb2maverick.patch and run into a couple of issues:
>
> 1. The upstart job is actually not included in the binary packages: there is a line in the debian/rules file that deletes the upstart file in the clean target.

The rules file does need to have the rm line removed, but it removes 'mongodb.upstart', while the file is mongodb-server.mongodb.upstart. The contents of the package as built by pbuilder:

clint@ubuntu:/var/cache/pbuilder/result$ dpkg -c mongodb-server_1.4.3-1ubuntu1_amd64.deb |grep init
drwxr-xr-x root/root 0 2010-06-04 13:10 ./etc/init/
-rw-r--r-- root/root 451 2010-06-04 11:29 ./etc/init/mongodb.conf
drwxr-xr-x root/root 0 2010-06-04 13:10 ./etc/init.d/
lrwxrwxrwx root/root 0 2010-06-04 13:10 ./etc/init.d/mongodb -> /lib/init/upstart-job

> 2. There is a missing dependency on libmozjs.so:
>
> mathiaz@t-mongodb:~$ sudo start-stop-daemon --start --pidfile
> /var/run/mongodb.pid --make-pidfile --chuid mongodb --exec
> /usr/bin/mongod -- --dbpath /var/lib/mongodb --logpath
> /var/log/mongodb/mongodb.log --config /etc/mongodb.conf
> run/usr/bin/mongod: error while loading shared libraries: libmozjs.so:
> cannot open shared object file: No such file or directory

Actually I believe the dependency needs to be on xulrunner-1.9.2. Not sure why dh_shlibdeps didn't pick that up.

>
> I'd suggest to also install the binary packages in a base install to
> make sure they work correctly. Testing upgrade is also important by
> installing the current version from the archive and trying to upgrade to
> the newly build packages.

Thanks for the tips!

Micah Gersten (micahg) wrote :

dh_shlibdeps can't find xulrunner libraries since they're not in the normal locations, you probably need a wrapper for the mongodb binary

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mongodb - 1:1.4.3-2ubuntu1

---------------
mongodb (1:1.4.3-2ubuntu1) maverick; urgency=low

  [ Clint Byrum ]
  * Merge from Debian unstable (LP: #589566)
    Remaining changes:
    - debian/mongodb-server.mongodb.upstart: add upstart job.

  [ Mathias Gug ]
  * debian/control:
    - Add dependency on xulrunner-1.9.2 since mongodb requires libmozjs.so.
    - Mark mongodb-{server,client,dev} as replacing mongodb to be able to
      upgrade from Lucid.

mongodb (1:1.4.3-2) unstable; urgency=low

  * [64bca3c] Updated copyright information as requested by Richard
    Kreuter

mongodb (1:1.4.3-1) unstable; urgency=low

  * New upstream version 1.4.3
  * Change log 1.4.3
    http://jira.mongodb.org/browse/SERVER/fixforversion/10156
  * added log to dirs to fix piuparts error

mongodb (1:1.4.2-3) unstable; urgency=low

  * Clean up debian/copyright
  * Fix various typos
  * Generally make lintian happy
  * Change section of mongodb-dev from database to libdevel (now matches
    archive override file)
  * Properly express copyrights
  * Fix typo in manpage
  * Remove unused lintian override.
  * Install usr/lib64 instead of usr/lib in mongodb-dev
  * updated watch file to actually work and report available
    stable releases

mongodb (1:1.4.2-2) unstable; urgency=low

  * Split single binary package into mongodb-server, mongodb-dev, and
    mongodb-clients.

mongodb (1:1.4.2-1) unstable; urgency=low

  * [4770a09] New upstream version 1.4.2
  * changelog for 1.4.1
    http://jira.mongodb.org/browse/SERVER/fixforversion/10144
  * changelog for 1.4.2
    http://jira.mongodb.org/browse/SERVER/fixforversion/10155

mongodb (1:1.4.0-2) unstable; urgency=low

  * added Roberto C. Sanchez as co-maintainer

mongodb (1:1.4.0-1) unstable; urgency=low

  * [0ca01a9] Imported Upstream version 1.4.0
  * [76c18ea] removed not needed files for debian
  * [c1578d9] merged changes from debianization from 1.2.4
  * full upstream changelog
    http://jira.mongodb.org/secure/IssueNavigator.jspa?requestId=10080
  * upstream release notes
    http://www.mongodb.org/display/DOCS/1.4+Release+Notes

mongodb (1:1.2.4-1) unstable; urgency=low

  * [c3803a1] Imported Upstream version 1.2.4
  * [ab4e0c8] removal of unnecessary files for Debian from upstream
    source
  * changelog for upstream at
    http://jira.mongodb.org/browse/SERVER/fixforversion/10130

mongodb (1:1.2.2-4) unstable; urgency=low

  * ensure removal of upstart script as upload of repacked source is failing

mongodb (1:1.2.2-3) unstable; urgency=low

  * [aced2f4] removed unnecessary dependency (Closes: #572873)
  * [ce78acd] Added call for tests to ensure correct build
    (Closes: #570106)

mongodb (1:1.2.2-2) unstable; urgency=low

  * [49232f8] removed upstart, it is buggy + not supported in Debian
    (Closes: #572812)
 -- Mathias Gug <email address hidden> Thu, 10 Jun 2010 15:25:34 -0400

Changed in mongodb (Ubuntu):
status: Triaged → Fix Released
Robert Osborne (rjo1970) wrote :

10.10 Beta Server install with only apt-get install mongodb (1:1.4.4-2)

after install, mongo still fails with:
mongo: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory

 @Robert Osborne
This is bug 557024

On 09/03/2010 12:43 PM, Robert Osborne wrote:
> 10.10 Beta Server install with only apt-get install mongodb (1:1.4.4-2)
>
> after install, mongo still fails with:
> mongo: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory
>

Clint Byrum (clint-fewbar) wrote :

Robert, you probably want bug #557024

https://bugs.launchpad.net/ubuntu/+source/mongodb/+bug/557024

It is awaiting sponsorship, please click the "this bug affects me" link at the top.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers