Ubuntu

mongo / mongod as packaged can't load libmozjs.so

Reported by a.strotmann on 2010-04-07
184
This bug affects 38 people
Affects Status Importance Assigned to Milestone
mongodb (Ubuntu)
High
Unassigned
Lucid
Undecided
Clint Byrum
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: mongodb

As a workaround, I created a symbolic link to the xulrunner version of this library in /usr/lib.
This stops working and has to be relinked whenever xulrunner gets updated to a new version number.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: mongodb 1:1.2.2-1
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
Architecture: amd64
Date: Tue Apr 6 21:57:33 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
ProcEnviron:
 LANG=en_CA.utf8
 SHELL=/bin/bash
SourcePackage: mongodb

== SRU REPORT ==

=== IMPACT ===

The impact of this bug could be moderate, as we are removing the rpath link to a specific release of libmozjs.so and instead providing a wrapper that will find the library for the user. However, no running code is changing, just the startup mechanism.

=== DEV STATUS ===
This has been resolved in Maverick and the current dev branch by writing a wrapper script that finds the currently installed libmozjs.so and adds it to LD_LIBRARY_PATH. This solution will work going forward as long as the library maintains ABI compatibility, but that is an issue for xulrunner, not mongodb, and will affect many other packages as well.

=== PATCH STATUS ===
Patch is in development. See merge proposals when complete.

=== TEST CASE ===

* Install Ubuntu Server 10.04 without applying updates
* Check that xulrunner-1.9.2 is at version 1.9.2.3+nobinonly-0ubuntu2
* Install package mongodb
* run 'mongo' -- should work
* Apply updates -- xulrunner-1.9.2 should be updated to 1.9.2.12+build1+nobinonly-0ubuntu0.10.04.1
* run 'mongo' -- this fails because the upstream version of xulrunner-1.9.2 has changed, and the rpath stored in these binaries is now invalid.

=== REGRESSION POTENTIAL ===

As the impact statement says, we are changing the startup behavior of the package in a fundamental way. However, the alternative is breaking the package every time a new version of xulrunner-1.9.2 is uploaded.

a.strotmann (andreas-strotmann) wrote :
Max Ischenko (ischenko) wrote :

Same for me.

$ find /usr/lib|grep libmozjs
/usr/lib/firefox-3.6.2/libmozjs.so
/usr/lib/xulrunner-devel-1.9.2.2/sdk/lib/libmozjs.so
/usr/lib/xulrunner-1.9.2.2/libmozjs.so

The following diff brings in support for xulrunner-1.9.2, and hard-codes the dependency on that version. Could we get this into Lucid?

diff --git a/debian/control b/debian/control
index 2aef1c3..b3ac29b 100644
--- a/debian/control
+++ b/debian/control
@@ -2,13 +2,13 @@ Source: mongodb
 Section: devel
 Priority: optional
 Maintainer: Richard Kreuter <richard@10gen.com>
-Build-Depends: debhelper (>= 7), libpcre3, libpcre3-dev, scons, xulrunner-dev, libboost1.35-dev | libboost1.37-dev | libboost1.38-dev | libboost1.40-dev, libboost-thread1.35-dev | libboost-thread1.37-dev | libboost-thread1.38-dev | libboost-thread1.40-dev, libboost-filesystem1.35-dev | libboost-filesystem1.37-dev | libboost-filesystem1.38-dev | libboost-filesystem1.40-dev, libboost-program-options1.35-dev | libboost-program-options1.37-dev | libboost-program-options1.38-dev | libboost-program-options1.40-dev, libboost-date-time1.35-dev | libboost-date-time1.37-dev | libboost-date-time1.38-dev | libboost-date-time1.40-dev, libpcap-dev, libreadline-dev
+Build-Depends: debhelper (>= 7), libpcre3, libpcre3-dev, scons, xulrunner-1.9.2-dev, libboost1.35-dev | libboost1.37-dev | libboost1.38-dev | libboost1.40-dev, libboost-thread1.35-dev | libboost-thread1.37-dev | libboost-thread1.38-dev | libboost-thread1.40-dev, libboost-filesystem1.35-dev | libboost-filesystem1.37-dev | libboost-filesystem1.38-dev | libboost-filesystem1.40-dev, libboost-program-options1.35-dev | libboost-program-options1.37-dev | libboost-program-options1.38-dev | libboost-program-options1.40-dev, libboost-date-time1.35-dev | libboost-date-time1.37-dev | libboost-date-time1.38-dev | libboost-date-time1.40-dev, libpcap-dev, libreadline-dev
 Standards-Version: 3.8.0
 Homepage: http://www.mongodb.org

 Package: mongodb
 Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, xulrunner-dev
+Depends: ${shlibs:Depends}, ${misc:Depends}, xulrunner-1.9.2
 Description: An object/document-oriented database
  MongoDB is a high-performance, open source, schema-free
  document-oriented data store that's easy to deploy, manage
diff --git a/buildscripts/hacks_ubuntu.py b/buildscripts/hacks_ubuntu.py
index 56649f8..480c622 100644
--- a/buildscripts/hacks_ubuntu.py
+++ b/buildscripts/hacks_ubuntu.py
@@ -39,7 +39,9 @@ def foundxulrunner( env , options ):
     env.Prepend( RPATH=[ libroot ] )

     env.Prepend( CPPPATH=[ incroot + "stable/" ,
- incroot + "unstable/" ] )
+ incroot + "unstable/" ,
+ incroot ] )
+ env.Prepend( CPPPATH=[ "/usr/include/nspr/" ] )

     env.Append( CPPDEFINES=[ "XULRUNNER" , "OLDJS" ] )
     if best.find( "1.9.0" ) >= 0 or best.endswith("1.9"):
diff --git a/scripting/engine_spidermonkey.h b/scripting/engine_spidermonkey.h
index a39d8fb..4e420de 100644
--- a/scripting/engine_spidermonkey.h
+++ b/scripting/engine_spidermonkey.h
@@ -42,6 +42,7 @@
 #endif

 #include "jsapi.h"
+#include "jsobj.h"
 #include "jsdate.h"
 #include "jsregexp.h"

tags: added: patch
Emmet Hikory (persia) on 2010-04-21
Changed in mongodb (Ubuntu):
assignee: nobody → Emmet Hikory (persia)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mongodb - 1:1.2.2-1ubuntu1

---------------
mongodb (1:1.2.2-1ubuntu1) lucid; urgency=low

  [ Richard M Kreuter ]
  * debian/mongodb.conf: uncomment lines to support upstart (LP: #564198)
  * debian/mongodb.upstart: only execute when available (LP: #564202)
  * buildscripts/hacks_ubuntu.py: include nspr in CPPPATH (LP: #557024)
  * scripting/engine_spidermonkey.h: include jsobj.h (LP: #557024)

  [ Emmet Hikory ]
  * Integrate patches (raw): expecting resync when Debian uses new upstream
 -- Emmet Hikory <email address hidden> Fri, 23 Apr 2010 00:43:22 +0900

Changed in mongodb (Ubuntu):
status: New → Fix Released
Stu (s-mitchell) wrote :

Is it possible to reopen this as xulrunner has been updated and as promised the package is broken

Changed in mongodb (Ubuntu):
status: Fix Released → Incomplete

It should just take a rebuild of the existing 1.2.2-1ubuntu1 package to pick up the new xulrunner version's dependency. Is there a way to force a new build in the Ubuntu autobuilders?

Sun Ning (classicning) wrote :

sorry, but I found the mongodb proxy `mongos` still cannot load libmozjs.so

Ken Barber (ken-bob) wrote :

Indeed - this is broken for me as well. I added /usr/lib/firefox-3.6.6 to /etc/ld.so.conf.d/mozilla.conf ... and ran ldconfig. But alas - an upgrade breaks all. Perhaps libmozjs needs to be seperated?

Changed in mongodb (Ubuntu):
status: Incomplete → Triaged
assignee: Emmet Hikory (persia) → nobody
importance: Undecided → Medium
Clint Byrum (clint-fewbar) wrote :

This bug's status was incorrectly marked as "Incomplete", which basically means the bug report needs more information.

Setting back to Triaged. I just verified it fails on Maverick:

clint@ubuntu:~$ mongos
mongos: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory

Setting importance to High as sharding is one of the key components of mongodb.

Changed in mongodb (Ubuntu):
importance: Medium → High
Clint Byrum (clint-fewbar) wrote :

A workaround, btw, is to set LD_LIBRARY_PATH=/usr/lib/xulrunner-`xulrunner --gre`

clint@ubuntu:~$ LD_LIBRARY_PATH=/usr/lib/xulrunner-`xulrunner --gre-version` mongos
error: no args for --configdb
clint@ubuntu:~$ mongos
mongos: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory
clint@ubuntu:~$

This can be added to /etc/init/mongodb.conf

Changed in mongodb (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Clint Byrum (clint-fewbar)
Changed in mongodb (Ubuntu):
status: In Progress → Confirmed
assignee: Clint Byrum (clint-fewbar) → nobody

  You should always use the version of xulrunner you want in the command
in case people are running multiple versions at once (i.e.
xulrunner-1.9.2 --gre-version)

On 08/12/2010 01:47 AM, Clint Byrum wrote:
> A workaround, btw, is to set
> LD_LIBRARY_PATH=/usr/lib/xulrunner-`xulrunner --gre`
>
> clint@ubuntu:~$ LD_LIBRARY_PATH=/usr/lib/xulrunner-`xulrunner --gre-version` mongos
> error: no args for --configdb
> clint@ubuntu:~$ mongos
> mongos: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory
> clint@ubuntu:~$
>
> This can be added to /etc/init/mongodb.conf
>

Clint Byrum (clint-fewbar) wrote :

Assigning back to me to fix rpath issues mentioned in merge proposal

Changed in mongodb (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Clint Byrum (clint-fewbar)
Clint Byrum (clint-fewbar) wrote :
Changed in mongodb (Ubuntu):
status: In Progress → Confirmed
assignee: Clint Byrum (clint-fewbar) → nobody
Kevin Fries (kevin-kevinfries) wrote :

I had the same problem on my Maverick. What I figured out was that /usr/lib/usr/lib/libmozjs.so was broken. It pointed to the wrong version of xul.

When I did:

# ls -l /usr/lib/libmozjs.so
lrwxrwxrwx 1 root root 38 2010-08-13 12:41 /usr/lib/libmozjs.so -> /usr/lib/xulrunner-1.9.2.8/libmozjs.so

Problem was that that file did not exist.

I then did:

# locate libmozjs.so
/usr/lib/libmozjs.so
/usr/lib/firefox-3.6.9/libmozjs.so
/usr/lib/sunbird/libmozjs.so
/usr/lib/thunderbird-3.1.3/libmozjs.so
/usr/lib/xulrunner-1.9.2.9/libmozjs.so

BINGO!!

xul is at 1.9.2.9, not 1.9.2.8. I manually fixed the link, and presto, everything seems to be working again.

Hope this helps somebody.
Kevin Fries

Daniel Thomas (drt24) wrote :

Thank you Kevin Fries.

An updated workaround is:
sudo ln -s /usr/lib/libmozjs.so /usr/lib/xulrunner-1.9.2.10/libmozjs.so

FGM (fgm) wrote :

You probably mean :

sudo ln -s /usr/lib/xulrunner-1.9.2.10/libmozjs.so /usr/lib/libmozjs.so

instead of the other way round ? This fixes the issue for me, at least.

Erik Gregg (ralree) wrote :

Here's what I did with the upstart script. It works. Mongo starts now with `sudo start mongodb`:

# Ubuntu upstart file at /etc/init/mongodb.conf

pre-start script
    mkdir -p /var/lib/mongodb/
    mkdir -p /var/log/mongodb/
end script

start on runlevel [2345]
stop on runlevel [06]

script
  ENABLE_MONGODB="yes"
  if [ -f /etc/default/mongodb ]; then . /etc/default/mongodb; fi
  export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib/xulrunner-`xulrunner-1.9.2 --gre-version`
  bname=`basename $0`
  if [ "$bname" = "xulwrapper" ] ; then
      echo xulwrapper must not be used to wrap itself. Paradox avoided.
      exit 1
  fi
  if [ "x$ENABLE_MONGODB" = "xyes" ]; then
    exec start-stop-daemon --start --quiet --chuid mongodb --exec /usr/bin/mongod -- --config /etc/mongodb.conf;
  fi
end script

temporarily solved my problems:
ln -s /usr/lib/xulrunner-1.9.2.10/libmozjs.so /usr/lib/libmozjs.so

Micah Gersten (micahg) on 2010-10-04
Changed in mongodb (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
status: Confirmed → In Progress
Micah Gersten (micahg) wrote :

Uploaded, merged, and pushed to bzr branch

Changed in mongodb (Ubuntu):
assignee: Micah Gersten (micahg) → nobody
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mongodb - 1:1.4.4-2ubuntu2

---------------
mongodb (1:1.4.4-2ubuntu2) maverick; urgency=low

  * Providing a wrapper for xulrunner (LP: #557024)
    - Moves all binaries under /usr/lib/mongodb
    - adds xulwrapper script to mongodb-clients
    - Sets up symlinks to xulwrapper in /usr/bin for all binaries in
      /usr/lib/mongodb
    - Adding dependency on xulrunner-1.9.2 to mongodb-clients as these
      binaries require the library as well.
    - patched SConstruct + buildscripts/hacks_ubuntu.py: removing rpath
      because wrapper is used
    - Removing debian/mongodb-server.lintian -- rpath is no longer used
    - Removing debian/mongodb-clients.lintian -- rpath is no longer used
 -- Clint Byrum <email address hidden> Tue, 05 Oct 2010 09:33:47 -0500

Changed in mongodb (Ubuntu):
status: Fix Committed → Fix Released
JanBrinkmann (jbrinkmann) wrote :

It seems to me that it is not fixed for lucid packages (sorry for the german locale):

jbrinkmann@h1714494:~$ sudo apt-cache policy mongodb
mongodb:
  Installiert: 1:1.2.2-1ubuntu1
  Kandidat: 1:1.2.2-1ubuntu1
  Versions-Tabelle:
 *** 1:1.2.2-1ubuntu1 0
        500 ftp://ftp.stratoserver.net/pub/linux/ubuntu/ lucid/universe Packages
        100 /var/lib/dpkg/status

jbrinkmann@h1714494:~$ mongo
mongo: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory

rockfx01 (tim-filmchicago) wrote :

@JanBrinkmann

Indeed, the same problem affects me on lucid as well.

mongodb 1:1.2.2-1ubuntu1

Clint Byrum (clint-fewbar) wrote :

Yes, this is going to happen every time xulrunner is updated in lucid unless the wrapper fix is applied.

I've nominated this fix for lucid, and we should also probably backport the latest version into lucid backports, as 1.2 is crazy old.

Still broken in Ubuntu Lucid, as also reported by JanBrinkmann, rockfx01 and Clint Byrum.

Status "fix released" seems to be wrong, but I don't seem to be able to change it. Could someone change the bug status to "New" or "Confirmed"?

## The bug

$ sudo mongod # just for testing, normally use: sudo service mongodb start
mongod: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory

## Bypass

$ sudo ln -s /usr/lib/xulrunner-1.9.2.12/libmozjs.so /usr/lib/libmozjs.so
$ sudo mongod # for testing only
Mon Nov 1 15:25:09 Mongo DB : starting : pid = 9901 port = 27017 dbpath =
/data/db/ master = 0 slave = 0 32-bit
[...]

## Testing

$ sudo service mongodb start
$ mongo
MongoDB shell version: 1.2.2
url: test
connecting to: test
type "exit" to exit
type "help" for help
>

Thus, Lucid (10.04) seems to have the libmozjs.so bug. The bypass given seems to work.

## Environment

$ dpkg --list xulrunner-1.9.2 xulrunner-1.9.2-dev mongodb
Gives: mongodb 1:1.2.2-1ubuntu1, xulrunner-1.9.2 1.9.2.12+build1+nobinonly-0ubuntu0.10.04.1, xulrunner-1.9.2-dev 1.9.2.12+build1+nobinonly-0ubuntu0.10.04.1
$ uname -m
i686

Could someone change the bug status to "New" or "Confirmed"? Thank you.

Micah Gersten (micahg) wrote :

This is nominated for Lucid and we will be uploading a fix for it soon.

Clint Byrum (clint-fewbar) wrote :

I am working on the SRU report and patch for Lucid.

Also this was actually released in Maverick, and so I've marked the maverick task as Fix Released accordingly.

Changed in mongodb (Ubuntu Lucid):
status: New → In Progress
assignee: nobody → Clint Byrum (clint-fewbar)
Changed in mongodb (Ubuntu Maverick):
status: New → Fix Released
description: updated

Thank you Clint for working on the fix (and correcting the status too).

Clint Byrum (clint-fewbar) wrote :

SRU diff is contained in the above merge proposal for lucid.

Changed in mongodb (Ubuntu Lucid):
status: In Progress → Confirmed
Stefano Rivera (stefanor) wrote :

Uploaded to lucid-proposed, pending SRU review

Changed in mongodb (Ubuntu Lucid):
assignee: Clint Byrum (clint-fewbar) → nobody
status: Confirmed → Fix Committed
Changed in mongodb (Ubuntu Lucid):
assignee: nobody → Clint Byrum (clint-fewbar)
status: Fix Committed → In Progress
Clint Byrum (clint-fewbar) wrote :

So, I don't see this in proposed yet. Is it waiting on archive upload approval?

Accepted mongodb into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in mongodb (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Andreas Beder (andreas-beder) wrote :

Just installed the mongodb package from lucid-proposed, now the error does not appear anymore !

Martin Pitt (pitti) on 2010-12-12
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mongodb - 1:1.2.2-1ubuntu1.1

---------------
mongodb (1:1.2.2-1ubuntu1.1) lucid-proposed; urgency=low

  [ Clint Byrum ]
  * debian/rules: install xulwrapper and symlinks to it (LP: #557024)
    - add quilt commands to patch out rpath
  * SConstruct, buildscripts/hacks_ubuntu.py: backported patch
    from maverick release 1:1.4.4-2ubuntu2 -- removes rpath

  [ Evan Broder ]
  * SConstruct: patching install to place executables in /usr/lib/mongodb
 -- Clint Byrum <email address hidden> Sat, 27 Nov 2010 01:25:28 -0800

Changed in mongodb (Ubuntu Lucid):
status: Fix Committed → Fix Released
wavded (wavded) wrote :

This issue is back in Natty.

wavded:~/ $ sudo apt-get install mongodb
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libboost-filesystem1.42.0 libboost-program-options1.42.0 libboost-system1.42.0
  libboost-thread1.42.0 libpcrecpp0 mongodb-clients mongodb-dev mongodb-server
The following NEW packages will be installed:
  libboost-filesystem1.42.0 libboost-program-options1.42.0 libboost-system1.42.0
  libboost-thread1.42.0 libpcrecpp0 mongodb mongodb-clients mongodb-dev mongodb-server
0 upgraded, 9 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/18.6 MB of archives.
After this operation, 47.9 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Selecting previously deselected package libpcrecpp0.
(Reading database ... 261700 files and directories currently installed.)
Unpacking libpcrecpp0 (from .../libpcrecpp0_8.12-3ubuntu2_i386.deb) ...
Selecting previously deselected package libboost-system1.42.0.
Unpacking libboost-system1.42.0 (from .../libboost-system1.42.0_1.42.0-4ubuntu2_i386.deb) ...
Selecting previously deselected package libboost-filesystem1.42.0.
Unpacking libboost-filesystem1.42.0 (from .../libboost-filesystem1.42.0_1.42.0-4ubuntu2_i386.deb) ...
Selecting previously deselected package libboost-program-options1.42.0.
Unpacking libboost-program-options1.42.0 (from .../libboost-program-options1.42.0_1.42.0-4ubuntu2_i386.deb) ...
Selecting previously deselected package libboost-thread1.42.0.
Unpacking libboost-thread1.42.0 (from .../libboost-thread1.42.0_1.42.0-4ubuntu2_i386.deb) ...
Selecting previously deselected package mongodb-clients.
Unpacking mongodb-clients (from .../mongodb-clients_1%3a1.6.3-1ubuntu2_i386.deb) ...
Selecting previously deselected package mongodb-server.
Unpacking mongodb-server (from .../mongodb-server_1%3a1.6.3-1ubuntu2_i386.deb) ...
Selecting previously deselected package mongodb-dev.
Unpacking mongodb-dev (from .../mongodb-dev_1%3a1.6.3-1ubuntu2_i386.deb) ...
Selecting previously deselected package mongodb.
Unpacking mongodb (from .../mongodb_1%3a1.6.3-1ubuntu2_i386.deb) ...
Processing triggers for man-db ...
Processing triggers for ureadahead ...
Setting up libpcrecpp0 (8.12-3ubuntu2) ...
Setting up libboost-system1.42.0 (1.42.0-4ubuntu2) ...
Setting up libboost-filesystem1.42.0 (1.42.0-4ubuntu2) ...
Setting up libboost-program-options1.42.0 (1.42.0-4ubuntu2) ...
Setting up libboost-thread1.42.0 (1.42.0-4ubuntu2) ...
Setting up mongodb-clients (1:1.6.3-1ubuntu2) ...
Setting up mongodb-server (1:1.6.3-1ubuntu2) ...
mongodb start/running, process 3117
Setting up mongodb-dev (1:1.6.3-1ubuntu2) ...
Setting up mongodb (1:1.6.3-1ubuntu2) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
wavded:~/ $ mongo
/usr/lib/mongodb/mongo: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory

Download full text (3.3 KiB)

Excerpts from wavded's message of Thu Jun 02 16:08:13 UTC 2011:
> This issue is back in Natty.
>
>
> wavded:~/ $ sudo apt-get install mongodb
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> The following extra packages will be installed:
> libboost-filesystem1.42.0 libboost-program-options1.42.0 libboost-system1.42.0
> libboost-thread1.42.0 libpcrecpp0 mongodb-clients mongodb-dev mongodb-server
> The following NEW packages will be installed:
> libboost-filesystem1.42.0 libboost-program-options1.42.0 libboost-system1.42.0
> libboost-thread1.42.0 libpcrecpp0 mongodb mongodb-clients mongodb-dev mongodb-server
> 0 upgraded, 9 newly installed, 0 to remove and 0 not upgraded.
> Need to get 0 B/18.6 MB of archives.
> After this operation, 47.9 MB of additional disk space will be used.
> Do you want to continue [Y/n]? y
> Selecting previously deselected package libpcrecpp0.
> (Reading database ... 261700 files and directories currently installed.)
> Unpacking libpcrecpp0 (from .../libpcrecpp0_8.12-3ubuntu2_i386.deb) ...
> Selecting previously deselected package libboost-system1.42.0.
> Unpacking libboost-system1.42.0 (from .../libboost-system1.42.0_1.42.0-4ubuntu2_i386.deb) ...
> Selecting previously deselected package libboost-filesystem1.42.0.
> Unpacking libboost-filesystem1.42.0 (from .../libboost-filesystem1.42.0_1.42.0-4ubuntu2_i386.deb) ...
> Selecting previously deselected package libboost-program-options1.42.0.
> Unpacking libboost-program-options1.42.0 (from .../libboost-program-options1.42.0_1.42.0-4ubuntu2_i386.deb) ...
> Selecting previously deselected package libboost-thread1.42.0.
> Unpacking libboost-thread1.42.0 (from .../libboost-thread1.42.0_1.42.0-4ubuntu2_i386.deb) ...
> Selecting previously deselected package mongodb-clients.
> Unpacking mongodb-clients (from .../mongodb-clients_1%3a1.6.3-1ubuntu2_i386.deb) ...
> Selecting previously deselected package mongodb-server.
> Unpacking mongodb-server (from .../mongodb-server_1%3a1.6.3-1ubuntu2_i386.deb) ...
> Selecting previously deselected package mongodb-dev.
> Unpacking mongodb-dev (from .../mongodb-dev_1%3a1.6.3-1ubuntu2_i386.deb) ...
> Selecting previously deselected package mongodb.
> Unpacking mongodb (from .../mongodb_1%3a1.6.3-1ubuntu2_i386.deb) ...
> Processing triggers for man-db ...
> Processing triggers for ureadahead ...
> Setting up libpcrecpp0 (8.12-3ubuntu2) ...
> Setting up libboost-system1.42.0 (1.42.0-4ubuntu2) ...
> Setting up libboost-filesystem1.42.0 (1.42.0-4ubuntu2) ...
> Setting up libboost-program-options1.42.0 (1.42.0-4ubuntu2) ...
> Setting up libboost-thread1.42.0 (1.42.0-4ubuntu2) ...
> Setting up mongodb-clients (1:1.6.3-1ubuntu2) ...
> Setting up mongodb-server (1:1.6.3-1ubuntu2) ...
> mongodb start/running, process 3117
> Setting up mongodb-dev (1:1.6.3-1ubuntu2) ...
> Setting up mongodb (1:1.6.3-1ubuntu2) ...
> Processing triggers for libc-bin ...
> ldconfig deferred processing now taking place
> wavded:~/ $ mongo
> /usr/lib/mongodb/mongo: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory

wavded, thanks for the update. Can you...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers