Ubuntu

MIT-Scheme will not launch

Reported by Brit Butler on 2008-04-15
40
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mit-scheme (Ubuntu)
Medium
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

Binary package hint: mit-scheme

On noticing that MIT-Scheme wouldn't launch from the applications I ran 'mit-scheme --edit' on the command line and received an error stating the 'Largest address does not fit in datum field of object.
Allocate less space or re-configure without HEAP_IN_LOW_MEMORY.'

1)
Description: Ubuntu 8.04
Release: 8.04

2)
mit-scheme:
  Installed: 7.7.90+20070205-1ubuntu1
  Candidate: 7.7.90+20070205-1ubuntu1
  Version table:
 *** 7.7.90+20070205-1ubuntu1 0
        500 http://us.archive.ubuntu.com hardy/universe Packages
        100 /var/lib/dpkg/status

3)
I expected an emacs-like X-Window to open so that I could hack me some Scheme.

4)
Instead my computer did nothing. It was sad. A brief google returned little on the problem and passing the argument '--heap 250' or even '--heap 10' did nothing at all. I also tested the upstream Debian Unstable package with no luck, done a purge reinstall, and will soon try the Gutsy and Etch builds.

PS: This has happened systematically on two separate systems for me (a desktop and laptop) after running some of the last week's updates. Of course, those are updates to dozens of packages. MIT-Scheme may well not be the source of the bug.

description: updated

Confirmed on Hardy with the same version as the reporter.

Changed in mit-scheme:
importance: Undecided → Medium
status: New → Confirmed
Sean McIntyre (s-mcintyre0) wrote :

Also confirmed on Hardy with:
mit-scheme (7.7.90+20070205-1ubuntu1)
libmcrypt4 (2.5.7-5) ...
libmhash2 (0.9.9-1) ...

Tried .deb from MIT/GNU Scheme website, and libmcrypt4 and libmhash2 were installed as dependencies. In that case, I got the following output (regardless of what value I gave to --heap):
"Requested allocation is too large.
Try again with a smaller argument to '--heap'."

mindcreek (mindcreek) wrote :

Same problem here.

Hardy 8.04

mit-scheme (7.7.90+20070205-1ubuntu1)
libmcrypt4 (2.5.7-5)
libmhash2 (0.9.9-1)

Same allocation error

Brit Butler (redline6561) wrote :

You all might be interested in knowing that I found a workaround. Just download the portable C sources for the latest MIT-Scheme from http://www.gnu.org/software/mit-scheme/ and follow the instructions to build. The compilation takes an hour or two but went off without a hitch and MIT-Scheme works fine. I couldn't get edwin to start but just dropped (require 'xscheme) in my .emacs and was right as rain.

Changed in mit-scheme:
status: Confirmed → Triaged

Chris Hanson, the package maintainer, explains the cause of this problem and gives a workaround at http://ubuntuforums.org/showthread.php?p=4868292

He attributes the problem to a clash between MIT-scheme's allocator and AppArmor.

magisu (magi-mail) wrote :

I can confirm this, hope it get repaired soon!

This is strongly related to this Wine bug: https://bugs.launchpad.net/wine/+bug/114025/

nitishp (nitishp) wrote :

Confirmed on 8.04: mit-scheme (7.7.90+20070205-1ubuntu1), libmcrypt4 (2.5.7-5), libmhash2 (0.9.9-1)
$ mit-scheme
Largest address does not fit in datum field of object.
Allocate less space or re-configure without HEAP_IN_LOW_MEMORY.

jan2ary (jan2ary) wrote :

Confirm this issue in 8.10.
I have no AppArmor and Wine installed.
Also I've installed libltdl3 from Debian's repository since it is not available in Ubuntu.

Thanks.
Andrey

magisu (magi-mail) wrote :

I have switched to Debian Lenny/Sid, It has DrScheme and PLT-Scheme, seems work!

Ai.Freedom (aifreedom) wrote :

Error Message:

Largest address does not fit in datum field of object.
Allocate less space or re-configure without HEAP_IN_LOW_MEMORY.

Solution:

sudo sysctl -w vm.mmap_min_addr=0

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mit-scheme - 7.7.90+20090107-1ubuntu1

---------------
mit-scheme (7.7.90+20090107-1ubuntu1) jaunty; urgency=low

  * Merge from debian unstable, remaining changes (LP: #288000, #217792):
    * Bootstrapping done via binary package from Debian unstable. See log
        entry for 7.7.90+20060906-3ubuntu1 for details.

 -- Evan Broder <email address hidden> Sun, 08 Mar 2009 00:46:17 -0500

Changed in mit-scheme:
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

Accepted mit-scheme into intrepid-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Noah Lavine (noah549) wrote :

The proposed package starts fine for me, and works in minimal testing.

Martin Pitt (pitti) on 2009-04-01
Changed in mit-scheme (Ubuntu Intrepid):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mit-scheme - 7.7.90+20090107-1ubuntu0.1

---------------
mit-scheme (7.7.90+20090107-1ubuntu0.1) intrepid-proposed; urgency=low

  * Merge from debian unstable, remaining changes (LP: #288000, #217792,
    #341832):
    * Bootstrapping done via binary package from Debian unstable. See log
        entry for 7.7.90+20060906-3ubuntu1 for details.

 -- Evan Broder <email address hidden> Thu, 12 Mar 2009 12:34:43 -0400

Changed in mit-scheme (Ubuntu Intrepid):
status: Fix Committed → Fix Released
Blaise Li (bli) wrote :

Is it possible to fix this bug for Ubuntu LTS also ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers