[FFe] Merge miro 2.0.3-1 (universe) from Debian unstable (main)

Bug #336029 reported by Brian Murray on 2009-02-28
98
This bug affects 7 people
Affects Status Importance Assigned to Milestone
miro (Ubuntu)
High
Unassigned

Bug Description

Hi,

I'd like to merge the new upstream release of miro, 2.0.2, from Debian. This release is mainly bugfixes but there are a couple of new sites supported so it will need an FFe. It also fixes installability due to python transition and moves to using the system's libtorrent-rasterbar.

Upstream changelog:

Changes and bug fixes in Miro 2.0.3 (pending)

    * Bug fixes
          o #11611 FIXED MiroUnicodeError?: text 'http://www.sermon.net/new' is not a unicode string (type:<type 'str'>)
          o #11607 FIXED Miro doesn't start playback of external files
          o #11618 FIXED Sidebar -> Copy url active for channel folder
          o #11615 FIXED After cmd-T toggle, and stop, playback menu items all active when video was not playing

    * Updates
          o updated translations from Launchpad on 3/11/2009

Changes and bug fixes in Miro 2.0.2 (March 7th, 2009)

    * Bug fixes
          o #11385 FIXED support for both libtorrent 0.13 and 0.14
          o #11413 FIXED single quote and double quote translation into Miro 2.0
          o #11423 FIXED Delete unused icon cache files
          o #11430 FIXED ValueError?: Multiple default guides!
          o #11432 FIXED EOFError loading config
          o #11456 FIXED 'Show More' crashes with UnicodeDecodeError?
          o #11460 FIXED Non-UTF8 locales break things
          o #11477 FIXED Miro shows no videos in a specific invalid feed
          o #11478 FIXED TypeError?: 'NoneType?' object is unsubscriptable
          o #11479 FIXED AttributeError?: 'AppController?' object has no attribute 'pausedDownloaders'
          o #11474 FIXED Can't process cookie expiration. Thanks Uwe!
          o #11022 FIXED "File name:" string is bold. Thanks Zach!
          o #11245 FIXED OPML import/export issues with non-ascii filenames
          o #11525 FIXED migrating folders with non-ascii characters
          o #11527 FIXED watched directories with non-ascii characters
          o #11528 FIXED playback fails for items in directories with non-ascii characters
          o #11544 FIXED handling for site type in subscriptions
          o #11546 FIXED pause all does not pause queued downloads
          o #11435 FIXED re-worked xine driver code so that it respects xine-driver property
          o #11522 FIXED error loading windll.winhttp
          o #11539 FIXED OSX crash when migrating to directory with non-ascii characters
          o #11557 FIXED non-ascii directory names are not displayed properly in Folder panel of preferences
          o #11575 FIXED non-ascii movies dir - startup check dir name mangled
          o #11554 FIXED first time startup search, non-ascii directory
          o #11560 FIXED crash when updated torrent that is in a folder with other files
          o #11568 FIXED Miro_Downloader Crashes on Launch
          o #11588 FIXED gstreamerrenderer passes "python" as executable for gst_extractor -- now uses sys.executable

    * Updates
          o updated translations synced from LaunchPad? on 3/04/2009
          o #11516 Updated to libtorrent 0.14.2

    * New Features
          o #11518 NEW Added metavid.org search support. Thanks Uwe!
          o #11461 NEW Added 5min.com search support. Thanks Uwe!
          o #3858 NEW Added EveryZing? search support. Thanks Uwe!
          o #11458 NEW Added vimeo.com url scraping support. Thanks Uwe!

Debian changelog:

miro (2.0.3-1ubuntu1) jaunty; urgency=low

  * Merge with Debian unstable (LP: #336029)
  * debian/pyversions: Change to "2.5-" to build for 2.6
  * debian/patches/70_python_version.patch: Add. Force python to 2.6
  * debian/control: Add python libtorrent bindings to build-deps to have these
    available for the build.

 -- Iain Lane <email address hidden> Tue, 17 Mar 2009 18:14:34 +0000

miro (2.0.3-1) unstable; urgency=low

  * New upstream release.
  * Standards-Version: 3.8.1 (no changes required).

 -- Uwe Hermann <email address hidden> Mon, 16 Mar 2009 15:29:35 +0100

miro (2.0.2-1) unstable; urgency=low

  * New upstream release.
  * debian/patches:
    + 40_feedparser.patch: Drop, merged upstream.
    + 50_miro_debug_fix.patch: Update.
    + 60_xine_driver.patch: Drop, fixed upstream in different form.
    + 90_manpage_fixes.patch: Drop, merged upstream.
    + debian/miro.xpm: Drop, merged upstream.
  * Build-depend/depend on libtorrent-rasterbar-dev/python-libtorrent (the
    Python bindings of libtorrent-rasterbar) instead of using the version
    shipped with Miro.
  * Switch to the new boost 1.37 packages as build-dependencies (needed for
    the Debian package of libtorrent-rasterbar anyway).
  * debian/60_boost_mt.patch: Add file, boost 1.37 only provides -mt variant.
  * Use common-install-prehook-arch target to remove the unneeded
    'test' directory from the 'miro' package (Closes: #516308).
  * Use LDFLAGS += "-Wl,--as-needed" to eliminate some unneeded dependencies.

 -- Uwe Hermann <email address hidden> Mon, 09 Mar 2009 12:46:19 +0100

Related branches

Changed in miro:
importance: Undecided → High
Daniel Hollocher (chogydan) wrote :

There is do to an upgrade to python2.6. This was announced on u-d-a mailing list, which can be subscribed to here: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel-announce

Here is the message FYI:
After the alpha-5 release we will update the python interpreter from 2.5.4 to
2.6.1. For about 24 hours you will no be able to cleanly update jaunty, until
some packages are rebuilt with python2.6. For a better upgrade experience during
 this time, please add the pythoneers PPA to your sources.list, which already
has the rebuilds available:

 deb http://ppa.launchpad.net/pythoneers/ppa/ubuntu jaunty main

Don't forget to remove this line after the change is complete; I will notice
u-d-a when the change is done for main. For universe you may experience
installability issues somewhat longer.

 Matthias

Changed in miro:
status: New → Invalid
Iain Lane (laney) wrote :

It's not actually invalid; we do need to work on this. Keeping open.

Changed in miro:
status: Invalid → Triaged
Iain Lane (laney) wrote :

FTBFS due to something in boost-python. http://orangesquash.org.uk/~laney/miro_ftbfs.txt

It looks like libboost-python-dev will force python 2.6 too anyway, and according to upstream miro is not compatible yet and still requires 2.5. So I'm a bit stuck.

Help required.

Iain Lane (laney) wrote :

Aha, I think I figured it out. We need to explicitly build-dep on python2.5-dev since boost.python pulls in 2.6 now. I'll fix this bug with Miro 2.0.2 which I am told is imminent.

Changed in miro:
assignee: nobody → laney
status: Triaged → In Progress
Iain Lane (laney) on 2009-03-10
description: updated

Thank you---I was about to file a report due to Miro not being installable due to the 2.6 move--I'm waiting until the release---

Thank You

Dean Loros
autocrosser at ubuntuforums

Daniel Hahler (blueyed) wrote :

2.0.3 has been released, which provides more bugfixes and might get included in this upload.

btw: I don't think adding support for new services is really an addition of new features, but rather extending an existing one.

Changelog for 2.0.3:
    * Bug fixes
          o #11611 FIXED MiroUnicodeError?: text 'http://www.sermon.net/new' is not a unicode string (type:<type 'str'>)
          o #11607 FIXED Miro doesn't start playback of external files
          o #11618 FIXED Sidebar -> Copy url active for channel folder
          o #11615 FIXED After cmd-T toggle, and stop, playback menu items all active when video was not playing

    * Updates
          o updated translations from Launchpad on 3/11/2009

sfan (sfan) wrote :

Version 2.0.3 is out!

Daniel Hahler (blueyed) wrote :

Iain, can you attach the debdiff you're about to use (with the python2.5 related fixes), or/and upload it to your PPA?
I'd like to try 2.0.3, but do not want to duplicate your work about fixing the build etc.
Thanks.

Iain Lane (laney) wrote :

Yes, here's[1] my debdiff. I posted a mail[0] to ubuntu-motu saying that it doesn't work though, so please feel free to help out if you have the time and inclination. Basically the public modules and extensions need to be made private and then miro taught to use them from the new location.

Grab me on IRC later if you want.

[0] https://lists.ubuntu.com/archives/ubuntu-motu/2009-March/005577.html
[1] https://lists.ubuntu.com/archives/ubuntu-motu/attachments/20090315/168560e5/attachment.diff

Any progress made on these last issues?

I tried poking around to see if I could make the changes suggested, but I couldn't quite get it working.

You may want to look at this:
http://forum.soft32.com/linux/Tool-support-private-modules-ftopict461105.html

In particular this bit:
> > How can I use the tools available — distutils, setuptools,
> > debhelper — to install these package-specific modules to a
> > package-specific location, such that all the programs in the
> > package will be able to find them?
>
> The easiest way, if the modules are relocatable (99% of them are) is
> to simply move them after installation.
>
> Otherwise, you can pass specific arguments to setup.py. That would
> be, python setup.py install --home=/usr/share/$package
> --install-purelib=.
>
> More information:
> http://www.python.org/doc/2.4/inst/search-path.html

Also of note:
https://develop.participatoryculture.org/trac/democracy/changeset/9131#file0

Is there a reason why this is specifically targeting 2.5? If the above works, it might be simpler to just make it work with 2.6?

I've tried making a version built against 2.6:
https://launchpad.net/~jbsnyder-fanplastic/+archive/ppa

xine playback seems to be flaky, but I'm not sure if that's due to using python2.6, or if that's just my system or it's pulseaudio.

LCID Fire (lcid-fire) wrote :

Thanks James for the build - at least for me it works without any problems so far - but I'm using gstreamer as a backend, not xine. The only playback problem once in a while is pulseaudio - but that issue is well known.

Iain Lane (laney) wrote :

Thanks for your feedback. I'll try and upload a python2.6 version and watch carefully for any regressions.

Iain Lane (laney) wrote :

OK, it actually seems to work! Uploading all the information for the FFe.

description: updated
Iain Lane (laney) wrote :
Iain Lane (laney) wrote :
Iain Lane (laney) wrote :
Iain Lane (laney) wrote :
Iain Lane (laney) on 2009-03-17
Changed in miro (Ubuntu):
assignee: laney → nobody
status: In Progress → New
Iain Lane (laney) wrote :

* Downloaded a video from a default feed and played it
* Added a video from my hard drive and played it
* Added a feed, downloaded a video and played it
* Indexed my home directory and played some videos that are added from it.

I found a crash which I think is related to pulse; when pulse starts outputting garbage audio and I have to kill it, miro often dies too. This seems to only happen with the xine backend though. All-in-all the performance with 2.6 seems better than I could have hoped it to be.

Please note that I do not and cannot rule out bugs relating to the python 2.6 support. If this proves too unstable then I will try to move back to 2.5. Wider testing will prove whether this is necessary.

For me it seems to work pretty well. Using gstreamer seems to be quite stable. With xine, skipping around within the video seems to sometimes result in a hang that may be related to audio (keeps playing video for a bit, with no audio, then hangs)

Since I've had behavior similar to this appear with earlier versions of Miro, I'm not sure if this is due to a bug with pulseaudio, xine, or Miro. I also don't get much in the logs, so I'm not sure what the best approach might be to get more info without just digging into the code.

I presume the reason that xine is the default renderer is the need to potentially install the good/bad/ugly codecs, is this true? I'm not suggesting that any issues be ignored, just curious why the default is set to xine.

LCID Fire (lcid-fire) wrote :

Iain: I have had a few crashes with miro now but they all seem to be related to pulseaudio. Don't know whether it would make sense to make the backend interfaces more robust in miro.

James: As long as I've been using Ubuntu (few years) the Xine backend has supported far more codecs than gstreamer and was much more stable. With jaunty xine is so far surprisingly unstable and has quite a few regressions - which actually doesn't bother me too much since gstreamer seems to have improved quite a bit.
In general I agree - I'd say before the beta launch there should be a decision whether xine is still stable enough to be the default option for the release.

Iain Lane (laney) wrote :

I appreciate your feedback, and will definitely assess this as the release progresses. Once pulseaudio attains stability we can look into whether the default should be switched; it may be the case that once whatever bug is fixed then the problems go away.

Rashad Tatum (rmtatum) wrote :

James,

I tried your packages but I received the output at the following webpage when trying to run Miro:

http://rafb.net/p/kdJ3D840.html

Rashad,
Most of that should be innocuous. The last part is where it dies:
Traceback (most recent call last):
  File "/usr/bin/miro.real", line 261, in <module>
    startapp()
  File "/usr/bin/miro.real", line 206, in startapp
    startup(props_to_set)
  File "/usr/bin/miro.real", line 93, in startup
    _temp = __import__(frontend, globals(), locals(), ['application'], -1)
ImportError: No module named widgets

It looks like it isn't finding the widgets...

What platform and version of Ubuntu are you running? I did try installing this on a fresh i386 machine, and my main amd64 box seems OK.

Iain Lane (laney) wrote :

Here's an updated debdiff. I've expanded the changelog and fixed debian/pyversions since last time.

Iain Lane (laney) wrote :
Download full text (6.0 KiB)

I am using the amd64 version of Ubuntu Jaunty.

On Tue, Mar 17, 2009 at 8:55 PM, James Snyder <email address hidden>wrote:

> Rashad,
> Most of that should be innocuous. The last part is where it dies:
> Traceback (most recent call last):
> File "/usr/bin/miro.real", line 261, in <module>
> startapp()
> File "/usr/bin/miro.real", line 206, in startapp
> startup(props_to_set)
> File "/usr/bin/miro.real", line 93, in startup
> _temp = __import__(frontend, globals(), locals(), ['application'], -1)
> ImportError: No module named widgets
>
> It looks like it isn't finding the widgets...
>
> What platform and version of Ubuntu are you running? I did try
> installing this on a fresh i386 machine, and my main amd64 box seems OK.
>
> --
> [FFe] Merge miro 2.0.3-1 (universe) from Debian unstable (main)
> https://bugs.launchpad.net/bugs/336029
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “miro” source package in Ubuntu: New
>
> Bug description:
> Hi,
>
> I'd like to merge the new upstream release of miro, 2.0.2, from Debian.
> This release is mainly bugfixes but there are a couple of new sites
> supported so it will need an FFe. It also fixes installability due to python
> transition and moves to using the system's libtorrent-rasterbar.
>
> Upstream changelog:
>
> Changes and bug fixes in Miro 2.0.3 (pending)
>
> * Bug fixes
> o #11611 FIXED MiroUnicodeError?: text 'http://www.sermon.net/new'
> is not a unicode string (type:<type 'str'>)
> o #11607 FIXED Miro doesn't start playback of external files
> o #11618 FIXED Sidebar -> Copy url active for channel folder
> o #11615 FIXED After cmd-T toggle, and stop, playback menu items
> all active when video was not playing
>
> * Updates
> o updated translations from Launchpad on 3/11/2009
>
> Changes and bug fixes in Miro 2.0.2 (March 7th, 2009)
>
> * Bug fixes
> o #11385 FIXED support for both libtorrent 0.13 and 0.14
> o #11413 FIXED single quote and double quote translation into Miro
> 2.0
> o #11423 FIXED Delete unused icon cache files
> o #11430 FIXED ValueError?: Multiple default guides!
> o #11432 FIXED EOFError loading config
> o #11456 FIXED 'Show More' crashes with UnicodeDecodeError?
> o #11460 FIXED Non-UTF8 locales break things
> o #11477 FIXED Miro shows no videos in a specific invalid feed
> o #11478 FIXED TypeError?: 'NoneType?' object is unsubscriptable
> o #11479 FIXED AttributeError?: 'AppController?' object has no
> attribute 'pausedDownloaders'
> o #11474 FIXED Can't process cookie expiration. Thanks Uwe!
> o #11022 FIXED "File name:" string is bold. Thanks Zach!
> o #11245 FIXED OPML import/export issues with non-ascii filenames
> o #11525 FIXED migrating folders with non-ascii characters
> o #11527 FIXED watched directories with non-ascii characters
> o #11528 FIXED playback fails for items in directories with
> non-ascii characters
> o #11544 FIXED handling for site type in subscriptions
> o #11546 FIXE...

Read more...

The james-snijder packages work on my jaunty-64 box using the gstreamer output.
Some video's don't play (they halt miro until I do killall pulseaudio), but those video's do the exact same thing when played with totem. So it's just the normal pulseaudio nightmare that Jaunty is turning into.

I haven't seen any miro specific bugs yet using those packages and I'm quite the power-user.

Oh and the xine output has even more issues with pulseaudio. It won't play anything and halt miro, until I killall pulseaudio again. (it seems to auto-respawn, is there a way to rid my system of pulseaudio? is it wise? i can only assume there are already zillions of bugs concerning pulseaudio .. are they focused, does anybody know wether or not they will sort this out before release? it was sort of working in intrepid, unlike in hardy)

Rashad Tatum (rmtatum) wrote :
Download full text (5.9 KiB)

I reinstalled Kubuntu Jaunty and the packages worked fine. I think my
python install may have been corrupted.

On Wed, Mar 18, 2009 at 6:23 PM, Ralf Nieuwenhuijsen <
<email address hidden>> wrote:

> Oh and the xine output has even more issues with pulseaudio. It won't
> play anything and halt miro, until I killall pulseaudio again. (it seems
> to auto-respawn, is there a way to rid my system of pulseaudio? is it
> wise? i can only assume there are already zillions of bugs concerning
> pulseaudio .. are they focused, does anybody know wether or not they
> will sort this out before release? it was sort of working in intrepid,
> unlike in hardy)
>
> --
> [FFe] Merge miro 2.0.3-1 (universe) from Debian unstable (main)
> https://bugs.launchpad.net/bugs/336029
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “miro” source package in Ubuntu: New
>
> Bug description:
> Hi,
>
> I'd like to merge the new upstream release of miro, 2.0.2, from Debian.
> This release is mainly bugfixes but there are a couple of new sites
> supported so it will need an FFe. It also fixes installability due to python
> transition and moves to using the system's libtorrent-rasterbar.
>
> Upstream changelog:
>
> Changes and bug fixes in Miro 2.0.3 (pending)
>
> * Bug fixes
> o #11611 FIXED MiroUnicodeError?: text 'http://www.sermon.net/new'
> is not a unicode string (type:<type 'str'>)
> o #11607 FIXED Miro doesn't start playback of external files
> o #11618 FIXED Sidebar -> Copy url active for channel folder
> o #11615 FIXED After cmd-T toggle, and stop, playback menu items
> all active when video was not playing
>
> * Updates
> o updated translations from Launchpad on 3/11/2009
>
> Changes and bug fixes in Miro 2.0.2 (March 7th, 2009)
>
> * Bug fixes
> o #11385 FIXED support for both libtorrent 0.13 and 0.14
> o #11413 FIXED single quote and double quote translation into Miro
> 2.0
> o #11423 FIXED Delete unused icon cache files
> o #11430 FIXED ValueError?: Multiple default guides!
> o #11432 FIXED EOFError loading config
> o #11456 FIXED 'Show More' crashes with UnicodeDecodeError?
> o #11460 FIXED Non-UTF8 locales break things
> o #11477 FIXED Miro shows no videos in a specific invalid feed
> o #11478 FIXED TypeError?: 'NoneType?' object is unsubscriptable
> o #11479 FIXED AttributeError?: 'AppController?' object has no
> attribute 'pausedDownloaders'
> o #11474 FIXED Can't process cookie expiration. Thanks Uwe!
> o #11022 FIXED "File name:" string is bold. Thanks Zach!
> o #11245 FIXED OPML import/export issues with non-ascii filenames
> o #11525 FIXED migrating folders with non-ascii characters
> o #11527 FIXED watched directories with non-ascii characters
> o #11528 FIXED playback fails for items in directories with
> non-ascii characters
> o #11544 FIXED handling for site type in subscriptions
> o #11546 FIXED pause all does not pause queued downloads
> o #11435 FIXED re-worked xine dri...

Read more...

Daniel Hahler (blueyed) wrote :

Thanks Iain!

For anybody wanting to test it, I've just uploaded the package (built from the debdiff posted by Iain) to my PPA:
https://edge.launchpad.net/~blueyed/+archive/ppa

For me, there are several tracebacks like the following on startup (in the console):
gtcache.gettext: not initialized for string "Ok"
  File "/usr/bin/miro.real", line 47, in <module>
    import miro.storedatabase
  File "/var/lib/python-support/python2.6/miro/storedatabase.py", line 62, in <module>
    from miro import databaseupgrade
  File "/var/lib/python-support/python2.6/miro/databaseupgrade.py", line 40, in <module>
    from miro import schema
  File "/var/lib/python-support/python2.6/miro/schema.py", line 257, in <module>
    from miro.downloader import RemoteDownloader, HTTPAuthPassword
  File "/var/lib/python-support/python2.6/miro/downloader.py", line 34, in <module>
    from miro.dl_daemon import daemon, command
  File "/var/lib/python-support/python2.6/miro/dl_daemon/daemon.py", line 45, in <module>
    from miro.httpclient import ConnectionHandler
  File "/var/lib/python-support/python2.6/miro/httpclient.py", line 53, in <module>
    from miro import httpauth
  File "/var/lib/python-support/python2.6/miro/httpauth.py", line 30, in <module>
    from miro import dialogs
  File "/var/lib/python-support/python2.6/miro/dialogs.py", line 83, in <module>
    BUTTON_OK = DialogButton(_("Ok"))
  File "/var/lib/python-support/python2.6/miro/gtcache.py", line 96, in gettext
    traceback.print_stack()

Apart from that, it's just as flaky as the previous version (no sound when starting a video sometimes and then halts and needs to be killed).

Nathan Handler (nhandler) wrote :

Based on the relatively positive test feedback, and the results of my own review, I am giving this FFe request its first ACK. However, please monitor this package to ensure that no other issues crop up.

Scott Kitterman (kitterman) wrote :

Ack #2. Approved. Clealry there is more work to do on miro, but this is a step in the right direction.

Changed in miro:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package miro - 2.0.3-1ubuntu1

---------------
miro (2.0.3-1ubuntu1) jaunty; urgency=low

  * Merge with Debian unstable (LP: #336029)
  * debian/pyversions: Change to "2.6" to build for 2.6
  * debian/patches/70_python_version.patch: Add. Look in python 2.6 include
    directory during the build.
  * debian/control: Add python libtorrent bindings to build-deps to have these
    available for the build.
  * debian/control: Change python2.5 build-dep to python2.6

 -- Iain Lane <email address hidden> Tue, 17 Mar 2009 18:14:34 +0000

Changed in miro:
status: Confirmed → Fix Released
Iain Lane (laney) wrote :

Thanks for your feedback guys. Please file separate bugs for any more issues; uploaded now.

Changed in miro (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released

I filed a crash, but it was considered as a duplicate of bug #145413 !

Daniel Hahler (blueyed) wrote :

Fred, why shouldn't this happen? I've seen that this bug is marked "Incomplete", so you might want to help triaging it.
Apart from that, you could un-duplicate it yourself (but I don't see why it should not become a duplicate - without looking closer at those bugs though).

FWIW, now running the 2.0.3 package that Iain got into the mainline (automatically upgraded from my PPA). Everything seems to be working quite well on gstreamer at the moment, no major crashes or weird issues with video as of late.

Xine still appears to be wonky though if I switch to that.

Thanks for getting things merged Iain! :-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers