Feisty Fawn installer freezes at 88%

Bug #99004 reported by Erik Penninga on 2007-03-30
30
Affects Status Importance Assigned to Milestone
migration-assistant (Ubuntu)
Undecided
Evan

Bug Description

When installing Feisty Fawn (Beta - 22 March 2007) from the live CD, the installer freezes at 88%. At this point the installer is importing document and settings.

No profiles where selected to import (from Dapper 6.06.1 LTS), even when selected one profile from one user (Firefox settings) the installer freezed at 88%.
The install could not be finished.

The same behaviour was seen after a restart.

pirast (pirast) wrote :

We will need the log files, specifically /var/log/syslog and /var/log/installer/debug, in order to find the true cause of the error for them. These can be obtained by running the installer with the --debug option. Instructions for doing so can be found here:
https://wiki.ubuntu.com/DebuggingUbiquity/AttachingLogs

Changed in migration-assistant:
status: Unconfirmed → Needs Info
Erik Penninga (penninga) wrote :

As requested the required log files after running "ubiquity --debug":

Some additional information:
1.) CD integrity checked - 0 checksums failed
2.) When selecting /dev/hda13 as root to install, ubiquity returns "Too small size <OK>" - while it has 4926 MB available.
3.) During the installation process only a terminal was opened and ubiquity.

medspx (mederic-ribreux) wrote :

Hello,

I've got the same problem...
I found that the problem comes from ubiquity which was not able to go into /dev/hda1 (don't ask me why). Solved the problem by manually mount /dev/hda1.
My configuration was:
/dev/hda1 => / for Ubuntu Edgy.
/dev/hda11 => / for Ubuntu Feisty (new installation)

I can confirm this. I used the text- installer to install Ubuntu then.

Changed in migration-assistant:
status: Needs Info → Confirmed
Evan (ev) on 2007-04-01
Changed in migration-assistant:
assignee: nobody → evand
Evan (ev) wrote :

I believe this was fixed in Ubiquity 1.4.5 by Colin:

ubiquity (1.4.5) feisty; urgency=low

  * Handle migration-assistant/failed-unmount being asked from ma-apply.

Can one of you boot the live CD and run `sudo apt-get update && sudo apt-get install ubiquity` in a console to make sure you're using the absolute latest version of the installer. From there could you run the installer again using the --debug option (`sudo ubiquity --debug` in a console), and attach /var/log/installer/debug and /var/log/syslog to this bug report. Thanks!

Erik Penninga (penninga) wrote :

As per above, I've followed the instructions. Unfortunately Ubiquity stopped at the same point (88%), but this time showing an error message (see attached). When I pressed "Continue" the same error message was shown again. When I pressed "Go Back", Ubiquity quit. Also included the required logfiles.

Evan (ev) wrote :

migration-assistant (0.4.5) feisty; urgency=low

  * Proper grep for mounted devices. (LP: #99004)

 -- Evan Dandrea <email address hidden> Thu, 5 Apr 2007 02:27:15 -0400

Changed in migration-assistant:
status: Confirmed → Fix Committed
Colin Watson (cjwatson) wrote :

Uploaded.

Changed in migration-assistant:
status: Fix Committed → Fix Released
Erik Penninga (penninga) wrote :

I saw that Ubiquity version 1.4.7 was released. Once more followed the instructions and installed Feisty Fawn without any problems. The data migrated perfectly from the Dapper profile. Nice work thanks!

I've included the required logfiles.

Evan (ev) wrote :

I'm very glad to hear it!

Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers