jaunty: Migration-Assistant always comes on when os is present

Bug #339898 reported by Dave Morley on 2009-03-09
4
Affects Status Importance Assigned to Milestone
migration-assistant (Ubuntu)
Medium
Evan
Jaunty
Medium
Evan

Bug Description

Binary package hint: migration-assistant

RELEASE: Jaunty
CD/DVD VARIANT: Ubuntu i386 desktop cd
ISO BUILD: 20090309

SYMPTOMS: Migration-Assistant always appears even when you do a whole drive install if there is a previous os on the drive. This may make some people believe that their docs etc will be transferred across when in fact they aren't.

CAUSE: Unknown

STEPS TO REPRODUCE:
1/ Have a drive with a previously installed os on
2/ Install Ubuntu select whole drive
3/ See m-a window appear in the install details
4/ M-a is only meant to work from an install side by side install not whole drive.

Steve Langasek (vorlon) on 2009-03-25
Changed in migration-assistant:
importance: Undecided → Medium
status: New → Confirmed
JD (jacobdorne) wrote :

Similar bug:
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/349334

Screenshot attached.
sda3 is going to be formatted in the screenshot.

Changed in migration-assistant (Ubuntu Jaunty):
assignee: nobody → evand
Colin Watson (cjwatson) wrote :

This was fixed yesterday, but between Evan and me we forgot to close the bug.

migration-assistant (0.6.4) jaunty; urgency=low

  * If there are no items to import, don't bother asking the question.
    This supports a change to ubiquity to not always show the migration-
    assistant page.

 -- Evan Dandrea <email address hidden> Thu, 09 Apr 2009 10:34:46 +0100

ubiquity (1.12.6) jaunty; urgency=low

  [ Colin Watson ]
  * GTK frontend:
    - Copy-and-paste gdm-signal from powermanagement-interface, since that
      package is no longer in main and is slated to go away. In future we
      ought to be able to use gnome-session D-BUS calls or similar for this
      work (LP: #357101).
  * Use gksudo --preserve-env / sudo -E so that we can check DESKTOP_SESSION
    from the GTK frontend, and use other desktop environment variables in
    future.
  * Try a couple of different locations for NetworkManager's init script
    (LP: #356813).
  * Sync with console-setup 1.28ubuntu8: treat the Kazakhstan layout (kz) as
    non-Latin (LP: #356816).
  * Work around a debconf bug which broke the default time zone for some
    countries: REGISTER does not appear to give a newly-registered question
    the same default as the question associated with its template, unless we
    also RESET it, so do that (LP: #356794).
  * Update translations from Launchpad.
  * Automatic update of included source packages: base-installer
    1.98ubuntu6, console-setup 1.28ubuntu8, flash-kernel 2.13ubuntu6,
    partman-auto 84ubuntu3, partman-base 129ubuntu7, partman-target
    58ubuntu7, user-setup 1.23ubuntu18.

  [ Evan Dandrea ]
  * Provide translation support for the format warning on the automatic
    partitioning page, and make it less tied to English grammar. Thanks
    Timo Jyrinki (LP: #356333).
  * Only show the migration-assistant page if we have items we can
    import.
  * Don't let the time zone map image grow larger than the original.
  * Automatic update of included source packages: migration-assistant
    0.6.4.

 -- Evan Dandrea <email address hidden> Thu, 09 Apr 2009 14:46:10 +0100

Changed in migration-assistant (Ubuntu Jaunty):
status: Confirmed → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments