Kubuntu - setting "Country or region" is ignored by applications

Bug #366285 reported by Tathosh on 2009-04-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
meta-kde4 (Ubuntu)
Undecided
Unassigned
speedcrunch (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

I have installed Kubuntu 9.04 64 bit with English language, but I want to have locale settings for Slovakia (so I get Slovak number and date formats). So I have changed "Country or region" setting to Slovakia. At first sight it seems, that everything is correctly set (in preview I see correct example of number and date formats), but at the end these setting are ignored by the applications. For example when I run OpenOffice.org Spreadsheet and I enter the date "31.12.2008" (which is Slovak date format), Spreadseet does not recognise this as date. Another example is when I enter 2,8 (Slovak decimal separator is ",") in SpeedCrunch, it is not recognised as a number. SpeedCrunch recognises only 2.8 as a number ("." is not Slovak decimal separator). Also when I enter decimal number by keyboard's numpad, it is using dot as decimal separator (again this is not correct).

So applications are using English regional setting despite the fact that I have set Slovakia in "Country or region" settings.

Thanks for your help.

affects: ubuntu → kdebase-workspace (Ubuntu)
affects: kdebase-workspace (Ubuntu) → openoffice.org (Ubuntu)
Chris Cheney (ccheney) wrote :

What is the output of 'locale' in a terminal?

Changed in openoffice.org (Ubuntu):
status: New → Incomplete
Tathosh (fedurco) wrote :

Hello,

the output of locale in terminal is:

LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

So it seems that regional settings in "Country or region" are not recognised by system.

I tried to edit /etc/default/locale file where I entered following lines (in order to get Slovak settings):

LANG="en_US.UTF-8"
LC_CTYPE="sk_SK.UTF-8"
LC_NUMERIC="sk_SK.UTF-8"
LC_TIME="sk_SK.UTF-8"
LC_COLLATE="sk_SK.UTF-8"
LC_MONETARY="sk_SK.UTF-8"
LC_PAPER="sk_SK.UTF-8"
LC_NAME="sk_SK.UTF-8"
LC_ADDRESS="sk_SK.UTF-8"
LC_TELEPHONE="sk_SK.UTF-8"
LC_MEASUREMENT="sk_SK.UTF-8"
LC_IDENTIFICATION="sk_SK.UTF-8"

and the result was that OpenOffice.org Spreadsheet recognised coma as decimal separator (",") and also it typed coma when I pressed decimal separator on keyboard's numpad. But SpeedCrunch did not recognised coma as decimal separator (I had to use dot ".") and also when I pressed decimal separator on keyboard's numpad, the dot showed in SpeedCrunch.

Chris Cheney (ccheney) on 2009-09-08
Changed in openoffice.org (Ubuntu):
status: Incomplete → Invalid
affects: openoffice.org (Ubuntu) → meta-kde4 (Ubuntu)
Changed in meta-kde4 (Ubuntu):
status: Invalid → New
dotancohen (dotancohen) wrote :

This upstream bug may be relevant:
https://bugs.kde.org/show_bug.cgi?id=197727

Felix Krull (fkrull) wrote :

Original problem is a (persisting) KDE issue; can't reproduce the later issue (after manually tweaking /etc/default/locale).

Changed in speedcrunch (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.