compiz crashed with SIGSEGV in intel_miptree_release() (Fixed in 8.0.3)

Bug #952896 reported by Benoit des Ligneris on 2012-03-12
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mesa
Unknown
Unknown
mesa (Ubuntu)
High
Unassigned
Precise
High
Unassigned
Quantal
High
Unassigned

Bug Description

Just connected a second screen. It maybe related.

Then compiz crashed and popup to report the crash.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity 5.4.0-0ubuntu2
Uname: Linux 3.3.0-030300rc5-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Mon Mar 12 07:00:44 2012
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111011)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=fr_CA:fr
 LANG=fr_CA.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fd728d805a9 <intel_miptree_release+9>: mov (%rdi),%rcx
 PC (0x7fd728d805a9) ok
 source "(%rdi)" (0x00000220) not located in a known VMA region (needed readable region)!
 destination "%rcx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 intel_miptree_release () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
 intel_update_renderbuffers () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
 intelSetTexBuffer2 () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
 TfpTexture::bindPixmapToTexture(unsigned long, int, int, int) () from /usr/lib/compiz/libopengl.so
 boost::detail::function::function_invoker4<GLTexture::List (*)(unsigned long, int, int, int), GLTexture::List, unsigned long, int, int, int>::invoke(boost::detail::function::function_buffer&, unsigned long, int, int, int) () from /usr/lib/compiz/libopengl.so
Title: compiz crashed with SIGSEGV in intel_miptree_release()
UpgradeStatus: Upgraded to precise on 2012-03-11 (1 days ago)
UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare

Revision history for this message
Benoit des Ligneris (benoit-des-ligneris) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 intel_miptree_release (mt=0x220) at intel_mipmap_tree.c:290
 intel_process_dri2_buffer_with_separate_stencil (buffer_name=0x7fd728e02d90 "dri2 hiz buffer", rb=0x2ba7f00, buffer=<optimized out>, intel=0x7fd735f3f040, drawable=<optimized out>) at intel_context.c:1267
 intel_update_renderbuffers (context=<optimized out>, drawable=0x36945e0) at intel_context.c:361
 intelSetTexBuffer2 (pDRICtx=0x137daa0, target=3553, texture_format=8410, dPriv=0x36945e0) at intel_tex_image.c:335
 PluginClassHandler<CompositeWindow, CompWindow, 4>::initializeIndex(CompWindow*) () from /tmp/tmpcta8bv/usr/lib/compiz/libopengl.so

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
affects: unity (Ubuntu) → mesa (Ubuntu)
Revision history for this message
Bryce Harrington (bryce) wrote :

Fixed in 8.0.3 which I've put in this PPA: https://launchpad.net/~bryce/+archive/mesa-803

Changed in mesa (Ubuntu):
importance: Medium → High
status: New → Triaged
summary: - compiz crashed with SIGSEGV in intel_miptree_release()
+ compiz crashed with SIGSEGV in intel_miptree_release() (Fixed in 8.0.3)
Changed in mesa (Ubuntu Precise):
importance: Undecided → High
status: New → Triaged
Bryce Harrington (bryce) on 2012-06-13
Changed in mesa (Ubuntu Quantal):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 8.0.3-0ubuntu1

---------------
mesa (8.0.3-0ubuntu1) quantal; urgency=low

  * New upstream stable release.
    + Fixes crash in intel_miptree_release()
      (LP: #952896)
    + Fixes slow WebGL in firefox
      (LP: #988343)

  [ Robert Hooker ]
  * Drop 118_fix_rendering_from_textures.patch and
    117_intel_fix_hiz_null_dereference.patch, both included upstream.
  * Refresh patches.

  [ Bryce Harrington ]
  * Add 117_nullptr_check_in_query_version.patch: Fix null pointer
    deref in QueryVersion() during login.
    (LP: #968284)
  * Add 118_glsl_initialize_samplers.patch: Initialize samplers to 0, as
    required by the spec. Fixes rendering corruption in MapsGL labels.
    Cherrypick from mesa master.
    (LP: #981883)
 -- Bryce Harrington <email address hidden> Mon, 18 Jun 2012 19:02:09 -0700

Changed in mesa (Ubuntu Quantal):
status: Fix Committed → Fix Released
Revision history for this message
Chris Halse Rogers (raof) wrote : Please test proposed package

Hello Benoit, or anyone else affected,

Accepted mesa into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mesa/8.0.3-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mesa (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed
Revision history for this message
Brian Murray (brian-murray) wrote :

There is a possible issue with the package from -proposed found in bug 1031821.

Revision history for this message
Bryce Harrington (bryce) wrote :

@Brian, looks like probably just archive skew, nothing actually wrong with the package.

Revision history for this message
Chris Halse Rogers (raof) wrote :

Hello Benoit, or anyone else affected,

Accepted mesa into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mesa/8.0.4-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Bartosz Kosiorek (gang65) wrote :

After install mesa from proposed, the problem solved for me (no more crashes.

Verification done.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Scott Kitterman (kitterman) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 8.0.4-0ubuntu0.1

---------------
mesa (8.0.4-0ubuntu0.1) precise-proposed; urgency=low

  * New upstream stable release. (LP: #1019444)
    + Fixes crash in intel_miptree_release()
      (LP: #952896)
    + Fixes slow WebGL in firefox
      (LP: #988343)

  [ Robert Hooker ]
  * Drop 118_fix_rendering_from_textures.patch and
    117_intel_fix_hiz_null_dereference.patch, both included upstream.
  * Refresh patches.

  [ Bryce Harrington ]
  * Add 117_nullptr_check_in_query_version.patch: Fix null pointer
    deref in QueryVersion() during login.
    (LP: #968284)
  * Add 118_glsl_initialize_samplers.patch: Initialize samplers to 0, as
    required by the spec. Fixes rendering corruption in MapsGL labels.
    Cherrypick from mesa master.
    (LP: #981883)
 -- Bryce Harrington <email address hidden> Fri, 07 Sep 2012 13:59:12 -0700

Changed in mesa (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.