[Saucy] Unity is slow on Intel graphics

Bug #1187500 reported by Martin Albisetti on 2013-06-04
178
This bug affects 40 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
High
Unassigned
Raring
Undecided
Unassigned
Saucy
High
Unassigned

Bug Description

For the last few weeks, unity and/or compiz has been crazy slow on both my computers with Intel graphics, alt+tab can take 2-3 seconds to complete. The lag can be seen across the board with the dash as well.
It worked fantastically well with previous versions, as well as at the beggining of the Saucy cycle.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: xorg 1:7.7+1ubuntu4
ProcVersionSignature: Ubuntu 3.9.0-3.8-generic 3.9.4
Uname: Linux 3.9.0-3-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.10.2-0ubuntu1
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Tue Jun 4 14:17:39 2013
DistUpgraded: 2013-05-15 16:20:35,929 DEBUG enabling apt cron job
DistroCodename: saucy
DistroVariant: ubuntu
EcryptfsInUse: Yes
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller [8086:0162] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:844d]
InstallationDate: Installed on 2012-07-31 (307 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: System manufacturer System Product Name
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.9.0-3-generic root=UUID=aac1b22f-87ee-4bc5-929b-1c9335912968 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: Upgraded to saucy on 2013-05-15 (19 days ago)
dmi.bios.date: 02/17/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 3202
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P8Z68-V PRO GEN3
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr3202:bd02/17/2012:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP8Z68-VPROGEN3:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.9~daily13.04.18.1~13.04-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.45-1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.1.3-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.1.3-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.3-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2b2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.7-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.7-0ubuntu1
xserver.bootTime: Fri May 31 19:02:46 2013
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.3-0ubuntu10
xserver.video_driver: intel

Martin Albisetti (beuno) wrote :
Timo Aaltonen (tjaalton) wrote :

this is because the latest mesa upload dropped a patch that worked around this

affects: xorg (Ubuntu) → mesa (Ubuntu)
Changed in mesa (Ubuntu):
importance: Undecided → High
status: New → Triaged
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu Raring):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 9.1.3-0ubuntu2

---------------
mesa (9.1.3-0ubuntu2) saucy; urgency=low

  * Add back a patch that reverts a change which made blur slow on i915,
    add two other reverts so the big one applies cleanly. (LP: #1187500)
 -- Timo Aaltonen <email address hidden> Fri, 07 Jun 2013 15:11:32 +0300

Changed in mesa (Ubuntu Saucy):
status: Triaged → Fix Released
Timo Aaltonen (tjaalton) wrote :

uploaded to raring-proposed

Changed in mesa (Ubuntu Raring):
status: Confirmed → In Progress
Chad Yu (yuzhaobo77) wrote :

A tricky bug..

Dave Chiluk (chiluk) on 2013-06-11
tags: added: raring
lucky (lucas-charles) wrote :

Is it available to users now ?
If yes how can we get our hand on it ?
I did my upgrade today and I'm still stuck with a lense that takes about 5-6 seconds to load and alt+tab cycles that take 4-5 seconds to start.

Chad Yu (yuzhaobo77) on 2013-06-12
Changed in mesa (Ubuntu Raring):
status: In Progress → Invalid
status: Invalid → Confirmed
status: Confirmed → In Progress

Hello Martin, or anyone else affected,

Accepted mesa into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mesa/9.1.3-0ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mesa (Ubuntu Raring):
status: In Progress → Fix Committed
tags: added: verification-needed
Dave Chiluk (chiluk) wrote :

Tested, 9.1.3-0ubuntu0.2 fixes the regression introeduced by LP: #1183269

Thanks.

tags: added: verification-done
removed: verification-needed
Harry Bear (hbrazzi-free) wrote :

perfectly fixed.
Thank you very much

Steve Langasek (vorlon) wrote :

already fixed in the pocket where the regression happened (raring-proposed), so marking resolved.

Changed in mesa (Ubuntu Raring):
status: Fix Committed → Fix Released
Martin Albisetti (beuno) wrote :

I can confirm everything works well now.

Thank you!

Download full text (4.2 KiB)

I can confirm everything working great on the Thinkpad Carbon X1

anmar

On 14 June 2013 09:23, Martin Albisetti <email address hidden> wrote:
> I can confirm everything works well now.
>
> Thank you!
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1188403).
> https://bugs.launchpad.net/bugs/1187500
>
> Title:
> [Saucy] Unity is slow on Intel graphics
>
> Status in “mesa” package in Ubuntu:
> Fix Released
> Status in “mesa” source package in Raring:
> Fix Released
> Status in “mesa” source package in Saucy:
> Fix Released
>
> Bug description:
> For the last few weeks, unity and/or compiz has been crazy slow on both my computers with Intel graphics, alt+tab can take 2-3 seconds to complete. The lag can be seen across the board with the dash as well.
> It worked fantastically well with previous versions, as well as at the beggining of the Saucy cycle.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.10
> Package: xorg 1:7.7+1ubuntu4
> ProcVersionSignature: Ubuntu 3.9.0-3.8-generic 3.9.4
> Uname: Linux 3.9.0-3-generic x86_64
> .tmp.unity.support.test.0:
>
> ApportVersion: 2.10.2-0ubuntu1
> Architecture: amd64
> CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
> CompositorRunning: compiz
> CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
> CompositorUnredirectFSW: true
> Date: Tue Jun 4 14:17:39 2013
> DistUpgraded: 2013-05-15 16:20:35,929 DEBUG enabling apt cron job
> DistroCodename: saucy
> DistroVariant: ubuntu
> EcryptfsInUse: Yes
> ExtraDebuggingInterest: Yes
> GraphicsCard:
> Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller [8086:0162] (rev 09) (prog-if 00 [VGA controller])
> Subsystem: ASUSTeK Computer Inc. Device [1043:844d]
> InstallationDate: Installed on 2012-07-31 (307 days ago)
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
> MachineType: System manufacturer System Product Name
> MarkForUpload: True
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.9.0-3-generic root=UUID=aac1b22f-87ee-4bc5-929b-1c9335912968 ro quiet splash vt.handoff=7
> SourcePackage: xorg
> Symptom: display
> UpgradeStatus: Upgraded to saucy on 2013-05-15 (19 days ago)
> dmi.bios.date: 02/17/2012
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: 3202
> dmi.board.asset.tag: To be filled by O.E.M.
> dmi.board.name: P8Z68-V PRO GEN3
> dmi.board.vendor: ASUSTeK Computer INC.
> dmi.board.version: Rev 1.xx
> dmi.chassis.asset.tag: Asset-1234567890
> dmi.chassis.type: 3
> dmi.chassis.vendor: Chassis Manufacture
> dmi.chassis.version: Chassis Version
> dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr3202:bd02/17/2012:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP8Z68-VPROGEN3:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
> dmi.product.name: System Product Name
> dmi.product.version: System Version
> dmi.sys.vendor: ...

Read more...

Colin Watson (cjwatson) wrote :

Waiving the usual waiting period by a few hours since this is blocking progress on bug 1175533.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Hello Martin, or anyone else affected,

Accepted mesa-lts-raring into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mesa-lts-raring/9.1.4-0ubuntu0.1~precise1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Reiner Jung (prefec2) wrote :

Bug #1206397 might be a duplicate, however, it is much slower than described in this bug report.

Reiner Jung (prefec2) wrote :

I have tested the latest proposed compiz, mesa etc. package and it is faster than reported in #1206397, but logout dialog is still incredible slow and the side bar sluggishness is still present. And the HUD and lenses is still so slow that it can not be used.

Per Gjerlov (per-gjerlov) wrote :

I am running the latest updated Saucy on an Acer netbook with Intel Atom processor and Intel video (?). The Dash is still extremely slow, when I hid the search button nothing happens for 45 seconds and it takes another 55 seconds for the search window to open. Also other operations as eg just shutting down are extremely slow. Same computer worked very well with Raring.

Carles Oriol (carlesoriol) wrote :

I've a compaq mini cq-500 13.04 unity worked fine but 13.10 is unusable because it's extremely slow. Fresh install on 4th october

Per Gjerlov (per-gjerlov) wrote :

I have now installed the final release of Saucy on the Acer netbook.. It is still very slow. When I hit the search button on Dash the screen is ready in appr. 35 seconds. It worked well with Raring.

fk (kamisli) wrote :

I did a fresh install of Saucy with an Intel Haswell HD4600 graphics and I have slow animations.

~$ /usr/lib/nux/unity_support_test -p

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Desktop
OpenGL version string: 3.0 Mesa 9.2.1

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes

Unity 3D supported: yes

~$ apt-cache policy libgl1-mesa-dri
libgl1-mesa-dri:
  Installed: 9.2.1-1ubuntu3
  Candidate: 9.2.1-1ubuntu3

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers