Please include gallium vdpau and xvmc driver support

Bug #1002224 reported by Timo Jyrinki on 2012-05-21
This bug report is a duplicate of:  Bug #872868: Mesa: Enable HW video decoding. Edit Remove
132
This bug affects 27 people
Affects Status Importance Assigned to Milestone
Mesa
New
Unknown
mesa (Ubuntu)
Wishlist
Ubuntu-X

Bug Description

Mesa 8.0+ now supports eg. hw accelerated video decoding via the VDPAU API, and XvMC support, over Gallium on at least Radeon r300+ and r600+. Please enable the support for it. More info and a patch in the linked Debian bug report.

tags: added: patch
Timo Jyrinki (timo-jyrinki) wrote :

Also, a debdiff attached. vdpauinfo now detects VDPAU on my r600+ (radeon hd 4670) card after installing the resulting libg3dvl-mesa .deb.

However, there is a build related issue at least I had - contrary to the debdiff, I used "-rf" instead of just "-r", ie. set -e; for file in $(NOT_INSTALLED); do rm -rf debian/tmp/$$file; done - because it complained about some XvMC files without -f. Therefore, as discussed in the comment above that line, those disappeared files should be probably accounted for in the packaging somehow. The reason the original line is in debdiff is that I added the -f manually and ran fakeroot debian/rules binary to complete creating the packages.

Timo Jyrinki (timo-jyrinki) wrote :

The -r added in the original patch was apparently needed because of a new vdpau directory.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
Changed in mesa:
status: Unknown → New

The attachment "debdiff_mesa_g3dvl.patch" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

Bryce Harrington (bryce) wrote :

+1, sounds good to me.

Easy enough to revert if we find it causes problems, I don't see a problem with rolling this into quantal presently.

Changed in mesa (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Wishlist
assignee: nobody → Ubuntu-X (ubuntu-x-swat)
Bryce Harrington (bryce) wrote :

Added to ubuntu-x git; will go out with the next mesa release to quantal.

Changed in mesa (Ubuntu):
status: Triaged → Fix Committed
Rovano (rovano) wrote :

And Nouveau? Is drvier Nouveau version compatible with this patch for HW accel now?

Timo Aaltonen (tjaalton) wrote :

The commit should probably be reverted for now, since it looks like the current version is not complete. Might be best to wait until it's committed to Debian, which should happen soon enough for quantal.

Bryce Harrington (bryce) wrote :

As per Timo's comments we're not going to do this change in Ubuntu.

Changed in mesa (Ubuntu):
status: Fix Committed → Triaged
status: Triaged → Won't Fix

Currently libg3dvl-mesa is provide working VDPAU on radeon driver (up to 1080p 30 fps) with Linux 3.10, so it would be nice to have it available in Saucy. Please review current situation with libg3dvl-mesa one more time.

Timo Aaltonen (tjaalton) on 2013-08-21
Changed in mesa (Ubuntu):
status: Won't Fix → In Progress
shankao (shankao) wrote :

@Timo, is there a testing package in any PPA around?

Oibaf PPA or Wolfgang Schupp Mesa PPA. You also have to install libg3dvl-mesa.

shankao (shankao) wrote :

Oh thanks. It's that intended to be merged into the main mesa package soon?

Timo Jyrinki (timo-jyrinki) wrote :

This should be just a packaging change and a patch for Mesa 10.0.1 is at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=656719#240

As it continues to be more WIP than stable (correct me if I'm wrong), it should probably stay in universe and not be installed by default. Still, offering it would be nice.

Timo Jyrinki (timo-jyrinki) wrote :

This seems to apply and build, but I don't currently have my Radeon card so I could test it. I wasn't sure about the Debian patch's '--disable-gallium-g3dvl', it's not there in this patch.

Jouni Mettala (jouni-mettala) wrote :

Package firmware-linux-nonfree is in Debian but not in Ubuntu.

To bump that issue a bit. We are running self made packages by wsnipex (https://launchpad.net/~wsnipex) since more than 6 months now. Trusty would bring everything (kernel, mesa, etc.) to be in really good shape for OSS radeon with vdpau.

If you need some background information or even want to see it in action, have look here: http://forum.xbmc.org/showthread.php?tid=174854

It would be really nice to have that relevant package included in trusty by default. Remember: Slow AMD E350 Fusion CPU are not able to play any HD content on their CPU, therefore GPU decoding support is a must.

Timo Aaltonen (tjaalton) wrote :

radeon vdpau has been enabled in trusty, xvmc is pretty much useless so it's not

Changed in mesa (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.