Please backport memtest86+ 5.01-3ubuntu1 from Ubuntu 15.10 Wily to 14.04 LTS (memtest86 is 4 years old (v4.2.0) in LTS)!

Bug #1234612 reported by Mantas Kriaučiūnas
146
This bug affects 26 people
Affects Status Importance Assigned to Milestone
trusty-backports
Undecided
Unassigned
memtest86+ (Debian)
Fix Released
Unknown
memtest86+ (Fedora)
Fix Released
Undecided
memtest86+ (Ubuntu)
Low
Unassigned

Bug Description

At September 2013, after more than 2 years since 4.20, 5.01 is finally out and the development of Memtest86+ is now fully resumed.

Please backport memtest86+ 5.01-3ubuntu1 from Ubuntu 15.10 Wily to 14.04 LTS - memtest86+ is 4 years old in 14.04 LTS and doesn't support lots of current hardware :(

Bellow is debian/changelog entry:

memtest86+ (5.01-3ubuntu1) wily; urgency=medium
  * Merge with Debian; remaining changes:
    - Only run update-grub in the postrm on remove/purge.
    - Drop the multiboot image from the GRUB menu for now, since it's
      experimental and has known problems detecting all memory on some
      systems at the moment.
    - Do not update grub configuration, if running in container, or
      update-grub not present, or grub config has not been previously
      generated.
    - Support localization of GRUB menu entries.
    - Don't present the GRUB menu option on EFI systems, since it won't work.
 -- Matthias Klose <email address hidden> Thu, 27 Aug 2015 14:44:32 +0200

memtest86+ (5.01-3) unstable; urgency=medium
  * Build with -fgnu89-inline for GCC 5 (Matthias Klose, Closes: #778001)
 -- Yann Dirson <email address hidden> Thu, 25 Jun 2015 19:14:21 +0200

memtest86+ (5.01-2) unstable; urgency=medium
  * Build -O0 to workaround what is apparently a gcc 4.9 optimisation bug,
    and use "static" the __in and __out macros to allow compilation to
    proceed under this condition (as done in other distros, including
    Mageia, closes: #753627): memtest86+-5.01-O0.patch.
  * Fix PCI bus scanning on Nehalem architectures (patch from the Mageia
    package): memtest86+-5.01-array-size.patch.
  * Bumped Standards-Version to 3.9.5, no change.
 -- Yann Dirson <email address hidden> Wed, 10 Sep 2014 21:58:11 +0200

memtest86+ (5.01-1) unstable; urgency=medium
  * Switch to source format 3.0 (quilt).
  * New upstream release (Closes: #727638).
    * Drop makeiso.sh fix for genisoimage, integrated upstream.
    * Refresh multiboot patch, but do not include additional fix for
      #568176 yet (needs more work).
    * Call build target explicitely, since the default target now attempts
      an scp.
  * Include chineses translations for package descriptions (Anthony Wong
    <email address hidden>, Closes: #741432)
  * Only run update-grub in the postrm on remove/purge (Luke Faraone /
    Ubuntu, Closes: #587340)
  * Remove leading ./ in lintian-override paths so they get recognized again.
 -- Yann Dirson <email address hidden> Sat, 28 Jun 2014 17:02:10 +0200

Memtest86+ V5.01 changelog from upstream:
--------------------------
- Added support for up to 2 TB of RAM on X64 CPUs
- Added experimental SMT support up to 32 cores
- Added complete detection for memory controllers.
- Added Motherboard Manufacturer & Model reporting
- Added CPU temperature reporting
- Added enhanced Fail Safe Mode (Press F1 at startup)
- Added support for Intel "Sandy Bridge-E" CPUs
- Added support for Intel "Ivy Bridge" CPUs
- Added preliminary support for Intel "Haswell" CPUs
- Added preliminary support for Intel "Haswell-ULT" CPUs
- Added support for AMD "Kabini" (K16) CPUs
- Added support for AMD "Bulldozer" CPUs
- Added support for AMD "Trinity" CPUs
- Added support for AMD E-/C-/G-/Z- "Bobcat" CPUs
- Added support for Intel Atom "Pineview" CPUs
- Added support for Intel Atom "Cedar Trail" CPUs
- Added SPD detection on most AMD Chipsets
- Enforced Coreboot support
- Optimized run time for faster memory error detection
- Rewriten lots of memory timings detection code
- Corrected bugs, bugs and more bugs

Tips : F1 will enable fail-safe mode, F2 will enable SMP Mode (disabled by default) and F3 will trigger an hidden alternative SMP Mode.

See http://memtest.org/#change for more info

Revision history for this message
In , Upstream (upstream-redhat-bugs) wrote :

Latest upstream release: 5.01.usb.installer
Current version/release in Fedora Rawhide: 4.20-11.fc21
URL: http://www.memtest.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

tags: added: upgrade-software-version
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in memtest86+ (Ubuntu):
status: New → Confirmed
Revision history for this message
In , Upstream (upstream-redhat-bugs) wrote :

Latest upstream release: 5.01
Current version/release in Fedora Rawhide: 4.20-11.fc21
URL: http://www.memtest.org/download/5.01/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Revision history for this message
Colin Watson (cjwatson) wrote :

This should be forwarded to the Debian maintainer; it's much easier and better for us to get new upstream versions via there.

Changed in memtest86+ (Debian):
status: Unknown → New
Revision history for this message
In , Jaroslav (jaroslav-redhat-bugs) wrote :

*** Bug 1014737 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Jaroslav (jaroslav-redhat-bugs) wrote :

It seems to crash if compiled with gcc-4.7.2 or newer. It works if compiled with gcc-4.4.7. Upstream ticket:

http://forum.canardpc.com/threads/83443-Memtest86-V5.01-crashes-with-gcc-4.7.2-or-later

Revision history for this message
In , Account (account-redhat-bugs) wrote :

MemTest86_v5 is going to be released with UEFI support: http://www.memtest86.com/technical.htm#new

Is it worth changing from Memtest86+ to MemTest86 ??

Revision history for this message
In , Account (account-redhat-bugs) wrote :

(In reply to Xose Vazquez Perez from comment #4)

> MemTest86_v5 is going to be released with UEFI support:
> http://www.memtest86.com/technical.htm#new
>
> Is it worth changing from Memtest86+ to MemTest86 ??

Forget it. MemTest86_v5 is not GPL, the last one was 4.3.6.

tags: added: precise saucy
tags: added: trusty
Changed in memtest86+ (Ubuntu):
importance: Undecided → Low
Revision history for this message
In , Jaroslav (jaroslav-redhat-bugs) wrote :

*** Bug 1057864 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Jaroslav (jaroslav-redhat-bugs) wrote :

The workaround could be to compile it with gcc-3.4.

Revision history for this message
In , Bill (bill-redhat-bugs) wrote :

Yes, please update memtest86+ in Fedora soon. Version 4.2 does not work on new hardware... Thanks!

Revision history for this message
In , Jaroslav (jaroslav-redhat-bugs) wrote :

OK, I compiled it with gcc-3.4 and it seems to work. I will push it and I will focus on the gcc-4.8 fix later.

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

memtest86+-5.01-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/memtest86+-5.01-1.fc20

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

memtest86+-5.01-1.fc20 has been pushed to the Fedora 20 stable repository. If problems still persist, please make note of it in this bug report.

Jonas Juodė (jonukas)
summary: - Please update memtest86+ to the latest 5.0.x release - memtest86 in
- Ubuntu 13.10 is 2 years old (v4.2.0)!
+ [FFe] Please update memtest86+ to the latest 5.0.x release - memtest86
+ in Ubuntu 14.04 LTS is 2 years old (v4.2.0)!
summary: - [FFe] Please update memtest86+ to the latest 5.0.x release - memtest86
+ [SRU] Please update memtest86+ to the latest 5.0.x release - memtest86
in Ubuntu 14.04 LTS is 2 years old (v4.2.0)!
Revision history for this message
Jackson Doak (noskcaj) wrote : Re: Please update memtest86+ to the latest 5.0.x release - memtest86 in Ubuntu 14.04 LTS is 2 years old (v4.2.0)!

This is unlikely to be fixed in trusty, but with any luck it will be done in time for utopic

summary: - [SRU] Please update memtest86+ to the latest 5.0.x release - memtest86
- in Ubuntu 14.04 LTS is 2 years old (v4.2.0)!
+ Please update memtest86+ to the latest 5.0.x release - memtest86 in
+ Ubuntu 14.04 LTS is 2 years old (v4.2.0)!
Changed in memtest86+ (Debian):
status: New → Fix Released
summary: - Please update memtest86+ to the latest 5.0.x release - memtest86 in
- Ubuntu 14.04 LTS is 2 years old (v4.2.0)!
+ Please merge memtest86+ 5.0.1 release from Debian - memtest86 in Ubuntu
+ 14.04 LTS is 2 years old (v4.2.0)!
description: updated
description: updated
description: updated
description: updated
Changed in memtest86+ (Debian):
status: Fix Released → New
Changed in memtest86+ (Debian):
status: New → Fix Released
description: updated
summary: - Please merge memtest86+ 5.0.1 release from Debian - memtest86 in Ubuntu
- 14.04 LTS is 2 years old (v4.2.0)!
+ FFe: Please merge memtest86+ 5.01-2 version from Debian - memtest86+ in
+ Ubuntu 14.10 is 3 years old (v4.2.0)!
Changed in memtest86+ (Ubuntu):
status: Confirmed → New
tags: added: utopic
removed: saucy
Revision history for this message
Iain Lane (laney) wrote : Re: FFe: Please merge memtest86+ 5.01-2 version from Debian - memtest86+ in Ubuntu 14.10 is 3 years old (v4.2.0)!

Without a proposed package, there's not really anything for the release team to approve - unsubscribing.

Revision history for this message
Iain Lane (laney) wrote :

Sorry, that was a bit brief - since nobody's done the merge work yet, I don't think the release team can properly consider the impact. Also, it seems kind of late for Utopic now (perhaps related as this could have been considered sooner if there was a proposed package), although I'd probably like one of the more experienced members of the release team to weigh in on this if it were necessary.

Revision history for this message
In , David (david-redhat-bugs) wrote :

Created attachment 948383
Patch fixes non-working binary with later GCC versions.

I have been working on this problem for a while. Disabling the inline-functions called-once optimization fixes the problem.

I also ran the static analyzer Cppcheck, and solved an array out-of-bounds bug, and an incorrect pointer bug.

-Dave

Revision history for this message
In , David (david-redhat-bugs) wrote :

PS. I've also sent this patch upstream, but I haven't heard much feedback from the developers.

-Dave

Revision history for this message
In , Jaroslav (jaroslav-redhat-bugs) wrote :

(In reply to David McInnis from comment #12)
Hi,

thanks for the patch, I will apply it with one minor change. I have already used:
- for(i = 0; i < sizeof(possible_nhm_bus); i++) {
+ for(i = 0; i < sizeof(possible_nhm_bus) / sizeof(possible_nhm_bus[0]); i++) {

I will keep it, because it is more generic solution than the hardcoded number of iterations.

Could you provide more information about the -fno-inline-functions-called-once. What it fixes and why?

Revision history for this message
In , David (david-redhat-bugs) wrote :

I like the more generic way of getting the size of an array in C. I've never seen this technique before, and I'll have to look into it.

About the -fno-inline-functions-called-once optimization:

I do not understand what it fixes or why. I will do more research into the problem and report back what I discover.

This patch is part of my larger effort of improve Memtest86+'s SMP mode. It always locks up hard on my Intel Core 2 Quad machine when in SMP. Once I find the deadlock issue my goal will be to improveimprove SMP performance.

Here is my project page: github.com/oraac/memtest86--SMP

If anyone here want's to help I'd be happy to get you a SSH key for commit access.

-Dave

Revision history for this message
In , Jaroslav (jaroslav-redhat-bugs) wrote :

(In reply to David McInnis from comment #15)
> About the -fno-inline-functions-called-once optimization:
>
> I do not understand what it fixes or why. I will do more research into the
> problem and report back what I discover.
>
Thanks.

I probably haven't encountered this problem, because I am using -O0 instead of -O1, i.e. no inlining at all. I will also keep this as is, it may resolve other hidden problems.

Revision history for this message
In , Jaroslav (jaroslav-redhat-bugs) wrote :

Fixed in memtest86+-5.01-8.fc22.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in memtest86+ (Ubuntu):
status: New → Confirmed
summary: FFe: Please merge memtest86+ 5.01-2 version from Debian - memtest86+ in
- Ubuntu 14.10 is 3 years old (v4.2.0)!
+ Ubuntu 15.04 is 4 years old (v4.2.0)!
description: updated
tags: added: vivid
removed: utopic
Revision history for this message
ariel cornejo (arielco) wrote : Re: FFe: Please merge memtest86+ 5.01-2 version from Debian - memtest86+ in Ubuntu 15.04 is 4 years old (v4.2.0)!

Debian has 5.01 packages:

http://ftp.debian.org/debian/pool/main/m/memtest86+/
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=727638

It works in my machine (Sandy Bridge i7-2700k CPU, Z77 chipset). The "experimental multiboot" option hangs, but I didn't test it in 4.20 either.

tags: added: needs-debian-merge
summary: FFe: Please merge memtest86+ 5.01-2 version from Debian - memtest86+ in
- Ubuntu 15.04 is 4 years old (v4.2.0)!
+ Ubuntu 15.10 is 4 years old (v4.2.0)!
Changed in memtest86+ (Ubuntu):
status: Confirmed → Fix Committed
summary: - FFe: Please merge memtest86+ 5.01-2 version from Debian - memtest86+ in
- Ubuntu 15.10 is 4 years old (v4.2.0)!
+ Please backport memtest86+ 5.01- version from Debian - memtest86+ in
+ Ubuntu 14.04 LTS is 4 years old (v4.2.0)!
summary: - Please backport memtest86+ 5.01- version from Debian - memtest86+ in
- Ubuntu 14.04 LTS is 4 years old (v4.2.0)!
+ Please backport memtest86+ 5.01-3ubuntu1 from Ubuntu 15.10 Wily to 14.04
+ LTS (memtest86 is 4 years old (v4.2.0) in LTS)!
description: updated
Revision history for this message
Hans Joachim Desserud (hjd) wrote :

memtest86+ 5.01-3ubuntu1 has been merged and is available in Ubuntu Wily, thus I believe this can be marked as Fix Released.

Thanks for adding the trusty-backports task, might be possible to make it available for 14.04 as well.

affects: memtest86+ (Ubuntu) → ubuntu
Changed in ubuntu:
status: Fix Committed → Fix Released
affects: ubuntu → memtest86+ (Ubuntu)
Mathew Hodson (mhodson)
affects: memtest86+ (Debian) → debian
Changed in debian:
status: Fix Released → Unknown
affects: debian → memtest86+ (Debian)
tags: removed: needs-debian-merge
Mathew Hodson (mhodson)
tags: removed: precise vivid
Changed in memtest86+ (Debian):
status: Unknown → Fix Released
Changed in memtest86+ (Fedora):
importance: Unknown → Undecided
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.