Comment 35 for bug 568275

Raik (jinto) wrote :

Hi,

here are the changes that need do be done for maverick. You need mediatomb_0.12.1.orig.tar.gz and the files I've attached. Than you can do dpkg-source -x mediatomb_0.12.1-0ubuntu1custom2.dsc.

For every xulrunner update you need to update the dependencies for the new version in the control file (the _2_ lines containing xulrunner-1.9.2-dev (>=1.9.2.12), xulrunner-1.9.2-dev (<< 1.9.2.13) ) and add an new entry in the changelog file. Thats all. The problem is that xulrunner updates very often. :-(

Maybe this could be avoided by renaming the mediatomb executable to mediatomb.real and make the mediatomb comand a wrapper script containing:
#!/bin/sh
IFS="
"
LD_LIBRARY_PATH=/usr/lib/xulrunner-`xulrunner --gre-version` /usr/bin/mediatomb.real $@

or something. Unfortunaly there is, afaik, no symlink that always points to the most recent version of xulrunner. That would make live much easier.