Mediascanner crashes and loops on bad media (webm)

Bug #1508142 reported by Alan Pope ๐Ÿบ๐Ÿง๐Ÿฑ ๐Ÿฆ„ on 2015-10-20
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Alejandro J. Cura
mediascanner2 (Ubuntu)
High
James Henstridge

Bug Description

Updated my retail bq E4.5 phone to OTA-7.

Opened Music app and saw no music. Tailed mediascanner log, found it repeatedly scanning my music over and over. This causes high cpu, high IO, increased disk usage through logging and locks the database so Music app is unusable.

The only way I could make Music appear was to issue:-

stop mediascanner-2.0

Then re-open Music.
Attached mediascanner log (all 369M of it)

Related branches

Changed in mediascanner2 (Ubuntu):
importance: Undecided → Critical
assignee: nobody → James Henstridge (jamesh)
Changed in canonical-devices-system-image:
assignee: nobody → Alejandro J. Cura (alecu)
importance: Undecided → Critical

Deleted two of the webm videos from my sd card and now it appears to have stopped looping.

Uploaded to here for "analysis":-

http://people.canonical.com/~alan/big_buck_bunny_1080p_VP8_VORBIS_25fps_7800K_short.WebM
http://people.canonical.com/~alan/goat-rage.webm

summary: - Mediascanner runs constantly, rescanning repeatedly
+ Mediascanner crashes and loops on bad media (webm)
Alejandro J. Cura (alecu) wrote :

I can reproduce this bug by putting this file in my Videos folder: http://video.webmfiles.org/elephants-dream.webm

bq krillin, rc-proposed, r153.

Alejandro J. Cura (alecu) wrote :

Since this seems to be happening only with webm videos, I'm lowering the priority of the bug.

Changed in canonical-devices-system-image:
importance: Critical → High
Changed in mediascanner2 (Ubuntu):
importance: Critical → High
Changed in canonical-devices-system-image:
milestone: none → ww46-2015
James Henstridge (jamesh) wrote :

The best solution for this is probably to finish off the external-metadata-extractor branch, which was set aside earlier this year.

I've updated the branch to get it building with trunk, but there is still a bit of work to do (there may be conflicts with the branches from the pending silo, and maybe some tweaks to the AppArmor profiles). The in-progress code can be found here though:

https://code.launchpad.net/~jamesh/mediascanner2/external-metadata-extractor/+merge/244416

Changed in canonical-devices-system-image:
status: New → Confirmed
Changed in mediascanner2 (Ubuntu):
status: New → In Progress
James Henstridge (jamesh) wrote :

I have some in-progress packages in landing silo 55 at the moment. Using Alan's test files, the main scanner daemon no longer crashes (so the startup directory scan isn't repeated), but it looks like there are still a few corner cases to fix up.

Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mediascanner2 - 0.108+16.04.20151109-0ubuntu1

---------------
mediascanner2 (0.108+16.04.20151109-0ubuntu1) xenial; urgency=medium

  * Move the metadata extractor to a separate process to isolate bugs in
    media codecs. (LP: #1508142)

 -- James Henstridge <email address hidden> Mon, 09 Nov 2015 01:56:39 +0000

Changed in mediascanner2 (Ubuntu):
status: In Progress → Fix Released
Josuรฉ (j2g2rp) wrote :

is the fix released now? or it will be released with the next OTA?
I'm answering because I'm having the same problem.
In the bug https://bugs.launchpad.net/music-app/+bug/1514517 Andrew told me that i was having this problem
I checked but it looks like that I haven't any webm files, but the mediascan file is looped.

Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers