SRU upstream bugfix micro point release 3.2.5

Bug #1009973 reported by Dimitri John Ledkov on 2012-06-07
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
Precise
Undecided
Dimitri John Ledkov
mdadm (Ubuntu)
Wishlist
Unassigned
Precise
Wishlist
Dimitri John Ledkov

Bug Description

[IMPACT]

 * Micro Stable Bug Fix release from upstream including many fixes for the mdmon utility bug 957494 as well as other minor to medium severity bug fixes

 * Hardware enablement trump card, improved DFF and IMSM support

 * Highly encouraged to upgrade by upsteam

 * Reduced LTS maintenance due to synergy / resync with Wheezy

[TESTCASE]

 * Verification of all the other bugs included in this SRU
 * Quantal alpha 2 testing
 * Wide testing
 * manual verification that the contents of the binary packages have not changed, except for the addition of the mdmon utility which is a deliberate SRU fix

[Regression Potential]

 * New software fixes bugs, but I also may introduce new as well. 3.2.5 was a bugfix to fix the 3.2.4 bugfix release =/ but overall there is potential for regressions.

[Other Info]

ANNOUNCE-3.2.4:

http://neil.brown.name/git?p=mdadm;a=blob_plain;f=ANNOUNCE-3.2.4;h=e321678604c0c36a5a35e34693756e5b1595e45d;hb=HEAD

ANNOUNCE-3.2.5:

http://neil.brown.name/git?p=mdadm;a=blob_plain;f=ANNOUNCE-3.2.5;h=396da12a6f614bfe041f88de4f040a65366913d6;hb=HEAD

Changed in mdadm (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
tags: added: fs.oneplanning
Changed in mdadm (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
Changed in mdadm (Ubuntu):
status: Confirmed → Fix Released
Changed in mdadm (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → Wishlist
assignee: nobody → Dmitrijs Ledkovs (dmitrij.ledkov)
no longer affects: mdadm (Ubuntu Quantal)
summary: - update mdadm in precise
+ SRU upstream bugfix micro point release 3.2.5
description: updated
description: updated
description: updated
Steve Langasek (vorlon) wrote :
Download full text (5.3 KiB)

--- mdadm-3.2.3/config.c 2011-12-15 04:13:08.000000000 +0000
+++ mdadm-3.2.5/config.c 2012-05-18 07:10:03.000000000 +0000
@@ -921,19 +921,19 @@
         * else 'yes'.
         */
        struct dev_policy *p;
- int no=0, found_auto=0;
+ int no=0, found_homehost=0;
        load_conffile();

        pol = pol_find(pol, pol_auto);
        pol_for_each(p, pol, version) {
                if (strcmp(p->value, "yes") == 0)
                        return 1;
- if (strcmp(p->value, "auto") == 0)
- found_auto = 1;
+ if (strcmp(p->value, "homehost") == 0)
+ found_homehost = 1;
                if (strcmp(p->value, "no") == 0)
                        no = 1;
        }
- if (is_homehost && found_auto)
+ if (is_homehost && found_homehost)
                return 1;
        if (no)
                return 0;

This appears to be an interface change. Why is this appropriate for an SRU?

+mdadm (3.2.5-1ubuntu2~12.04.1) precise-proposed; urgency=low

This is not the preferred numbering convention, as documented at <https://wiki.ubuntu.com/SecurityTeam/UpdatePreparation#Update_the_packaging>. Please use 3.2.5-1ubuntu0.1 as the version number here. Please also consolidate all the relevant information into a single changelog entry, which is the convention for SRUs. Bug #920324, for instance, has nothing to do with the SRU, and so should not be referenced in the changelog.

--- mdadm-3.2.3/debian/checkarray 2012-01-29 05:36:30.000000000 +0000
+++ mdadm-3.2.5/debian/checkarray 2012-06-15 09:42:28.000000000 +0000
@@ -175,6 +175,21 @@

The only reference in the changelog for this change is a Debian bug report. If this change is relevant for SRUing, it should get a separate bug report in Launchpad for tracking (targeted to precise); otherwise the change should be omitted from the SRU. (My recommendation is to omit the change.)

Likewise for this change:

--- mdadm-3.2.3/debian/mdadm.logcheck.ignore.server 2012-01-29 05:36:30.000000000 +0000
+++ mdadm-3.2.5/debian/mdadm.logcheck.ignore.server 2012-06-15 09:42:28.000000000 +0000
@@ -10,7 +10,7 @@

For bug #1002357, please provide an explicit test case related to the functionality of the udev rules so that we are verifying the empirical correctness of the behavior, and not just the contents of the package.

--- mdadm-3.2.3/debian/rules 2012-02-10 00:11:11.000000000 +0000
+++ mdadm-3.2.5/debian/rules 2012-06-15 10:54:50.000000000 +0000
@@ -75,10 +63,8 @@
        dh_installdirs
        chmod +x debian/install-rc
        PACKAGE=mdadm-udeb debian/install-rc check.d
- install -m0755 mdadm $(DESTDIR)/sbin
- install -m0755 mdadm.udeb $(DESTDIR_UDEB)/sbin/mdadm
- install -m0644 debian/mdadm.mdadm-blkid.udev \
- $(DESTDIR_UDEB)/etc/udev/rules.d/65-mdadm-blkid.rules
+
+ $(MAKE) install DESTDIR=$(DESTDIR)

        install -m0755 debian/initramfs/hook \
                $(DESTDIR)/usr/share/initramfs-tools/hooks/mdadm

Build system changes are not normally appropriate for SRU. Either these changes should be reverted / reduced to a minimal necessary change, o...

Read more...

Stéphane Graber (stgraber) wrote :

What's the status of this wrt 12.04.1?

I'm also a bit confused as to how a wishlist bug is targeted to the point release, unless it's planned to be bundled with important fixes.

Changed in mdadm (Ubuntu Precise):
status: Confirmed → Triaged
Dimitri John Ledkov (xnox) wrote :

> +++ mdadm-3.2.5/config.c 2012-05-18 07:10:03.000000000 +0000
> This appears to be an interface change. Why is this appropriate for an
> SRU?

* The new behaviour was the intended one. I have applied a patch to
  accept previous behaviour as well.
* version number fixed
* reverted the logwatch, checkarray, apport changes
* made debian rules changes minimal
* preserved previous behaviour changes:
  - bitmap chunk size of 0 means 512B

Dimitri John Ledkov (xnox) wrote :

I re-uploaded, but did not include in the debian/changelog a reference to close bug 946758, which is fixed by new upstream release.

Changed in ubuntu-release-notes:
milestone: none → 12.04.1
Changed in mdadm (Ubuntu Precise):
status: Triaged → In Progress

Hello Dmitrijs, or anyone else affected,

Accepted mdadm into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mdadm/3.2.5-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in mdadm (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Dimitri John Ledkov (xnox) wrote :

Currently one person reporting non-bootable system. See bug 1030292.

tags: added: verification-failed
removed: verification-needed
Adam Conrad (adconrad) wrote :

Hello Dmitrijs, or anyone else affected,

Accepted mdadm into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mdadm/3.2.5-1ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-failed
tags: added: verification-needed
Steve Langasek (vorlon) wrote :

Marking verified. No explicit test case here, the testing happens on the other bugs.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mdadm - 3.2.5-1ubuntu0.2

---------------
mdadm (3.2.5-1ubuntu0.2) precise-proposed; urgency=low

  * Patch udev-md-raid.rules to not auto-start arrays based on detection
    of ddf or isw (imsm) signatures; this conflicts with dmraid usage in
    precise and requires more analysis before it can be enabled in SRU.
    LP: #1030292.

mdadm (3.2.5-1ubuntu0.1) precise-proposed; urgency=low

  * Stable Micro Point Bug Fix release:
    - SRU master bug (LP: #1009973)
    - Fixes segfault upon update-initramfs (LP: #969384)
    - Fixes does not allow internal bitmap on version 1.2 arrays (LP: #1022915)
  * Preserved previous behaviour, by reverting:
    - bitmap chunk size of 0 will continue to mean 512B
    - Modify the below fix, to accept previous syntax
      "b10c663 config: fix handing of 'homehost' in AUTO line."
  * Use upstream version of udev rules, instead of three slightly
    different ubuntu udev rules (LP: #968074) (LP: #1002357)
  * Add missing mdmon utility. This enables external metadata RAID
    formats: DDF and Intel Matrix Storage Management (IMSM). (LP: #957494)
  * Copy udev rule from /etc/udev/rules.d/ as well as the
    /lib/udev/rules.d/, to allow local administrator to override mdadm
    rules file (LP: #1017407)
  * debian/initramfs/local-premount: add call wait_for_udev to wait a
    little longer for RAID devices to appear. This improves
    boot reliability. (LP: #942106)

mdadm (3.2.5-1) unstable; urgency=low

  [ Michael Tokarev ]
  * new upstream (bugfix) release, fixing regression when --add'ing
    device to an array, introduced in 3.2.4, plus other minor fixes
    (Closes: #673104, #673344)
  * new patch: sha1-includes.diff to fix #include mess in new sha1.h
  * added a check into debian/checkarray to skip checking arrays created
    less than 2 weeks ago (Closes: #624273)

  [ Dmitrijs Ledkovs ]
  * Remove obsolete documentation dating back to ~etch release
  * Remove reference to obsolete documention from debconf templates
  * Update debconf templates translations
  * Remove compatability with acient initramfs-tools
  * Remove debian-specific mdadm-startall.8 in clean target

mdadm (3.2.4-1) unstable; urgency=low

  * new upstream (bugfix) release (Closes: #664088, #661552)
  * removed debian-run-udev.diff (applied upstream), and
    all RUNDIR handling from debian/rules (it is the default now)
  * add build-arch and build-indep targets to debian/rules, and
    bump Standards-Version to 3.9.3

mdadm (3.2.3-3) unstable; urgency=low

  * switch from topgit to plain 3.0 (quilt) layout, creating
    debian/patches. Don't build-depend on quilt as patching
    is done automatically by dpkg-source.
  * debian/patches/debian-run-udev.diff by Roger Leigh (Closes: #644319, #627774)
  * update debian/mdadm.logcheck.ignore.server to recognize "k" in
    addition of "blocks" in kernel messages. Thanks to Frédéric Brière
    for the patch (Closes: #656038)
 -- Steve Langasek <email address hidden> Fri, 03 Aug 2012 23:08:39 -0700

Changed in mdadm (Ubuntu Precise):
status: Fix Committed → Fix Released
Colin Watson (cjwatson) on 2012-10-17
Changed in ubuntu-release-notes:
status: New → Invalid
Dimitri John Ledkov (xnox) wrote :

made it into 12.04.1.

Steve Langasek (vorlon) wrote :

I don't see this documented anywhere in the precise release notes. So either the release notes task is "wontfix", or it's still to be done.

Dimitri John Ledkov (xnox) wrote :

In retrospect, maybe we opened the task when we thought there would be regression in non-bootable intel matrix systems. But it was fixed and made it into a respin for 12.04.1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers