Non-Windowed launchers pulse indefinitely

Bug #1683230 reported by Robert Tari on 2017-04-17
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
mate-dock-applet (Ubuntu)
Undecided
MATE Desktop

Bug Description

MATE Dock Applet 0.77, Ubuntu MATE 17.04:

When one clicks an icon whose application performs an action that does not involve presenting a window (e.g. the application calls a function over D-BUS, calls a shell script, opens the browser, etc.), the icon keeps on pulsing. To make matters worse, when the icon is clicked again, it starts another blinking timer, so it pulses twice as fast. Every subsequent click adds more pulsing and this goes on indefinitely.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mate-dock-applet (Ubuntu):
status: New → Confirmed
Robert Tari (robert-tari) wrote :

MATE Dock Applet 0.79, Ubuntu MATE 17.10:

The issue is still present.

Changed in mate-dock-applet (Ubuntu):
assignee: nobody → MATE Desktop (mate-desktop)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mate-dock-applet - 0.80-1

---------------
mate-dock-applet (0.80-1) unstable; urgency=medium

  [ Martin Wimpress ]
  * New upstream release. (LP: #1683230)

  [ Mike Gabriel ]
  * debian/control:
    + Set Priority: to optional.
    + Bump Standards-Version: to 4.1.1.
    + Drop useless B-Ds: dh-autoreconf, autotools-dev.

 -- Mike Gabriel <email address hidden> Fri, 03 Nov 2017 09:26:28 +0100

Changed in mate-dock-applet (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers