Ubuntu upgrade to Lucid failed badly!

Bug #560237 reported by ullix on 2010-04-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-panel (Ubuntu)
Low
Unassigned
gthumb (Ubuntu)
Low
Unassigned
mail-notification (Ubuntu)
Undecided
Unassigned
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

My system was initially set up as a Kubuntu Intrepid system, and then changed to Ubuntu (as an escape from KDE4). Since then I have only run the Ubuntu desktop. The stepwise upgrade from 8.10 to 9.04 to 9.10 went well, but failed badly on upgrade to 10.04.

Step1: Upgrade to 9.04:
Step2: Upgrade to 9.10:
Both steps executed without problems. Optically - how the desktop and panels were arranged - and by playing with my standard software, everything was fine. I definitively was running the Gnome Ubuntu desktop.

Step3: Upgrade to 10.04:
A myriad of issues had come up with that upgrade. I'll list a few of them:
1) Only Kubuntu (and xterm) was available after the upgrade; Gnome was gone! I then installed ubuntu-desktop via Synaptic, and noticed that it pulled a whole bunch of dependencies. So obviously the whole ubuntu-thing was eradicated and only KDE left! After installing ubuntu-desktop the desktop and panels were a mess. Apparently the previous theme is absent, and no new one is established by default. Some icons were - e.g. that from firefox - were replaced by the 'missing-icon' icon, although the program is still installed, and clicking the 'missing-icon' opens that application.

2) During start, right before the login screen, the display shows some scrambled color lines at the top of the screen, the audio gives some bop-bop-bop-bop sound, before the correct login screen comes up, and the correct jingle sounds. After that, another round of bop-bops and then screen and sound are ok. During shutdown, the same happens in reverse, i.e. first the scrambled colors at top of monitor, then bop-bop-bop-bop, then shutdown. This never occured throughout all Intrepid times

3) After login some unknown process causes 100% CPU use, of which 50-60% are io-wait states (see attached screenshot: in the middle of the top panel are Systemmonitor displays. The leftmost one has blue for user and red for IO)

4) Also right after login some unknown process is causing sending of bursts of 20-45kbits7sec every 3 sec to the network. see attached screenshot (visible both in top panel - middle window of Systemmonitor - and bottom part of Resources display). It is NOT apt-get or any other update activity; I would expect to see something like this from a virus. Again, I have never seen such before on my system

5) I use mail-notification, which, on other Lucid systems of mine, is popping up a notification about new emails near the top panel. Here, however, the messages appear as dialog boxes (with ok and cancel buttons) in the middle of the screen, and stay there irrespective of preferences I set.

6) gthumb does not recognize any of my many, carefully created catalogues. This had been a lot of work. At least, some import option should be offered!!!

7) my keyboard had been changed from using the grave and acute keys to not using them

8) the top panel icon to logout/suspend/hibernate/shutdown has been deleted. I can only shutdown using the System menu; don't know how to suspend or hibernate

etc.

This is a real mess. Good thing I tried the upgrade from a copy of the partition ;-/

ullix (ullix) wrote :
Christopher "cv" (vchristopher) wrote :

Of course you can't upgrade all the time. You can upgrade from 9.10 to 10.04 or from 8.04 to 10.04 but you can't upgrade from 8.10 to 9.04 to 9.10 to 10.04 and still think that everything will work ;-)

Why don't you just save your few files on an usb stick and do a fresh Lucid install?

Rickard Närström (riccetn) wrote :

Thanks for your report, you seem to have a lot of problems many of which are most likely unrelated. We would like to help you identify each individual problem and try to solve them but to do that we would need you to begin with attaching the log files found in "/var/log/dist-upgrade".

affects: ubuntu → update-manager (Ubuntu)
ullix (ullix) wrote :

Rickard, log files attached (I did chmod 777 in case you are wondering about permissions)

oh boy, there is some good reading for a long weekend ;-)

Michael Vogt (mvo) wrote :

Thanks for your bugreport and for the logs.

It looks like the upgrade happend at a unfortunate time:

Package udisks has broken Hängt ab on libparted0
  Considering libparted0 3 as a solution to udisks 13
  Holding Back udisks rather than change libparted0

this caused the removal of gnome, but because you had kubuntu-desktop installed it assumed that it
is ok to continue (its not very smart, once desktop environment is enough to make the upgrader happy).

A lot of the other issues are application specific, I create tasks for that.

Michael Vogt (mvo) wrote :

> 5) I use mail-notification, which, on other Lucid systems of mine, is popping up a notification about new emails near the top panel. Here, however, the messages appear as dialog boxes (with ok and cancel buttons) in the middle of the screen, and stay there irrespective of preferences I set.

That is a mail-notification issue, it uses notificaitons with actions, something that notify-osd does not support

Michael Vogt (mvo) wrote :

> 6) gthumb does not recognize any of my many, carefully created catalogues. This had been a lot of work. At least, some import option should be offered!!!

Adding a gthumb task

Michael Vogt (mvo) wrote :

> 7) my keyboard had been changed from using the grave and acute keys to not using them
> 8) the top panel icon to logout/suspend/hibernate/shutdown has been deleted. I can only shutdown using the System menu; don't know how to suspend or hibernate

For (8) I created a gnome-panel task, I'm not sure about (7), maybe someone from the desktop team can reassign/create a appropriate task.

Michael Vogt (mvo) wrote :

For 2-4 you can use a tool like ionice to try to figure out what is going on.

Michael Vogt (mvo) wrote :

sorry, iotop of course

Michael Vogt (mvo) wrote :

I close the update-manager task, the problem is fixed with the latest version of udisks in the archive.

Changed in update-manager (Ubuntu):
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

do you have indicator-session installed? did you get an error after login because the applet was not there and click to remove the configuration for it?

Changed in gnome-panel (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
ullix (ullix) wrote :

Sebastian,
the indicator-session remained installed with version 0.2.7-0ubuntu3. I have now upgraded to 0.2.8-0ubuntu2.

I believe this package is in charge of showing the suspend/hibernate/shutdown as well as user change/logout options? It is still not showing

ullix (ullix) wrote :

Michael,
I used iotop and found that I have 2 instances of kjournald running, which both are doing a lot(!) of disk access. I also saw "rsyslogd -c4" which also does a lot of disk access. The latter probably was due to another failed upgrade part, namely mythtv is solidly broken by the upgrade. The mythbackend perpetually terminates and respawns, which may be creating much/most/all of this logging activity:
...
Apr 15 19:38:06 athlon--80gb init: mythtv-backend main process (6014) terminated with status 254
Apr 15 19:38:06 athlon--80gb init: mythtv-backend main process ended, respawning
Apr 15 19:38:11 athlon--80gb init: mythtv-backend main process (6020) terminated with status 254
Apr 15 19:38:11 athlon--80gb init: mythtv-backend main process ended, respawning
Apr 15 19:38:16 athlon--80gb init: mythtv-backend main process (6026) terminated with status 254
Apr 15 19:38:16 athlon--80gb init: mythtv-backend main process ended, respawning
Apr 15 19:38:21 athlon--80gb init: mythtv-backend main process (6037) terminated with status 254
Apr 15 19:38:21 athlon--80gb init: mythtv-backend main process ended, respawning
...
killing the mythbackend brought some peace

I still have these network outgoing bursts every 3 second. Is there something like iotop for network ('nettop') to see which programs are doing this?

Sebastien Bacher (seb128) wrote :

do you get the issue in a guest session?

Sebastien Bacher (seb128) wrote :

closing the gthumb task since lucid uses the old serie now

Changed in gthumb (Ubuntu):
importance: Undecided → Low
status: New → Fix Released
ullix (ullix) wrote :

Sebastian,
testing a guest session for the presence of the session function on the panel, missing on my desktop, would first require the presence of that session function on my desktop, which would render testing the guest session irrelevant :-(
Or is there a different way to login as guest?

Michael (mnichau) wrote :

I have a very similar firefox-icon related problem ullix mentioned in his point 1). I just upgraded to Lucid today, and in my case, both Gnome panel AND Applications->Internet menu have the default icon-not-found icons.

There's a thread about it on ubuntu forums as well: http://ubuntuforums.org/showthread.php?p=9322472#post9322472

I also commented about it under Bug #518985, but that one's technically about Lucid Alpha 2 and I'm talking about the final version.

papukaija (papukaija) on 2010-09-11
tags: added: karmic2lucid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers