Polkit support lost: cannot add language

Bug #1292868 reported by Lars Noodén on 2014-03-15
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
lxsession (Ubuntu)
Undecided
Julien Lavergne

Bug Description

The desktop cannot add additional languages. The following error pops up:

org.freedesktop.PolicyKit.Error.Failed: ('system-bus-name', {'name': ':1.47'}): org.debian.apt.install-or-remove-packages

It happens each and every time.

To get the error,

LXDE Menu->Preferences->Language Support->Install/Remove Languages (then select a language to try to add)

What should happen instead is that the selected language gets installed. What happens unfortunately is the error message above.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: language-selector-gnome 0.123
ProcVersionSignature: Ubuntu 3.13.0-17.37-generic 3.13.6
Uname: Linux 3.13.0-17-generic i686
ApportVersion: 2.13.3-0ubuntu1
Architecture: i386
CurrentDesktop: LXDE
Date: Sat Mar 15 16:42:03 2014
InstallationDate: Installed on 2014-03-15 (0 days ago)
InstallationMedia: Lubuntu 14.04 "Trusty Tahr" - Alpha i386 (20140314)
PackageArchitecture: all
SourcePackage: language-selector
UpgradeStatus: No upgrade log present (probably fresh install)

Lars Noodén (larsnooden) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1292868

tags: added: iso-testing
Lars Noodén (larsnooden) wrote :

Same system works fine under Unity. The problem seems to be under LXDE.

Gunnar Hjalmarsson (gunnarhj) wrote :

So it seems.

Are you sure that all files are there that should be present? Is lubuntu-desktop installed?

Also, it might give additional info if you open a terminal window and start Language Support from there (use the command gnome-language-selector).

tags: added: lubuntu
Lars Noodén (larsnooden) wrote :

lubuntu-desktop is installed, version 0.55 Running gnome-language-selector from the terminal gives the same error. Running it as root eliminates the error.

Gunnar Hjalmarsson (gunnarhj) wrote :

Ok, thanks. Hopefully someone in the Lubuntu team get sight of this bug report soon.

Julien Lavergne (gilir) wrote :

It's the polkit support which have been lost with last update of lxsession. As a temporary solution, you can install lxpolkit, and reboot. That should fix the problem until I make the proper fix.

affects: language-selector (Ubuntu) → lxsession (Ubuntu)
Changed in lxsession (Ubuntu):
assignee: nobody → Julien Lavergne (gilir)
status: New → In Progress
Julien Lavergne (gilir) on 2014-03-17
summary: - Cannot add language
+ Polkit support lost: cannot add language
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxsession - 0.4.9.2+git20140317-0ubuntu1

---------------
lxsession (0.4.9.2+git20140317-0ubuntu1) trusty; urgency=medium

  * New upstream snapshot, only bug fixes:
   - Fix some help texts.
   - Re-enable buildin support for polkit (LP: #1292868)
   - Fix exporting environment variables twice (LP: #1278062)
  * debian/patches/100_disable_Werror.patch:
   - Refresh.
 -- Julien Lavergne <email address hidden> Mon, 17 Mar 2014 22:01:25 +0100

Changed in lxsession (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers