run dialog called from one desktop opens on the desktop with preferences dialog, regardless of which desktop is current

Bug #1445818 reported by Lyn Perrine on 2015-04-18
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
lxpanel (Ubuntu)
Low
Unassigned

Bug Description

STEPS TO REPRODUCE
 1. right click on lxpanel
 2. left click "Panel Settings" option from context menu (leave this window open)
 3. switch to a different desktop with any means (control alt right mousewheel over desktop, alt mouse wheel, using the desktop pager on the panel, client list menu by middle clicking on the desktop background, super f2)
 4. launch the run dialog by any means (alt-f2, super+r, from the menu select "Run", `lxpanelctl run` from a terminal)

EXPECTED RESULTS
When you call for the run dialog, it appears on your current desktop.

ACTUAL RESULTS
No run dialog will appear on your current desktop but if you switch back to the desktop the preferences dialog is on, the run dialog will appear on that desktop.

AFFECTS
 * lxpanel 0.7.2-1ubuntu2 (probably 0.7.2-1ubuntu1, too)
 * daily images starting 1 February 2015 and on

DOES NOT AFFECT
 * Precise (lxpanel 0.5.8+git20120212-0ubuntu3)
 * Trusty (lxpanel 0.6.1-0ubuntu3)
 * Utopic (lxpanel 0.6.2-0ubuntu2)

Lyn Perrine (walterorlin) wrote :
Lyn Perrine (walterorlin) wrote :

I am unable to reproudce this bug with lxpanel 0.6.1 in trusty so this might be caused by newer code and have not existed that long.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1445818

tags: added: iso-testing
description: updated
Walter Lapchynski (wxl) on 2015-04-22
description: updated
summary: - run dialog opens on desktop with lxpanel config not current desktop
+ run dialog called from one desktop opens on the desktop with preferences
+ dialog, regardless of which desktop is current
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxpanel (Ubuntu):
status: New → Confirmed
Walter Lapchynski (wxl) on 2015-04-22
description: updated
Walter Lapchynski (wxl) on 2015-04-22
description: updated
description: updated
Walter Lapchynski (wxl) wrote :

alpha2 is 0.6.2-0ubuntu2 and beta1 is 0.7.2-1ubuntu2. Even the intermediary 0.7.2-1ubuntu1 is not to be found in any official release. Anyone have any old dailies laying around from between 20 Jan and 24 Feb?

description: updated
Walter Lapchynski (wxl) wrote :

Please note that the i386 build of 0.7.2-1ubuntu1 doesn't include lxpanel-data, whatever that means. Not much changed in it, anyways. tl;dr, problem lies somewhere in 0.7.

Changed in lxpanel (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
description: updated
Walter Lapchynski (wxl) wrote :

More specifically 0.7.2-1ubuntu1 was published on 1 Feb and 0.7.2-1ubuntu2 was published on 3 Feb.

description: updated
tags: added: i386 lubuntu
sudodus (nio-wiklund) wrote :

This bug affects me too, but only when the "Panel Settings" option window is open. Why should it be left open?

Otherwise the run window appears in the current desktop (where it should appear).

Walter Lapchynski (wxl) wrote :

It's not a matter of should or shouldn't. It's a matter that if it was, it doesn't behave right. This should have other effects.

LStranger (andrej-rep) wrote :

Is any other window affected by this bug or only "Run" dialog? And have you tried 0.8.0 version from Lubuntu-dev PPA, is this bug still present in it? Thank you.

Lyn Perrine (walterorlin) wrote :

I have only found the run dialog to be effected by this. I tried 0.8.1 from the lubuntu-dev ppa and still got same behaviour of this bug.

Walter Lapchynski (wxl) wrote :

Confirmed in Lubuntu Xenial i386 Alpha 1.

tags: added: xenial
description: updated
Simon Quigley (tsimonq2) wrote :

Confirmed in Lubuntu Xenial Xerus Alpha 2.

Simon Quigley (tsimonq2) wrote :

Confirmed in Lubuntu Yakkety Yak Alpha 1.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxpanel - 0.9.1-1ubuntu1

---------------
lxpanel (0.9.1-1ubuntu1) zesty; urgency=medium

  * Merge with Debian unstable. Ubuntu remaining changes:
  * debian/control:
   - Add libindicator-dev build-depends.
   - Add lxpanel-indicator-applet-plugin binary.
   - Add build-depends on libicu-dev for weather plugin.
   - Update Replaces and Breaks on lxpanel-data (LP: #1417244).
  * debian/lxpanel.install:
   - Install all plugins except indicators.
  * debian/lxpanel-indicator-applet-plugin.install:
   - Install indicator plugin.
  * debian/rules:
   - Add --enable-indicator-support flag.
   - Add dh_install --fail-missing.
   - Re-enable dh_makeshlibs, FTBFS with lxpanel-indicator-applet-plugin.
  * debian/patches:
   - 04_disable_gtk3_indicators.patch: Hide incompatible indicators in the
     preference menu (LP: #1165245).

lxpanel (0.9.1-1) unstable; urgency=medium

  [ Andriy Grytsenko ]
  * Merging upstream version 0.9.1 (Closes: #845060).
  * Using aumix-gtk on !linux-any instead of gnome-alsamixer.

  [ Pino Toscano ]
  * Making sure that ALSA is always disabled for non-Linux architectures.

lxpanel (0.9.0-1) unstable; urgency=medium

  * Merging upstream version 0.9.0 (Closes: #831866, LP: #824071, #1445818,
    #1474936, #1490098, #1537334, #1533308, #1539930, #1555649, #1581708,
    #1583833, #1615326).
  * Bump Standards-Version to 3.9.8.
  * Updating debian/lxpanel.lintian-overrides for multiarch.
  * Updating lxpanel.hints.5 manpage.
  * Updating debian/lxpanel.README.Debian removing section about lxpanel-dev.
  * Updating debian/copyright file.

 -- Julien Lavergne <email address hidden> Sat, 26 Nov 2016 11:39:13 +0100

Changed in lxpanel (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers