lxdm-binary load 100% cpu

Bug #892683 reported by max steel on 2011-11-20
84
This bug affects 21 people
Affects Status Importance Assigned to Milestone
lxdm (Ubuntu)
Undecided
Unassigned

Bug Description

after system update today (20-11-2011), the lxdm-binary took all of my cpu resource (more than 50% on task-manager list and 100% on gnome-system-monitor). so my laptop heat increase significanly. (my laptop is Compaq CQ40-412AU).

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: lxdm 0.4.1-0ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: fglrx
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Sun Nov 20 12:09:30 2011
ExecutablePath: /usr/sbin/lxdm-binary
InstallationMedia: Lubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcEnviron: LANG=en_US.UTF-8
SourcePackage: lxdm
UpgradeStatus: No upgrade log present (probably fresh install)

max steel (max-steel-0000) wrote :
Timo Sulg (timgluz) wrote :

I have Ubuntu 11.04 and just installed lxdm with version (0.3.0) and i had similar problem. Best solution so far is to forgot lxdm.

lan1967 (5tarasm) wrote :

I have Ubuntu 11.10
I get the following report about lxdm
USER PID %CPU %MEM VSZ RSS TTY STAT START TIME COMMAND

root 1127 80.0 0.1 5236 2448 ? Rs 17:16 0:49 lxdm-binary

If I kill the proccess the sound is not playing.
Thank you for your attention.

lan1967 (5tarasm) wrote :

Acer - Aspire-5315 3.0.0-15-generic #25-Ubuntu SMP Mon Jan 2 17:45:26 UTC 2012 i686 i686 i386 GNU/Linux
Architecture: i386
lxdm 0.4.1-0ubuntu4

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxdm (Ubuntu):
status: New → Confirmed
SBKch (ssbkch) on 2012-03-30
tags: added: amd64 lxde
SBKch (ssbkch) wrote :

This bug makes my system almost unusable..
oneiric
lxde 0.5.0-4ubuntu3
libglib2.0-0 2.31.23+git20120319.322c6e93-0ubuntu1~11.10~ricotz0 - can't downgrade because it would broke system, gimp 2.7.x/2.8.x requires it

SBKch (ssbkch) wrote :

lxdm 0.4.1-0ubuntu4
sudo killall -s 9 lxdm-binary helps temporary

caludo (b-l-e-y) wrote :

I'm on precise, lxdm version 0.4.1-0ubuntu6.

Process hierarchy:

lxdm-binary
-> awesome
->/usr/bin/X -background none :0 vt07 -nolist ...

Here is an strace of the lxdm-binary after login with an awesome window manager session.

ls -lh /proc/1442/fd

lrwx------ 1 root root 64 Apr 30 15:03 0 -> /dev/null
l-wx------ 1 root root 64 Apr 30 15:03 1 -> /var/log/lxdm.log
l-wx------ 1 root root 64 Apr 30 15:03 2 -> /var/log/lxdm.log
l-wx------ 1 root root 64 Apr 30 15:03 3 -> /var/log/lxdm.log
lrwx------ 1 root root 64 Apr 30 15:03 4 -> socket:[11506]
lrwx------ 1 root root 64 Apr 30 15:03 5 -> socket:[11508]
lrwx------ 1 root root 64 Apr 30 15:03 6 -> anon_inode:[eventfd]
lrwx------ 1 root root 64 Apr 30 15:03 7 -> socket:[11688]
lrwx------ 1 root root 64 Apr 30 15:03 8 -> socket:[15049]
lr-x------ 1 root root 64 Apr 30 10:10 9 -> socket:[15514]

Sworddragon (sworddragon) wrote :

The problem appears only if ecryptfs is used. A workaround is to login into your console before login with LXDM. After this you can logout from your console. I have opened a report here too: https://bugs.launchpad.net/ubuntu/+source/lxdm/+bug/922363
There is a link to an upstream bug report and a patch with the changes dgod has posted on the upstream report.

Sworddragon (sworddragon) wrote :

Here is the upstream report: http://sourceforge.net/tracker/index.php?func=detail&aid=3548688&group_id=180858&atid=894869
I have attached the patch here too.

The attachment "login_ecryptfs.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Marc MAURICE (dooblem) wrote :

The patch works with a tiny change.

Here is the new patch.

I confess I tested it in Manjaro Linux, but it should be the same on Ubuntu.

Gromobir (gromobir) wrote :

Unfortunately, this still doesn't work in the latest Trisquel release. Can anyone confirm that Ubuntu itself isn't affected anymore?

Sworddragon (sworddragon) wrote :

> Can anyone confirm that Ubuntu itself isn't affected anymore?

On Ubuntu 13.10 dev lxdm-binary is still using 100% of cpu time of one core.

Bob Barry (bobb40) wrote :

Is this ever going to be fixed? I'm running Trisquel Toutatis Mini, and still have to login to console before lxde login to avoid 100% usage by lxde. Apt-get shows my system fully up-to-date.

Sworddragon (sworddragon) wrote :

> Is this ever going to be fixed?

I would like seeing this fixed too especially as we have a patch here that could be maybe used as a package specific changeset.

The next LTS release is comming and this major bug does unfortunately preventing me from recommending Ubuntu with LXDE to other persons as such workarounds are not acceptable for normal users.

Gromobir (gromobir) wrote :

I agree: Please fix this.

Sworddragon (sworddragon) wrote :

I'm now on Ubuntu 15.04 dev with lxdm 0.5.0-1 and the bug doesn't appear there anymore.

Changed in lxdm (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.