CTRL + ALT + L does not work in lubuntu 13.10

Bug #1242276 reported by Markus J Schmidt on 2013-10-20
80
This bug affects 16 people
Affects Status Importance Assigned to Milestone
lubuntu-default-settings (Ubuntu)
Medium
Unassigned

Bug Description

When pressing CTRL + ALT + L in the lubuntu release 13.10 (saucy), only an message window appears: "Openbox: Failed to execute child process "xscreensaver command (no such file or directory)".

I already found the bug:
The reason is an old assignment of openbox the xscreensaver, which is not used in saucy. The config file ~/.config/openbox/lubuntu_rc.xml has to be changed. I added my changed file where I replaced xscreensaver command with "dm-tool lock".

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: openbox 3.5.2-3
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
ApportVersion: 2.12.5-0ubuntu2
Architecture: amd64
Date: Sun Oct 20 10:43:13 2013
InstallationDate: Installed on 2013-10-20 (0 days ago)
InstallationMedia: Lubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MarkForUpload: True
SourcePackage: openbox
UpgradeStatus: No upgrade log present (probably fresh install)

Markus J Schmidt (smiddy84) wrote :
description: updated
Lars Noodén (larsnooden) wrote :

I get the same error dialog in amd64+mac.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openbox (Ubuntu):
status: New → Confirmed
description: updated

The attachment "Changed openbox config file ~/.config/openbox/lubuntu_rc.xml" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch

adding bugs related to this same issue:

#1204052

#1241901

best regards,
ibere

Mateusz Łukasik (mati75) wrote :

It's lubuntu-default-settings bug, not openbox.

Changed in lubuntu-default-settings (Ubuntu):
status: New → Confirmed
Changed in openbox (Ubuntu):
status: Confirmed → Invalid
no longer affects: openbox (Ubuntu)
Stefan Stefanov (s-stefanov) wrote :

Patched lubuntu_rc.xml from comment #1 works!

Lyn Perrine (walterorlin) wrote :

Hitting control alt L does not seem to be working in the current trusty daily.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1242276

tags: added: iso-testing
Paul White (paulw2u) on 2014-01-18
tags: added: trusty
Changed in lubuntu-default-settings (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Severin Wünsch (sk1d) wrote :

Is there a workaround to fix this?

Changed in lubuntu-default-settings (Ubuntu):
status: Triaged → Fix Released
Ben Zuber (aseedb) wrote :

I have just installed lubuntu over ubuntu 14.04. The bug is still present in the currently distributed lubuntu. Editing lubuntu_rc.xml works though.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers