notification dialog has horizonal bars

Bug #1362555 reported by Lars Noodén on 2014-08-28
186
This bug affects 38 people
Affects Status Importance Assigned to Milestone
lubuntu-artwork (Ubuntu)
Low
Redwolf

Bug Description

STEPS TO REPRODUCE:
1. Install libnotify-bin
2. Using the terminal, send a test notification with `notify-send -u normal "Hello" "Testing"`

EXPECTED RESULTS:
A clean looking notification.

ACTUAL RESULTS:
The notification has horizontal bars running through it.

ROOT CAUSE:
/usr/share/themes/Lubuntu-default/gtk-2.0/images/panel-bg.png is being used for the panel and is tiled. Previous versions did not have this.

WORKAROUND:
Remove /usr/share/themes/Lubuntu-default/gtk-2.0/images/panel-bg.png.

AFFECTED VERSIONS:
14.10 and 15.04.

Lars Noodén (larsnooden) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1362555

tags: added: iso-testing
Brendan Perrine (walterorlin) wrote :

This is actually xfce4-notiyd is the package for this not lxpanel that makes the notifications.

affects: lxpanel (Ubuntu) → xfce4-notifyd (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-notifyd (Ubuntu):
status: New → Confirmed
Brendan Perrine (walterorlin) wrote :

I am able to reproduce this bug with the lubuntu and lubuntu-dark panel gtk2 widgets but using any other widget works as a workaround.

Simon Steinbeiß (ochosi) wrote :

Looks like broken theming. You can easily check by installing the package shimmer-themes and setting the notification theme (in xfce4-notifyd-config) to "Greybird". That should fix it.

Redwolf (viking.redwolf) wrote :

I'm testing right now, but with 14.04 machine, sorry. Anyway, the theme hasn't changed from 14.04 to 14.10 so it must look well. For Lubuntu you must use the lubuntu-art/daily PPA and it should fix it.

Hans de Vries (tijdelijk386) wrote :

It is also easy to switch off the notifications:
Open terminal (ctrl+alt+t)
cd /usr/share/dbus-1/services
sudo mv org.xfce.xfce4-notifyd.Notifications.service org.xfce.xfce4-notifyd.Notifications.service.disable

Redwolf (viking.redwolf) wrote :

If there's any system with this bug we need to fix it. It's not a good idea turning off the notification system. I'll test on both environments, updating Box themes (with a re-merge from Ubuntu's Light Themes) and using Shimmer notify skin. That should be enough.

Tabasc0 (tabasco) wrote :

It's a theme bug. on a 14.10 fresh install, xfce4-notifyd is using /usr/share/themes/Lubuntu-default/gtk-2.0/images/panel-bg.png for background, and it tiles the image to fill the box
On my 14.04, there no panel-bg.png, so the notification box is plain. So as a workaround, i deleted this file. I've lost the shading of the panel, but the notifications are much more readable.

Brendan Perrine (walterorlin) wrote :

I get this same theme bug on vivid.

tags: added: vivid
Walter Lapchynski (wxl) on 2014-11-11
Changed in xfce4-notifyd (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Walter Lapchynski (wxl) wrote :

Marked as low due to workaround.

description: updated
affects: xfce4-notifyd (Ubuntu) → lubuntu-artwork (Ubuntu)
Walter Lapchynski (wxl) wrote :

An interesting observation:
 * /usr/share/themes/Lubuntu-default/gtk-2.0/apps/lubuntu_lxpanel.rc specifies the use of the image with bg_pixmap, while xfce4-notify.rc uses a plain bg.
 * If you remove the png, lxpanel still appears to use it. Notifications will have a black background.
 * If you change lubuntu_lxpanel.rc to specify a color instead, it will use that (you have to `lxpanelctl restart). Still black backgrounds for notifications.
 * If you make any changes to xfce4-notify.rc, none of them will have any effect.

Walter Lapchynski (wxl) on 2014-11-19
Changed in lubuntu-artwork (Ubuntu):
assignee: nobody → Lubuntu Artwork (lubuntu-art)
Tom Barry (tbarry1a) wrote :

Here is what I did to help with this issue:
Using gimp or another image editor, edit and replace the file:
/usr/share/themes/Lubuntu-default/gtk-2.0/images/panel-bg.png to be 300 by 300 pixels.

Then ising vim, edit:

/usr/share/themes/Lubuntu-default/gtk-2.0/apps/xfce4-notifyd.rc

to change the notify-text color from:

style "notify-text"
{
    fg[NORMAL] = "#ffffff"
    GtkWidget::link-color = "#a7a7a7"
}

To:

style "notify-text"
{
    fg[NORMAL] = "#000000"
    GtkWidget::link-color = "#a7a7a7"
}

This changes the notification text from white to black

Redwolf (viking.redwolf) wrote :

The problem is the panel won't "stretch" the background to adapt to 24px sizes if it's 300px now. Nice solution, but we want the panel look nice too.

Walter Lapchynski (wxl) wrote :

Maybe we should use a different default theme if this can't be readily fixed?

Redwolf (viking.redwolf) wrote :

We should get ridd off this notifier. It's giving problems to XFCE itself. But yes, I'll start looking for another theme right now, only for this.

Walter Lapchynski (wxl) wrote :

Might be a better solution, ultimately. What would you suggest?

Redwolf (viking.redwolf) wrote :

None. I'll made one by scratch, to ensure it works. The current one used to work. Alex designed it using parts of another, and it worked really fine for two releases. Until now, due to notify changes.

Redwolf (viking.redwolf) wrote :

After doing another theme from scratch, and testing 16 more themes, and everything fails, I'm going to re-send this bug to XFCE guys. The notification dialog takes bitmaps from the wrong place. No matter if you specify another source, it ALWAYS gets the gnome / xfce / lxde panel background. It's impossible to use separate images for both desktop elements.

affects: lubuntu-artwork (Ubuntu) → xfce4-notifyd (Ubuntu)
Changed in xfce4-notifyd (Ubuntu):
assignee: Lubuntu Artwork (lubuntu-art) → nobody
Redwolf (viking.redwolf) on 2015-05-26
affects: xfce4-notifyd (Ubuntu) → lubuntu-artwork (Ubuntu)
Changed in lubuntu-artwork (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Rafael Laguna (rafaellaguna)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-artwork - 0.55

---------------
lubuntu-artwork (0.55) wily; urgency=medium

  * Backup current artwork items to 1504 items, and prepare 1510 ones.
  * src/lib/plymouth/themes/lubuntu-text:
   - Update to 15.10.
  * src/usr/share/icons:
   - Update icons theme.
  * src/usr/share/themes/Lubuntu-default/
   - Update current theme.
   - Fix gtk3 bugs (LP: #1464349).
   - Fix notification dialog (LP: #1362555).
   - Don't use some GTK3 theming for thunar (LP: #1459988)

 -- Julien Lavergne <email address hidden> Tue, 11 Aug 2015 20:04:34 +0200

Changed in lubuntu-artwork (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers