SRU: Revert of initramfs package removal in KVM image

Bug #1880170 reported by Philip Roche
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
Fix Released
Medium
Unassigned
Eoan
Fix Released
Medium
Unassigned
Focal
Fix Released
Medium
Unassigned

Bug Description

No packages marked for auto-removal should be present in a published cloud image.

The current kvm binary hook in livecd-rootfs removes the packages `initramfs-tools` and `busybox-initramfs`. This results in many packages [1] being marked for auto-removal. These packages are still required in the image and should not be marked for auto-removal.

The removal of initramfs-tools and busybox-initramfs was to avoid the
generation of initramfs in images that should boot initramfsless.

This requirement is obsolete now because the initramfsless boot handling
is now handled via setting GRUB_FORCE_PARTUUID in /etc/default/grub.d/40-force-partuuid.cfg.

[Impact]

 * No packages marked for auto-removal. This is a requirement for all public cloud images.

[Test Case]

 * Perform livefs build with project ubuntu-base
 * Boot *-disk-kvm.img using kvm
   * Confirm it boots
   * Confirm there is no boot speed regression
   * Confirm that running `sudo apt-get autoremove` results in no packages being removed
   * Verify that `GRUB_FORCE_PARTUUID` is set in /etc/default/grub.d/40-force-partuuid.cfg.

[Regression Potential]

 * Boot speed regression
 * Unable to boot KVM image

[Other Info]

 * Original bug filed against cloud-images @ https://bugs.launchpad.net/cloud-images/+bug/1875400
 * MP already merged in to ubuntu/master @ https://code.launchpad.net/~philroche/livecd-rootfs/+git/livecd-rootfs/+merge/384105
 * livecd-rootfs version 2.667 in groovy was uploaded with this patch and was verified

[1] apport apport-symptoms at bc bcache-tools bolt btrfs-progs byobu cryptsetup cryptsetup-bin cryptsetup-run dmeventd ethtool finalrd
  fonts-ubuntu-console fwupd fwupd-signed git git-man htop initramfs-tools-bin klibc-utils kpartx landscape-common libaio1 libarchive13
  libcurl3-gnutls libdevmapper-event1.02.1 liberror-perl libevent-2.1-7 libfl2 libfwupd2 libfwupdplugin1 libgcab-1.0-0 libgpgme11
  libgudev-1.0-0 libgusb2 libisns0 libjson-glib-1.0-0 libjson-glib-1.0-common libklibc liblvm2cmd2.03 libmspack0 libreadline5
  libsgutils2-2 libsmbios-c2 libtss2-esys0 liburcu6 libutempter0 libxmlb1 libxmlsec1 libxmlsec1-openssl libxslt1.1 lvm2 lxd-agent-loader
  lz4 mdadm open-iscsi open-vm-tools patch pollinate python3-apport python3-automat python3-click python3-colorama python3-constantly
  python3-debconf python3-debian python3-hamcrest python3-hyperlink python3-incremental python3-newt python3-problem-report python3-pyasn1
  python3-pyasn1-modules python3-service-identity python3-systemd python3-twisted python3-twisted-bin python3-zope.interface run-one
  screen sg3-utils sosreport thin-provisioning-tools tmux tpm-udev update-notifier-common xfsprogs zerofree

Related branches

Philip Roche (philroche)
description: updated
Revision history for this message
Philip Roche (philroche) wrote :

debdiff for focal SRU

Revision history for this message
Philip Roche (philroche) wrote :

debdiff for eoan SRU

Revision history for this message
Philip Roche (philroche) wrote :

debdiff for focal SRU rev2. Building package without extraneous contents as per https://www.debian.org/doc/manuals/debmake-doc/ch05.en.html#build-noextra

Revision history for this message
Philip Roche (philroche) wrote :

debdiff for eoan SRU rev2. Building package without extraneous contents as per https://www.debian.org/doc/manuals/debmake-doc/ch05.en.html#build-noextra

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "lp-1880170-kvm-revert-of-initramfs-package-removal-focal-rev2.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Mathew Hodson (mhodson)
Changed in livecd-rootfs (Ubuntu):
importance: Undecided → Medium
Changed in livecd-rootfs (Ubuntu Eoan):
importance: Undecided → Medium
Changed in livecd-rootfs (Ubuntu Focal):
importance: Undecided → Medium
Changed in livecd-rootfs (Ubuntu):
status: New → Fix Released
tags: added: id-5eb57a2c4e0e137de504ab3e
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Philip, or anyone else affected,

Accepted livecd-rootfs into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.664.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in livecd-rootfs (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed verification-needed-focal
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Hello Philip, or anyone else affected,

Accepted livecd-rootfs into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.620.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in livecd-rootfs (Ubuntu Eoan):
status: New → Fix Committed
tags: added: verification-needed-eoan
Revision history for this message
Philip Roche (philroche) wrote :

Verification of livecd-rootfs 2.664.2 in focal -proposed completed.

The following verification was completed.

 * Perform livefs build with project ubuntu-base
 * Boot *-disk-kvm.img using kvm
   * Confirm it boots
   * Confirm there is no boot speed regression
   * Confirm that running `sudo apt-get autoremove` results in no packages being removed
   * Verify that `GRUB_FORCE_PARTUUID` is set in /etc/default/grub.d/40-force-partuuid.cfg.

See test images @
https://people.canonical.com/~philroche/lp-1880170-Revert-of-initramfs-package-removal-in-KVM-image/focal/

Revision history for this message
Philip Roche (philroche) wrote :

Verification of livecd-rootfs 2.620.3 in eoan -proposed completed.

The following verification was completed.

 * Perform livefs build with project ubuntu-base
 * Boot *-disk-kvm.img using kvm
   * Confirm it boots
   * Confirm there is no boot speed regression
   * Confirm that running `sudo apt-get autoremove` results in no packages being removed
   * Verify that `GRUB_FORCE_PARTUUID` is set in /etc/default/grub.d/40-force-partuuid.cfg.

See test images @
https://people.canonical.com/~philroche/lp-1880170-Revert-of-initramfs-package-removal-in-KVM-image/eoan/

tags: added: verification-done verification-done-eoan verification-done-focal
removed: verification-needed verification-needed-eoan verification-needed-focal
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.620.3

---------------
livecd-rootfs (2.620.3) eoan; urgency=medium

  * Revert of initramfs package removal in KVM image (LP: #1880170)

 -- Phil Roche <email address hidden> Fri, 22 May 2020 13:03:20 +0100

Changed in livecd-rootfs (Ubuntu Eoan):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for livecd-rootfs has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.664.2

---------------
livecd-rootfs (2.664.2) focal; urgency=medium

  * Revert of initramfs package removal in KVM image (LP: #1880170)

 -- Phil Roche <email address hidden> Fri, 22 May 2020 13:03:20 +0100

Changed in livecd-rootfs (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers