Comment 10 for bug 1513529

St├ęphane Graber (stgraber) wrote :

This is causing problem for LXD users on Xenial as our instructions say to use "apt install -t xenial-backports lxd" to get the latest non-LTS release of LXD on 16.04 LTS.

We've had report from MAAS users that xenial-backports isn't enabled on otherwise clean systems. This appears to be because MAAS instructs cloud-init not to regenerate sources.list, therefore using the original sources.list from the cloud image.

We'd very much appreciate some consistency there as having to instruct folks to manually mangle their sources file isn't exactly ideal, especially when it's unneeded in 90% of the case.