Build 12.04.2 images with X enablement (lts-quantal) stack

Bug #1098512 reported by Colin Watson
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
Undecided
Unassigned
Precise
Critical
Colin Watson

Bug Description

[Impact] We have committed to delivering the X enablement stack by default for 12.04.2.
[Test Case] Install system with old images and take a copy of /var/lib/apt/ (primarily extended_states). Install system with new images. Check that the X enablement stack is installed. Get a package management expert from Foundations to compare /var/lib/apt/extended_states before and after and check that any changes in auto-installed states are acceptable.
[Regression Potential] Aside from any possible X regressions, which I think are principally the responsibility of the (separately SRUed) X changes rather than this one, the main possible source of regressions from this change would be changes in auto-installed states. See below.

For 12.04.2, we need to build desktop images with the X lts-quantal stack in cases where they are already being built with the lts-quantal kernel (i.e. ubuntu, ubuntu-dvd, edubuntu, and edubuntu-dvd). This involves installing xserver-xorg-lts-quantal rather than xserver-xorg.

Unfortunately there is no non-invasive way to do this as far as I've been able to tell, because at present we can't regenerate tasks for stable releases - or, at least, if we do so there's no way to *remove* xserver-xorg and friends from the task. The only way to do this while still using tasks is to install the task and then install xserver-xorg-lts-quantal over the top, thereby removing xserver-xorg and friends. Not only is this extremely painful to arrange with the version of live-build in precise, but it would likely also result in significant amounts of library cruft remaining in the image. Removing that would entail a considerable amount of unmaintainable hardcoding.

Thus, with some regret, the only idea I have is to switch the images in question to install metapackages rather than tasks. This carries some risk because it may cause apt to have a different idea of which packages are auto-installed, and thus potentially cause problems for future upgrades. We'll simply need to keep a close eye on the results and make sure any changes in apt's extended states are acceptable.

Colin Watson (cjwatson)
Changed in livecd-rootfs (Ubuntu):
status: New → Invalid
Changed in livecd-rootfs (Ubuntu Precise):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Colin Watson (cjwatson)
milestone: none → ubuntu-12.04.2
Revision history for this message
Adam Conrad (adconrad) wrote : Please test proposed package

Hello Colin, or anyone else affected,

Accepted livecd-rootfs into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/livecd-rootfs/2.65.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in livecd-rootfs (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Colin Watson (cjwatson) wrote :

OK. So, as expected, lots more packages end up marked as auto-installed following this change (see attachment). I think that was pretty much inevitable. I've looked through the changes and they all seem broadly reasonable, though - the top-level metapackages and such are still marked as manually installed. In some ways I suppose you might argue that this is really better, although it does mean that people who remove metapackages will see lots of stuff offered for autoremove - but they might even want that sometimes, and we did always say that people who removed our metapackages were on their own.

I think this is about the best we can reasonably do in the circumstances.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Colin Watson (cjwatson) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.65.9

---------------
livecd-rootfs (2.65.9) precise; urgency=low

  * Add xserver-xorg-lts-quantal to Mythbuntu amd64/i386 as well.

livecd-rootfs (2.65.8) precise; urgency=low

  * live-build/auto/config:
    - Add some manual hints to work around slightly different dependency
      resolution for metapackages vs. tasks.
    - Use kernel and X enablement stacks for Mythbuntu amd64/i386 too.

livecd-rootfs (2.65.7) precise; urgency=low

  * live-build/auto/config: Build Ubuntu and Edubuntu images with X
    enablement stack on amd64 and i386 (LP: #1098512). Note that this
    requires switching those images to be built largely using metapackages
    rather than tasks.
 -- Colin Watson <email address hidden> Tue, 15 Jan 2013 18:00:15 +0000

Changed in livecd-rootfs (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers