Add missing lircd.conf and lircrc for the ASUS MyCinema P7131 Hybrid TV card

Bug #190018 reported by Gianfranco Liporace on 2008-02-07
8
Affects Status Importance Assigned to Milestone
lirc (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: mythtv

Hi,
attached to this bug report there is a lirc.conf file and lircrc for mythtv for the ASUS MyCinema P7131 Hybrid remote.
The device work through the input/event interface, so the device name can change on every reboot.
A udev rule could be useful here so a device name like '/dev/remote' can be used in configuring the device in hardware.conf.

Gianfranco Liporace (dr.kabuto) wrote :
Gianfranco Liporace (dr.kabuto) wrote :
Murat Gunes (mgunes) on 2008-02-07
Changed in mythtv:
importance: Undecided → Wishlist
Mario Limonciello (superm1) wrote :

Assigning this to the proper package (lirc)

Mario Limonciello (superm1) wrote :

Hi i've got this fixed locally. Would you mind submitting the remote upstream though to the LIRC project so that all distros can benefit? Thank you.

Changed in lirc:
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lirc - 0.8.3~pre1-0ubuntu7

---------------
lirc (0.8.3~pre1-0ubuntu7) hardy; urgency=low

  [ Mario Limonciello ]
  * Fix a logical error in the init script related
    to udev preventing it from working. (LP: #176616)
  * Fix race conditions with udev (LP: #204672)
  * Backup hardware.conf before changing. (LP: #198903)
  * Add support for the Medion MD1-NBC remote. (LP: #192392)
    - Thanks Florian Fahr
  * Add support for the Hauppauge HVR-1100 remote (LP: #203493)
    - Thanks Lucas
  * Flag repeat events on apple mac mini (LP: #179608)
    - Thanks Don Mahurin
  * Add support for Radioshack 15-2116 remote (LP: #193568)
    - Thanks Scott D
  * Add support for ASUS MyCinema P7131 remote (LP: #190018)
    - Thanks Gianfranco Liporace

  [ Mathias Hasselmann ]
  * Add 28_irrecord_resume_support for resume support to
    irrecord. (LP: #197493)

  [ Andrew Barbaccia ]
  * Fix typo in lirc init script preventing transmitter
    arguments from properly being built. (LP: #204664)
  * Update Scientific Atlanta config in 26_transmitter_lircd.conf.dpatch
    to better naming convention. (LP: #204342)

 -- Mario Limonciello <email address hidden> Sun, 23 Mar 2008 23:25:36 -0500

Changed in lirc:
status: In Progress → Fix Released
Gianfranco Liporace (dr.kabuto) wrote :

thanks very much, Mario!
I'll do what you've suggested as soon as possible!

bve (bve-telusplanet) wrote :

Sorry if this is the wrong place to post.

I am running an up to date Hardy with lirc - 0.8.3~pre1-0ubuntu7 installed and I have no support for my remote - no device is being created.

I have the ASUS MyCinema-P7131 Analog which uses the same PC-39 remote as the Hybrid, the TV / radio functions fine, yet no device is being created for the remote.

From what I read in the post https://bugs.launchpad.net/ubuntu/+source/lirc/+bug/190018/comments/5 above this should be working, I have posted in the forums http://ubuntuforums.org/showthread.php?t=798593 with 0 responses.

What am I missing? Is this a problem elsewhere, udev or hal, what can I do to try to resolve it, as every thread I have found pretty much leaves me looking for the device in the output from cat /proc/bus/input/devices which doesn't list the remote.

I read somewhere about a patch, should I need to apply a patch given this is supposed to be fixed with lirc - 0.8.3~pre1-0ubuntu7?

Again sorry if this is not the right place to be asking, however I am a bit lost on this.

bve wrote:
> Sorry if this is the wrong place to post.
>
> I am running an up to date Hardy with lirc - 0.8.3~pre1-0ubuntu7
> installed and I have no support for my remote - no device is being
> created.
>
> I have the ASUS MyCinema-P7131 Analog which uses the same PC-39 remote
> as the Hybrid, the TV / radio functions fine, yet no device is being
> created for the remote.
>
>>From what I read in the post
> https://bugs.launchpad.net/ubuntu/+source/lirc/+bug/190018/comments/5
> above this should be working, I have posted in the forums
> http://ubuntuforums.org/showthread.php?t=798593 with 0 responses.
>
> What am I missing? Is this a problem elsewhere, udev or hal, what can I
> do to try to resolve it, as every thread I have found pretty much leaves
> me looking for the device in the output from cat /proc/bus/input/devices
> which doesn't list the remote.
>
> I read somewhere about a patch, should I need to apply a patch given
> this is supposed to be fixed with lirc - 0.8.3~pre1-0ubuntu7?
>
> Again sorry if this is not the right place to be asking, however I am a
> bit lost on this.
>
This remote uses devinput. You will have to add in the
REMOTE_DEVICE=/dev/input/eventX after you identify which device it is supposed
to use. Place this in your /etc/lirc/hardware.conf

--
Mario Limonciello
<email address hidden>

bve (bve-telusplanet) wrote :

Thanks for the reply Mario.

I think in hindsight and further digging, probably this https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/141622 is the issue I am faced with instead, which suggests my particular version of the card requires a patch since there is no evidence of a device in /dev/input for the remote.

It seems evident from that bug report the patch never made it upstream, so I will pursue that, again thanks for the reply.

Hi bve,
can you post the output of dmesg so we can see what device is assigned to the remote?
Thanks!

bve (bve-telusplanet) wrote :

Attached is the output from dmesg, you will see there is no IR device in the output.

I have downloaded linux-source-2.6.24. sources and confirmed the patch described in 141622 is not in the saa7134.cards.c nor in sa7134.input.c

I just need time and a pointer on how to compile the module.

Also I would like to ensure the patch actually makes it upstream to the saa7134 maintainers would this be the v4l folks?

Thanks
Burke

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers