Comment 8 for bug 1004239

I now have LIRC compiled with the iguanaIR driver, but the LIRC install is still broken. Without the symlink fix, I get the ls error. With it, I still get

Errors were encountered while processing:
 lirc

I've tried apt-get clean, dpkg --configure -a and apt-get install -f, none fix the broken lirc install. It's a real pain since it won't let me install anything else. For example:

htpc@htpc:~$ sudo apt-get install samba-common
Reading package lists... Done
Building dependency tree
Reading state information... Done
samba-common is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up lirc (0.9.0-0ubuntu1) ...
dpkg: error processing lirc (--configure):
 subprocess installed post-installation script returned error exit status 20
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 lirc
E: Sub-process /usr/bin/dpkg returned an error code (1)

I'm pretty much a linux noob, and have no idea why a broken install of one package affects everything else. The only bright side is my IR blaster works again.