Ubuntu

External USB keyboard not working in Ubuntu 12.04

Reported by Mark Anderson on 2012-04-29
140
This bug affects 31 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Recently upgraded my Ubuntu 11.10 installation to 12.04 on my ThinkPad T400. I use dm-crypt which asks for password at boot. External USB keyboards will not work to type the password in. I must use the keyboard on the laptop itself, which is a problem since I use a docking station.

The USB keyboard works after I get into the GUI if I unplug it and plug it back in. I already ran a 'dpkg --configure -a' and a 'dpkg-reconfigure -a', with no luck.

I installed a fresh copy of 12.04 on the same system and have the same exact issue.

Let me know what debugging info you need, as well as how to retrieve it. This seems to be a serious bug that others are experiencing on other hardware platforms.

Kernel is 3.2.0-24.37-generic

Mark Anderson (c-st1ff-a) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/990870/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 990870

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Mark Anderson (c-st1ff-a) wrote :

I (unfortunately) cannot provide any additional debugging info, as I've switched to Debian Wheezy for this workstation.

There appear to be others having the same issue. Some suggestions include running "sudo apt-get -f install", which seems to fix it in xorg, but not in pre-boot. It's as if USB is not getting initialized in the initram. Some URLS are as follows:

http://askubuntu.com/questions/128513/mouse-and-keyboard-does-not-work-after-upgrade-to-12-04
http://askubuntu.com/questions/127410/upgrading-to-ubuntu-12-04-loses-keyboard-and-mouse

Googling "ubuntu 12.04 usb keyboard" brings up more.

I'm sorry that I can't provide any additional info at this point, but my occupation prohibits me from having a down primary workstation. I will see if I can acquire an additional ThinkPad today to provide additional debugging info from.

Changed in linux (Ubuntu):
importance: Undecided → Medium
Fredrik Wendt (fredrik-wendt) wrote :

I have a computer that's affected by this as well (and I've clicked the affects me above). When I run apport to report logs etc I get:
---
anton@the-blue-creeper:~$ apport-collect 990870

*** Error: Updating problem report

You are not the reporter or subscriber of this problem report, or the report is a duplicate or already closed.

Please create a new report using "apport-bug".
---
How can I get around this and report?

Desmond (desmond-armstrong) wrote :

With new install (12.04) I confirm this problem.

I can simply unplug keyboard and then re-plug and all is then well.

Serious problem as we cannot always be doing this every time we switch on computer.

With PS/2 connection no problem, just with the USB.

Consequence - cannot login in.

Andy (andy-akw) wrote :

I have the same problem. I have a clean install of Ubuntu 12.04 (32bit) and everything was good until 19th May - so presumably an update at that time has somehow disabled USB keyboard detection. When I get the login screen I cannot type my password. If I remove the keyboard USB plug then re-insert it I can type as normal. I have tried using different USB ports and the behaviour is the same. This one needs an urgent fix please!

Richard Chadwick (radddchad) wrote :

Fresh install using Unetbootin to put it onto usb drive. Tried to install with updates installed and without the updates being installed during installation. I tried three different usb ports. also the touchpad mouse does not work. It is a synaptics ps2 port even though it is below the keyboard. Will try a different usb drive or another imager tomorrow, such as pendrive linux. It is parallel to my XP SP3 install. No access to internet due to can't point. Can get to terminal though. System is an Acer Aspire AOA150. Cheap but works. When I ran 12.04 on the usb drive, everything ran fine, no problems.

Clifton (quantrex) wrote :

Fresh install on three different machines, (one laptop-two desktops), reveals the same problem with a Logitech K360 wireless USB keyboard/mouse and a Logitech K340 wireless USB keyboard. In these cases, unplugging and replugging doesn't cure the problem nor does running the patches. Only multiple reboots works and this sometimes requires as many as six tries and never fewer than two.
Someone dropped the ball on this one.

simon jarman (simon-jarman) wrote :

Just confirming this bug on an AsusAT510nt with wired Apple USB keyboard and wireless Shintaro keyboard after upgrading to 12.04. The wired one will mostly be recognised in unplugged and plugged in, although sometimes not in GRUB, just past that stage. The wireless one is more flakey and sometimes will connect after multiple unplugging and re-plugging. Also a bug in the equivalent Mint (13), so they haven't fixed it there either.

Ty Harlacker (harlacker) wrote :

Confirming this bug; My system (12.04) was working until the latest X11 update. After reboot I couldn't use my Microsoft optical mouse or wired keyboard. Everything works in Win7. The mouse will start working if I leave the login screen up for about 3 min. Then I click on the onscreen keyboard to enter my password and work. I have reinstalled with boot-cd and USB stick. Same result in the end. I have also attempted dpkg reconfigure && configure.

palimmo (palimmo) wrote :

Same problem. USB Keyboard HAMA SL640 on Ubuntu 12.04 64bit.
~$ lsusb
Bus 006 Device 003: ID 04d9:1503 Holtek Semiconductor, Inc. Shortboard Lefty

So the OS recognized it but the keyboard doesn't react ... even the Caps Lock and Num Lock keys don't blink.
Regarding the legacy support (useful for GRUB), I have found no entry in the BIOS.
In GRUB it works sometimes.
On the same laptop I have Win7 in dual boot. And I have to say that it always works on it.
Surprisingly now I have booted my laptop: the usb keyboard hasn't worked in GRUB but it has worked since the ubuntu login! And now I'm typing with it.
It means that Ubuntu has the right drivers and they work. But how to "load" them always correctly?

Madhurya Nangia (madhurya27) wrote :

My Microsoft optical mouse doesnt work either. I also noticed that my bluetooth stopped working so I tried uninstalling bluez and all its components. Mouse worked at once but as soon as I restarted its back to square one

Leah (leahnanderson) wrote :

Confirming this is an issue with my keyboard as well (USB Corded keyboard - Acer Keyboard SK 9020) It doesnt work well...............Typing issues
My mouse isnt experiencing problems.

n6151h (n6151h) wrote :

Having same issues. Here's a bit more info.

Installed 12.04 32-bit on a system with an ATI Radeon with dual Sceptre X20 displays.

All seemed to go fine.

Tried to reconfigure displays to non-mirroring. Found that I couldn't. ATI proprietary driver(s) not installed.

Installed these. Got a pop-up saying I'd need to reboot for new drivers to be activated.

Rebooted.

USB keyboard and mouse no longer work.

These devices seem to freeze long before the login screen comes up. As of the time the mouse pointer first appears on the screen, mouse input yields no effect on this pointer.

Have tried uninstalling / reinstalling fglrx.

Have tried uninstalling / reinstalling udev.

No effect in either case.

Have also tried using xorg.conf.failsafe (copying it to xorg.conf) in /etc/X11. No effect other than for another popup X11 startup that tells me monitor will now come up in low-res mode. Never gets past this.

Dave Lowe (dave-davedorm) wrote :

Confirmed on my system, 12.04 32-bit, NVIDIA chipset for video.Mouse and keyboard quit sporadically requiring hard reboot. Tried with both Logitech wireless USB set and with separate wired USB devices. Times and activity suggest random crashes.

Mercer Rivière (vincentuq) wrote :

I confirm this, update from the previous release (clean install).
Workaround is to unplug and plug the affected usb mouse again, which is then detected.
Actually, googling reveals this affects quite a lot of people. I believe it's not very pleasant surprise for a usual user.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
nick_s (nickstylianou) wrote :

This also affects me on 12.04 64-bit (Mythbuntu).
It used to work fine. A previous round of updates caused it to stop working but unplugging/replugging the USB adapter seemed to fix it. With the latest round of updates (to kernel 3.2.0-32) it's stopped working and unplugging/replugging doesn't fix it.
The keyboard's built-in trackball moves the mouse around fine, keyboard presses light up the LED activity indicator on the USB adapter but no keypresses are registered at the login prompt.

nick_s (nickstylianou) wrote :

Further to my last post... Firstly I attached a PS2 keyboard to get past the desktop login/password, when the desktop session started the wireless keyboard still wouldn't work. Secondly there was another USB device plugged in (a sensor for a remote control that appears to the system as a keyboard+mouse), I removed that and the wireless keyboard resumed working, plugged it back in and the wireless keyboard has continued to work ever since (including after reboots).

Peter Errity (perrity) wrote :

I have similar issues with a Logitech DiNovo (unified keyboard/mouse with proprietory bluetooth dongle).

I can't say for certain when the problem started but it is persistent on my current version of Ubuntu 3.2.0-32-generic-pae. I have a dual boot install (with Vista) and the Logitech Keyboard does not work at boot to select grub menu options so machine continues to default Ubuntu login. Keyboard does not work for Ubuntu login so I use a backup wirelees PS2 keyboard.

Sometimes after login the Logitech keyboard and mouse will function but only for a while. Eventually the keyboard and/or mousepad appear to lock up. Sometimes they will free themselves after a few minutes, Sometime they will free themselves after I power down/up the keyboard. Sometimes nothing works including backup PS2 wireless keyboard and mouse) and I have to reboot the machine.

I have tried many 'fixes' over the last month or two to no avail, including reinstalling bluetooth apps, setting KERNEL == 'hidraw*' in /lib/udev/rules.d/97-bluetooth-hid2hci.rules (http://ubuntuforums.org/showthread.php?t=1858493) and purchased a cheap usb bluetooth dongle to replace the Logitech one.

As I write this using USB wireless PS2 keyboard the Logitech mousepad works but the keyboard shows no response.

Strangely I just found KERNEL == "hiddev*" maybe I set it back at some point, so I will try it again and will report if it solves the problem.

Peter Errity (perrity) wrote :

Having reverted to KERNEL == "hidraw*" ()see above post) and reboot, I was able to use my Logitech keyboard to select in the grup menu and to login at the Ubuntu login screen (this is a first for a long time) . Keyboard and mouse appear to be working normally. I will monitor for a day or two and post back on whether or not my specific issue is resolved.

Peter Errity (perrity) wrote :

One addition...
I had set up Blueman Device Manager 1.23 to open on startup and was able to see the Logitech device connected and tx rx activity but this time the Blueman Window is empty and I do not have a bluetooth icon on the system tray.

Mercer Rivière (vincentuq) wrote :

Seems it will never be fixed?

Mercer Rivière (vincentuq) wrote :
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Mercer Rivière (vincentuq) wrote :

Unfortunately the problem persist
Sometimes after a boot the mouse is still not working, unplug and plug results with:

[10282.964070] hub 1-0:1.0: unable to enumerate USB device on port 3
[10434.128070] usb 2-4: new low-speed USB device number 2 using ohci_hcd
[10434.438116] input: HID 1241:1166 as /devices/pci0000:00/0000:00:02.0/usb2/2-4/2-4:1.0/input/input4
[10434.438985] generic-usb 0003:1241:1166.0001: input,hidraw0: USB HID v1.00 Mouse [HID 1241:1166] on usb-0000:00:02.0-4/input0
[10434.439047] usbcore: registered new interface driver usbhid
[10434.439052] usbhid: USB HID core driver
[10434.440748] usbcore: registered new interface driver usbmouse
[10434.440756] usbmouse: v1.6:USB HID Boot Protocol mouse driver

Felix Moreno (info-justdust) wrote :

same problem here, in ubuntu 13.10 is not working mouse and keyboard at start a problem if u have encrypted partitions...
probably the solution is the same as this... they fixed it for ubuntu 13.04 but again in ubuntu 13.10...
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1066376

larry2rock (coleld) wrote :

My related problem was that GRUB2 would not recognize a USB keyboard.
I discovered a BIOS setting for USB keyboard support (document says for DOS mode) that was Disabled by default. Enabling that feature fixed my problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.