1217:00f7 [TravelMate 8200] Firewire prevents booting

Bug #981936 reported by Sten Bennetsen on 2012-04-14
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Linux
Confirmed
High
linux (Ubuntu)
Medium
Unassigned

Bug Description

When trying to boot using kernel 3.2.x kernel the screen just goes blank and harddisk IO stops.
Removing the quiet and splash options in combination with nomodeset seems to reveal
that the booting stops due to an error in setting the firewire's power levels (see attachment)
Kernel 3.0.x work fine.

ps
The system was updgraded from 11.10 -> 12.04 beta 2

WORKAROUND: Disable the firewire module from loading during boot.

edit:
   /etc/modprobe.d/blacklist-firewire.conf

uncommented the line:
   blacklist firewire-ohci

Run:
   sudo update-initramfs -k all -u

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-generic 3.2.0.23.25
ProcVersionSignature: Ubuntu 3.0.0-17.30-generic 3.0.22
Uname: Linux 3.0.0-17-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu2
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: xylth 2060 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xb0000000 irq 50'
   Mixer name : 'Realtek ALC883'
   Components : 'HDA:10ec0883,1025160d,00100002 HDA:11c13026,11c13026,00100600'
   Controls : 32
   Simple ctrls : 19
Date: Sat Apr 14 23:55:19 2012
HibernationDevice: RESUME=UUID=4582b1cc-b90b-485e-9bae-5eb3afea532a
IwConfig: Error: [Errno 2] No such file or directory
MachineType: Acer, inc. TravelMate 8200
ProcEnviron:
 LANGUAGE=en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: root=UUID=4d03bdfa-c7f8-4502-8516-be6c6286e02b ro quiet splash
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-17-generic N/A
 linux-backports-modules-3.0.0-17-generic N/A
 linux-firmware 1.79
RfKill: Error: [Errno 2] No such file or directory
SourcePackage: linux
UdevDb: Error: [Errno 2] No such file or directory
UpgradeStatus: Upgraded to precise on 2012-04-13 (1 days ago)
WpaSupplicantLog:

dmi.bios.date: 06/19/06
dmi.bios.vendor: Acer
dmi.bios.version: v1.3319
dmi.board.name: Como
dmi.board.vendor: Acer, Inc.
dmi.board.version: Not Applicable
dmi.chassis.type: 1
dmi.chassis.vendor: , Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrv1.3319:bd06/19/06:svnAcer,inc.:pnTravelMate8200:pvrNotApplicable:rvnAcer,Inc.:rnComo:rvrNotApplicable:cvn,Inc.:ct1:cvrN/A:
dmi.product.name: TravelMate 8200
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer, inc.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu3
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: xylth 2060 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xb0000000 irq 49'
   Mixer name : 'Realtek ALC883'
   Components : 'HDA:10ec0883,1025160d,00100002 HDA:11c13026,11c13026,00100600'
   Controls : 32
   Simple ctrls : 19
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=4582b1cc-b90b-485e-9bae-5eb3afea532a
IwConfig: Error: [Errno 2] No such file or directory
MachineType: Acer, inc. TravelMate 8200
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: root=UUID=4d03bdfa-c7f8-4502-8516-be6c6286e02b ro quiet splash
ProcVersionSignature: Ubuntu 3.0.0-17.30-generic 3.0.22
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-17-generic N/A
 linux-backports-modules-3.0.0-17-generic N/A
 linux-firmware 1.79
RfKill: Error: [Errno 2] No such file or directory
SourcePackage: linux
Tags: precise precise
UdevDb: Error: [Errno 2] No such file or directory
Uname: Linux 3.0.0-17-generic i686
UpgradeStatus: Upgraded to precise on 2012-04-13 (2 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
WpaSupplicantLog:

dmi.bios.date: 06/19/06
dmi.bios.vendor: Acer
dmi.bios.version: v1.3319
dmi.board.name: Como
dmi.board.vendor: Acer, Inc.
dmi.board.version: Not Applicable
dmi.chassis.type: 1
dmi.chassis.vendor: , Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrv1.3319:bd06/19/06:svnAcer,inc.:pnTravelMate8200:pvrNotApplicable:rvnAcer,Inc.:rnComo:rvrNotApplicable:cvn,Inc.:ct1:cvrN/A:
dmi.product.name: TravelMate 8200
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer, inc.

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: New → Confirmed
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-23.36
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

The problem persists of halting boot on firewire initialization.

 It appears from the package description that the kernel is 64 bit
(Linux kernel image for version 3.2.0 on 64 bit x86 SMP )

But my machine is a Intel Duo T2300 (32-bit) which should then be a
 Linux kernel image for version 3.2.0 on 32 bit x86 SMP .

- How did a 64 bit kernel get onto my 32 bit system - serious problem or wrong package description ?!.

The 3.0.0.17 kernel im running on now is 32/64 bit according to the description
(Linux kernel image for version 3.0.0 on x86/x86_64)
but no SMP in the description though both processors are utilized.

tags: added: bot-stop-nagging needs-bisect needs-upstream-testing regression-release
removed: kernel-request-3.2.0-23.36

Sten Bennetsen, thank you for reporting this and helping make Ubuntu better. Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/daily/current/ . If the issue remains, please run the following command in the development release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.

Please let us know your results. Thanks in advance.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

I cannot reinstall the system using the iso images as I have data I do not want to delete on this machine.
I did intall the linux-image-3.4.0-999-generic_3.4.0-999.201204150427_i386.deb + headers and the booting problem persists.
- It stops at the same place as the previously attached jpeg shows.
   I have to power off the machine in order to get it to work again crtl+alt+del does nothing.

I think the developer have to investigate this firewire "set link power level" problem.
The problem must have been introduced after 3.0.0-17 and at latest 3.2.0-23 since the problem can be reproduced in 3.2.0-23 and above.

I tried doing the apport thingy but it threw an error in the process so Im not sure all data got attached.

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing

Sten Bennetsen, thank you for apporting in Precise and testing mainline. The next step is to perform a kernel bisect to identify which commit introduced this problem. Could you please do so following https://wiki.ubuntu.com/Kernel/KernelBisection ?

Changed in linux (Ubuntu):
importance: Undecided → Medium
Changed in linux (Ubuntu):
status: Incomplete → Triaged

I've tried following the guide but I always end up loosing the ubuntu specific folders for doing a build when bisecting.
Heres what I've done:

 git clone git://kernel.ubuntu.com/ubuntu/ubuntu-precise.git

 sudo apt-get build-dep linux-image-$(uname -r) -- this would then be the 3.0.0-17 stuff

Everything is fine and I can run the commands
- fakeroot debian/rules clean
- fakeroot debian/rules binary-headers binary-generic
Because the debian/rules aso is present.

Then I start bisecting:
 git bisect start Ubuntu-3.2.0-1.1 Ubuntu-3.0.0-1402.3

Now I cant build because the debian/rules stuff is gone.
How do I build and/or get the debian/rules stuff back without resetting bisection.

Didt a manual bisect instead.

I've found the problem all the way back to the Ubuntu-3.1.0-1.1 tag.
I where not able to build the 3 earlier tags due to compliation errors.

Hope this helps so you can find and fix this error that seems to be related to firewire and power settings.

Found a work-around :
   Disable the firewire module from loading during boot.

edit:
   /etc/modprobe.d/blacklist-firewire.conf

uncommented the line:
   blacklist firewire-ohci

Run:
   sudo update-initramfs -k all -u

Im now able to boot the release kernel 3.2.0-24 without any problem only downside is no firewire support.

I've now proven that its a firewire bug or very closely related to firewire.
Also proven that the bug appeared between kernel 3.0.0-17+ and 3.1.0-1.

tags: added: found-workaround
removed: needs-bisect
tags: added: needs-bisect
removed: found-workaround
description: updated
description: updated
Rob Allen (theburge) wrote :

Having binary chopped through http://kernel.ubuntu.com/~kernel-ppa/mainline/, it seems that the problem was introduced between 3.1.0-0301rc2 (working) and 3.1.0-0301rc3 (broken as in the original report).

Rob Allen (theburge) wrote :

Filed an upstream kernel bug for this issue.

Changed in linux:
importance: Undecided → Unknown
status: New → Unknown
Changed in linux:
importance: Unknown → High
status: Unknown → Confirmed
summary: - Firewire prevents booting
+ 1217:00f7 Firewire prevents booting

Rob Allen, please execute the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug linux

Thanks!

Rob Allen (theburge) wrote :

Christopher,

As requested, I've raised an apport bug (bug #1000197). Thanks.

Rob Allen (theburge) wrote :

Christopher,

One more thing: I was told that the kernel bug-reporting instructions you referenced in comment #28 are incorrect. (See the initial discussion linked from the kernel bug.)

What's the best way to get them updated? Should I simply email the page author, leannogasawara?

Rob Allen (theburge) wrote :

Actually *I'm* wrong about the bug reporting instructions being wrong. They're technically correct, but they seem to imply that one should go straight to the kernel bugzilla, instead of the kernel mailing lists.

So it might still be useful to emphasise the use of the mailing lists for bug *reporting*.

Sten Bennetsen, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc5

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: bios-outdated-3521
Changed in linux (Ubuntu):
status: Triaged → Incomplete

I don't want to install an alpha version on my machine therefore I've
tried with USB boot stick instead using 13.10 and 14.01
(trusty-desktop-i386.iso 04-Jan-2014 07:51 ).

Both fails on exactly the same line when booting without the splash
screen.
"firewire_ohci failed to set power level" and then everything halts -
keyboard unresponsive.

The USB stick boots fine on other machines.

If I add the blacklist=firewire_ohci to the commandline boot it loads a
bit further, but halts later on
it seems like its loading the firewire_ohci disregarding the boot
option. Guess its an USB stick boot "design issue".
Since I cant boot from the stick, I cant run the apport command. Cant
you use the original attached apport ?. My hardware hasn't changed.

As long as the kernel issue remains unfixed I don't see how newer
versions of ubuntu could fix this ?.
https://bugzilla.kernel.org/show_bug.cgi?id=43244

I think Rob Allan did a bisect and found a pretty precise commit in the
3.1.0-rc2 & 3.1.0-rc3 kernel that caused the issue.
Some firewire "refactoring".

On Sun, 2013-12-29 at 19:55 +0000, Christopher M. Penalver wrote:

> Sten Bennetsen, this bug was reported a while ago and there hasn't been
> any activity in it recently. We were wondering if this is still an
> issue? If so, could you please test for this with the latest development
> release of Ubuntu? ISO images are available from
> http://cdimage.ubuntu.com/daily-live/current/ .
>
> If it remains an issue, could you please run the following command in
> the development release from a Terminal
> (Applications->Accessories->Terminal), as it will automatically gather
> and attach updated debug information to this report:
>
> apport-collect -p linux <replace-with-bug-number>
>
> If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
> kernel-fixed-upstream
> kernel-fixed-upstream-VERSION-NUMBER
>
> where VERSION-NUMBER is the version number of the kernel you tested. For example:
> kernel-fixed-upstream-v3.13-rc5
>
> This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
> needs-upstream-testing
>
> If the mainline kernel does not fix this bug, please add the following tags:
> kernel-bug-exists-upstream
> kernel-bug-exists-upstream-VERSION-NUMBER
>
> As well, please remove the tag:
> needs-upstream-testing
>
> Once testing of the upstream kernel is complete, please mark this bug's
> Status as Confirmed. Please let us know your results. Thank you for your
> understanding.
>
> ** Tags added: bios-outdated-3521
>
> ** Changed in: linux (Ubuntu)
> Status: Triaged => Incomplete
>

tags: added: saucy trusty

Sten Bennetsen, thank you for your comments. As per your https://launchpadlibrarian.net/101909791/BootDmesg.txt :
[ 0.000000] ACPI: BIOS bug: multiple APIC/MADT found, using 0
...
[ 0.164693] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored

Hence, as per http://us.acer.com/ac/en/US/content/drivers an update is available for your BIOS (3521). If you update to this following https://help.ubuntu.com/community/BiosUpdate , does it change anything? If it doesn't, could you please both specify what happened, and just provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

For more on BIOS updates and linux, please see https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette .

Thank you for your understanding.

summary: - 1217:00f7 Firewire prevents booting
+ 1217:00f7 [TravelMate 8200] Firewire prevents booting
tags: added: pwa
Patochem (pmullot) wrote :

I'm in exactly the same situation as Sten Bennetsen.

I've just upgraded the BIOS, but without any change to the firewire issue.

by the way the "firewire-ohci.blacklist=yes" command doesn't work for me. Instead I have to use
"blacklist=firewire_ohci"

I confirm the work-around works perfectly.

Thanks!

Patochem, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Fred McKilroy (fred-mckilroy) wrote :

I'm having the same problem with my Acer Travelmate 8215WLMI. Now, funny as it seems, since Ubuntu 11 I have to use
"blacklist.firewirewire_ohci=yes" as a work-around, "blacklist=firewire_ohci" just wouldn't work.
I'm actually using Ubuntu 12.04.5 Kernel 3.2.0-67.
Trying Ubuntu 14 using the work-around and alternatively trying "blacklist=firewire_ohci" fails at booting with "firewire_ohci .....:failed to set link power". I tried booting with USB-stick and as well DVD.

Seems the newer Kernel not only keeps on with the same bug, but to worsen the situation ignores the blacklist command.

Anything else that I could do?

Fred McKilroy, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
https://wiki.ubuntu.com/Kernel/Policies/DuplicateBugs
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

As well, please do not announce in this report you created a new bug report.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.