1180:e822 [Lenovo Thinkpad T420] SD Card-reader non functional

Bug #978929 reported by Daniel Manrique
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux
Confirmed
Medium
linux (Ubuntu)
Incomplete
Medium
Unassigned
Nominated for Precise by Jeff Marcom

Bug Description

The SD card reader on this system doesn't work at all: no errors, no messages, nothing on SD card insertion. It's like it's not even there.

I think it shares the card reader with the systems reported on bug 773524, but the symptoms reported there were different.

Also, this is pretty much the same bug as 879674, which was duped to bug 717435, which is in turn marked Fix Released, but since this is still not working, I decided to file a new bug (it's also a different Ubuntu release).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-23-generic 3.2.0-23.36
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.95-0ubuntu1
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1527 F.... pulseaudio
Date: Wed Apr 11 09:40:22 2012
HibernationDevice: RESUME=UUID=da651f8f-a75f-4777-b03f-a7f795389a08
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120328)
MachineType: LENOVO 4177Q2U
ProcEnviron:
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=c1d31d25-d3b8-4c00-9393-4d97bce5ab12 ro quiet splash initcall_debug vt.handoff=7
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/31/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 83ET53WW (1.23 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4177Q2U
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr83ET53WW(1.23):bd03/31/2011:svnLENOVO:pn4177Q2U:pvrThinkPadT420:rvnLENOVO:rn4177Q2U:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4177Q2U
dmi.product.version: ThinkPad T420
dmi.sys.vendor: LENOVO

Revision history for this message
Daniel Manrique (roadmr) wrote :
Revision history for this message
Daniel Manrique (roadmr) wrote :

I tried the series of setpci commands from comment #13 on this bug:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/773524

I still get nothing from the card reader.

Brad Figg (brad-figg)
Changed in linux (Ubuntu):
status: New → Confirmed
Revision history for this message
Daniel Manrique (roadmr) wrote :

Tried the latest mainline kernel (3.4.0-rc2) and I get the same result (i.e. nothing, zilch).

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Revision history for this message
Mike Sterling (mike-sterling) wrote :

I'll +1 this. Running latest Precise on my T420s and attempting to access a Transcend 8 GB Class 10 SDHC Micro-SD card (in adapter) fails with the error -110.

[ 439.677072] sdhci: Switching to 1.8V signalling voltage failed, retrying with S18R set to 0
[ 449.672202] mmc0: Timeout waiting for hardware interrupt.
[ 451.274181] mmc0: error -110 whilst initialising SD card

Linux mikester-t420l 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

-M

Ara Pulido (ara)
tags: added: blocks-hwcert
Revision history for this message
Daniel Manrique (roadmr) wrote :

The following two upstream reports look like they may apply to this problem, although the symptom seems different (mine doesn't see the reader at all):

https://bugzilla.kernel.org/show_bug.cgi?id=38922

https://bugzilla.kernel.org/show_bug.cgi?id=42568

Revision history for this message
Michael Cook (michaelcook-mjc) wrote :

In my experience with a T420 U12.04b2 the SDHC card appeared. However, had (different) problems
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/975305.

In U10.10,11.10 I didn't see the SDHC appear at all when inserted. Nothing in the logs. In U12.04b2 I see it appear and can read/write although I'm not convinced reliably read-write and have problems with dd.

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernels, as well as the latest Quantal kernel?

The latest upstream kernel can be downloaded from:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-quantal/

The latest Quantal kernel can be downloaded from(Arch specific links are under "Builds"):
https://launchpad.net/ubuntu/+source/linux/3.4.0-3.8

tags: added: kernel-da-key
Revision history for this message
Daniel Manrique (roadmr) wrote :

Hi Joseph,

I tested the Quantal kernel you suggest (actually the system has Quantal installed right now), and I also tested the mainline kernel from here:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc1-quantal/

both give the same result, nothing appears at all when inserting the USB stick.

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Revision history for this message
Daniel Manrique (roadmr) wrote :
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Ara Pulido (ara)
tags: added: regression-release
tags: added: bios-outdated-1.46 needs-upstream-testing
tags: added: quantal
tags: added: kernel-bug-exists-upstream-v3.5-rc1
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Daniel Manrique, as per http://download.lenovo.com/express/ddfm.html an update is available for your BIOS (1.46). If you update to this following https://help.ubuntu.com/community/BiosUpdate , does it change anything? If it doesn't, could you please both specify what happened, and just provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Thank you for your understanding.

summary: - [Lenovo Thinkpad T420] SD Card-reader non functional
+ 1180:e822 [Lenovo Thinkpad T420] SD Card-reader non functional
Changed in linux (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.