8086:4229 Unable to connect to 5Ghz Wireless Network Intel 4965

Bug #974674 reported by Darren Watt on 2012-04-05
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

Unable to connect to 5Ghz, 2.4Ghz working fine, older versions of Ubuntu working up to and including 11.04, broken after this point. Tested in mainline build, same problem occurs.
Occasionally connects, but usually just keeps requesting password for the network.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-21-generic-pae 3.2.0-21.34
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic-pae 3.2.13
Uname: Linux 3.2.0-21-generic-pae i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.95-0ubuntu1
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: darren 1779 F.... pulseaudio
Date: Thu Apr 5 22:48:20 2012
HibernationDevice: RESUME=UUID=91bf5939-87b5-4724-8dfc-67d9b135dfee
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120328)
MachineType: Dell Inc. XPS M1530
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-21-generic-pae root=UUID=074762ed-4dcc-4979-84b1-6526a36a4992 ro quiet splash vt.handoff=7
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/19/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A12
dmi.board.name: 0D501F
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA12:bd11/19/2008:svnDellInc.:pnXPSM1530:pvr:rvnDellInc.:rn0D501F:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: XPS M1530
dmi.sys.vendor: Dell Inc.

Darren Watt (thedarrenwatt) wrote :
tags: added: natty needs-bisect regression-release

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: New → Confirmed
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-22.35

Darren Watt, thank you for reporting this and helping make Ubuntu better. If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: bot-stop-nagging
removed: kernel-request-3.2.0-22.35
Changed in linux (Ubuntu):
importance: Undecided → Medium
Darren Watt (thedarrenwatt) wrote :

Updated to mainline kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current/
Problem remains.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Brad Figg (brad-figg) on 2012-04-11
tags: added: kernel-wifi
Darren Watt (thedarrenwatt) wrote :
Changed in linux:
importance: Undecided → Unknown
status: New → Unknown
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in linux:
status: Confirmed → Incomplete
Changed in linux:
status: Incomplete → Invalid
Mekanix (kubuntu-mekanix) wrote :

Is there a fix for this for ordinary 12.04 users?

I can see that Darren Watt solved it by installing a custom kernel (3.4?)... is there any less drastic (I'd like to get automatic security updates etc.) method?

summary: - Unable to connect to 5Ghz Wireless Network Intel 4965
+ 8086:4229 Unable to connect to 5Ghz Wireless Network Intel 4965
madvinegar (madvinegar) wrote :

Try this:

Open terminal (ctrl+alt+T) and give the following command:

sudo gedit /etc/modprobe.d/options.conf

In the file that will open, paste inside the following line:

options iwl4965 11n_disable=1

Save, exit, reboot and see if that helped.

Darren Watt, following on https://bugzilla.kernel.org/show_bug.cgi?id=43103#c14 after you updated to the Precise enablement stack 12.04.3, is this issue still reproducible?

tags: added: latest-bios-a12 needs-upstream-testing
Changed in linux (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.