11.10: ata1: Link is slow to respond

Bug #965863 reported by Matthew Stapleton on 2012-03-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Confirmed
Medium
linux (Ubuntu)
Low
Unassigned

Bug Description

I have a friend who is getting ata1: Link is slow to respond on an Acer Aspire 5560G laptop and an SSD with Ubuntu 11.10 (latest updates as of 27 March 2012) and 12.04 beta1 livecd at bootup. Once this happens the laptop has to be power cycled to get the SSD working again. On Ubuntu 11.04 and previous versions and System Rescue CD kernels the laptop boots without any problems.

The SSD is a AR120GBE and the AHCI controller is 1022:7804, subsystem: 1025:059f

Have also tried adding libata.force=norst libata.force=0:norst libata.force=1:norst libata.force=2:norst to the grub boot option although not sure if that is the correct set of parameters.

WORKAROUND: linux-image-lowlatency package with Ubuntu 12.04 as that has CONFIG_HZ=1000 which appears to work without any problems.

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
CasperVersion: 1.312
DistroRelease: Ubuntu 12.04
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
MachineType: Acer Aspire 5560
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB:
 0 radeondrmfb
 1 radeondrmfb
ProcKernelCmdLine: boot=casper initrd=hostname_12.04-beta2-desktop-amd64/casper/initrd.lz netboot=nfs nfsroot=10.4.5.1:/home/storage/hostname-12.04-beta2-desktop-amd64 -- BOOT_IMAGE=hostname_12.04-beta2-desktop-amd64/casper/vmlinuz
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic 3.2.12
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
Tags: precise
Uname: Linux 3.2.0-20-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 12/05/2011
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: V1.15
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Aspire 5560
dmi.board.vendor: Acer
dmi.board.version: A11
dmi.chassis.asset.tag: Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: Acer
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvrV1.15:bd12/05/2011:svnAcer:pnAspire5560:pvr0.1:rvnAcer:rnAspire5560:rvrA11:cvnAcer:ct9:cvr0.1:
dmi.product.name: Aspire 5560
dmi.product.version: 0.1
dmi.sys.vendor: Acer

affects: esp → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 965863

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
importance: Undecided → Medium

apport information

tags: added: apport-collected precise
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-21.34

I just manually compiled linux-source-3.2.0.tar.bz2 from linux-source-3.2.0_3.2.0-21.34_all.deb with a custom config and it detected the SSD correctly. Using the binary kernel from linux-image-3.2.0-21-generic_3.2.0-21.34_amd64.deb still times out.

My custom kernel config

I just compiled linux-source-3.2.0.tar.bz2 from linux-source-3.2.0_3.2.0-21.34_all.deb with config-3.2.0-21-generic from linux-image-3.2.0-21-generic_3.2.0-21.34_amd64.deb and got the timeout.

This is the config I have so far (working back from the Ubuntu default config) and it is still timing out on the SSD.

I just tried mainline kernels: 3.2.0 and 3.2.14 with the standard Ubuntu kernel and got the timeout there as well so it isn't a problem with just the Ubuntu kernel. I might report this to the main kernel bugzilla site.

Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Incomplete → Triaged

Here is the url for the upstream bug report: https://bugzilla.kernel.org/show_bug.cgi?id=43039

Maarten Bezemer (veger) wrote :

Thanks for taking the time to report this bug in the upstream bug tracking system this is a tremendous help. Launchpad has the ability to watch lots of upstream bug trackers and this can be done by following the procedure documented at https://wiki.ubuntu.com/Bugs/Watches. I've added the bug watch for this bug report.

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed

It looks like the timeout only occurs with CONFIG_HZ set to 250 which is what most/all? of the Ubuntu kernels use, although the timeout also occurs with mainline kernel as well without all of the Ubuntu patches applied, and it is 'fixed' by changing CONFIG_HZ to 100 or 1000 (Haven't tried 300 yet).

Let me know if you want me to do any more testing. We're now using the linux-image-lowlatency package with Ubuntu 12.04 as that has CONFIG_HZ=1000 which appears to work without any problems. Even recent versions of the linux-image package with CONFIG_HZ=250 still appear to have the timeout problem.

tags: added: bot-stop-nagging latest-bios-v1.15 needs-upstream-testing oneiric
removed: kernel-request-3.2.0-21.34
tags: added: regression-release
description: updated

Matthew Stapleton, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc5

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: needs-bisect
Changed in linux (Ubuntu):
importance: Medium → Low
status: Triaged → Incomplete

It may be a few weeks before I can run tests with the very latest kernel. Also, since finding out that the linux-image-lowlatency package works, we haven't done much more testing, but it was still having problems on the generic kernel the last time we upgraded to a new version of Ubuntu about half a year ago. We also still haven't tested with a hard drive to see if the problem exists there as well or if the laptop only has the problem with that particular SSD.

To post a comment you must log in.