Ubuntu

Asus Zenbook UX31 doesn't resume from suspend, possible corruption

Reported by Timo Jyrinki on 2012-03-23
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Asus Zenbook UX31 doesn't resume from suspend, and possibly causing semi-permanent corruption in memory and SSD controller based on reports. "Semi-permanent" because fixing the problem requires removing the battery, which is integrated in the laptop so that one voids her warrant opening the laptop up and removing the battery.

There is a known workaround available which fixes the problem, adding a /etc/pm/sleep.d/20_zenbook file with the following contents:

EHCI_BUSES="0000:00:1a.0 0000:00:1d.0"
case "${1}" in
    hibernate|suspend)
        # Switch USB buses off
        for bus in $EHCI_BUSES; do
            echo -n $bus > /sys/bus/pci/drivers/ehci_hcd/unbind
        done
        ;;
    resume|thaw)
        # Switch USB buses back on
        for bus in $EHCI_BUSES; do
            echo -n $bus > /sys/bus/pci/drivers/ehci_hcd/bind
        done
        ;;
esac

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-20-generic 3.2.0-20.32
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: timo 1952 F.... pulseaudio
CRDA: Error: [Errno 2] Tiedostoa tai hakemistoa ei ole
Date: Fri Mar 23 07:39:54 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120316)
MachineType: ASUSTeK Computer Inc. UX31E
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=fi_FI.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-20-generic root=UUID=3a913d68-5aad-4ac9-9436-4798da5b8fc2 ro crashkernel=384M-2G:64M,2G-:128M quiet splash drm.vblankoffdelay=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1 i915.semaphores=1 pcie_aspm=force vt.handoff=7
SourcePackage: linux
StagingDrivers: rts5139 mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/26/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: UX31E.210
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: UX31E
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrUX31E.210:bd12/26/2011:svnASUSTeKComputerInc.:pnUX31E:pvr1.0:rvnASUSTeKComputerInc.:rnUX31E:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: UX31E
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.

Timo Jyrinki (timo-jyrinki) wrote :
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-precise/

tags: added: needs-upstream-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux:
importance: Unknown → Medium
status: Unknown → Incomplete
Timo Jyrinki (timo-jyrinki) wrote :

Not fixed in upstream, which is why the kernel bugzilla bug is still open as well. http://ubuntuforums.org/showthread.php?t=1865577&page=132 thread has among its multitude of messages some debate as well. The bug is also documented at help.ubuntu.com https://help.ubuntu.com/community/AsusZenbook#Suspend.2C_Hibernate.2C_Shut-down_and_Reboot

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Ernst Sjöstrand (ernstp) wrote :

This should now be fixed in upstream 3.3.5! Will test really soon.
Here's the commit that could be cherrypicked to the Ubuntu kernel:
http://git.kernel.org/?p=linux/kernel/git/stable/linux-stable.git;a=commit;h=1ce9245f5aff46201fa81fdd3f796a6c9f3ad1ab

Ernst Sjöstrand (ernstp) wrote :

3.3.5 works for me, so now it's just a matter of getting this into Ubuntu.

Changed in linux (Ubuntu):
status: Triaged → In Progress
Timo Jyrinki (timo-jyrinki) wrote :

It should also be fixed in Linux 3.2.17 - https://lwn.net/Articles/496940/ / http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.17-precise/

If that's the case, it'll just happen with the next Ubuntu 12.04 LTS kernel update probably, which would be awesome.

Changed in linux:
status: Incomplete → In Progress
Timo Jyrinki (timo-jyrinki) wrote :

The patch was included in the 3.2.0-25.40 kernel that has now moved from proposed to real updates in 12.04.

Timo Jyrinki (timo-jyrinki) wrote :

At least I've been now running the 3.2.0-25.40 kernel without the 20_zenbook script just fine for a few days, so I suspect the patch is working as intended. Therefore marked as Fix Released.

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Changed in linux:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.