12.04: Toshiba Tecra R840 fail to resume after suspend

Bug #962142 reported by Artur Pinheiro on 2012-03-22
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Linux
Incomplete
High
linux (Ubuntu)
Medium
Unassigned

Bug Description

Trying to resume from suspend fail.

The only activity in the laptop is the cooler fan that seems to be put to maximum. There are no caps lock binking, no disk activity. Then display stays black. Then /var/log/pm_* don't shoes nothing special (no error on suspend, no messages on resume). I have to restart the computer.

I try pm-suspend and s2ram, the results are the same.

Suspend/resume works well with 11.10.

WORKAROUND: I change /etc/default/grub from:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nox2apic"

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: artur 1913 F.... pulseaudio
 /dev/snd/controlC0: artur 1913 F.... pulseaudio
 /dev/snd/pcmC0D0c: artur 1913 F...m pulseaudio
 /dev/snd/pcmC0D0p: artur 1913 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xcc520000 irq 51'
   Mixer name : 'Realtek ALC269VB'
   Components : 'HDA:10ec0269,1179062a,00100100'
   Controls : 18
   Simple ctrls : 10
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xcc420000 irq 52'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 6
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=f3ab48a8-f353-4736-8531-1101a642ba82
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
MachineType: TOSHIBA TECRA R840
NonfreeKernelModules: fglrx
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-19-generic root=UUID=74326f68-7f22-43f6-8a92-039818fcd4ff ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-19.31-generic 3.2.12
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-19-generic N/A
 linux-backports-modules-3.2.0-19-generic N/A
 linux-firmware 1.72
StagingDrivers: mei
Tags: precise staging
Uname: Linux 3.2.0-19-generic x86_64
UpgradeStatus: Upgraded to precise on 2012-03-19 (3 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 04/19/2011
dmi.bios.vendor: TOSHIBA
dmi.bios.version: Version 2.60
dmi.board.asset.tag: 0000000000
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Version A0
dmi.chassis.asset.tag: 0000000000
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: Version 1.0
dmi.modalias: dmi:bvnTOSHIBA:bvrVersion2.60:bd04/19/2011:svnTOSHIBA:pnTECRAR840:pvrPT429E-00M007EP:rvnTOSHIBA:rnPortablePC:rvrVersionA0:cvnTOSHIBA:ct10:cvrVersion1.0:
dmi.product.name: TECRA R840
dmi.product.version: PT429E-00M007EP
dmi.sys.vendor: TOSHIBA

Artur Pinheiro (agp75) wrote :

I forget to mention that this bug is related to 12.04 beta...

Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in linux.

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://help.ubuntu.com/community/ReportingBugs.

affects: ubuntu → linux (Ubuntu)
Fabio Marconi (fabiomarconi) wrote :

please run in a terminal
apport-collect 962142
Thanks
fabio
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected precise staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: regression-release
tags: added: needs-upstream-testing
Artur Pinheiro (agp75) on 2012-03-22
tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-20.32
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Incomplete → Triaged
Artur Pinheiro (agp75) wrote :

I submit a bug in bugzilla.kernel.org.

https://bugzilla.kernel.org/show_bug.cgi?id=42977

Maarten Bezemer (veger) wrote :

Thanks for taking the time to report this bug in the upstream bug tracking system this is a tremendous help. Launchpad has the ability to watch lots of upstream bug trackers and this can be done by following the procedure documented at https://wiki.ubuntu.com/Bugs/Watches. I've added the bug watch for this bug report.

Changed in linux:
importance: Unknown → High
status: Unknown → Incomplete
Changed in linux:
status: Incomplete → In Progress
Changed in linux:
status: In Progress → Incomplete
Changed in linux:
status: Incomplete → In Progress
Changed in linux:
status: In Progress → Incomplete

Artur Pinheiro, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

tags: added: needs-full-computer-model needs-upstream-testing
removed: kernel-bug-exists-upstream kernel-request-3.2.0-20.32
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Artur Pinheiro (agp75) wrote :

Hi,

this is related to a bug in 46 bit kernel, as you can see in https://bugzilla.kernel.org/show_bug.cgi?id=42977.

This issue is not solve, but there is a workaround, adding "nox2apic" to Linux boot.

I change /etc/default/grub from
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nox2apic"

This way I'm able to suspend/resume without problem.

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.