8086:4232 [Dell Latitude E6400] wifi not working

Bug #956519 reported by Nicolò Chieffo on 2012-03-15
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Confirmed
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

The wifi is enabled and connected to the correct access point.
Unfortunately no data is transmitted, so even if I ping my router I don't get any answer.

After disabling and enabling wifi several times I can get a good connection

+ https://bugzilla.kernel.org/show_bug.cgi?id=42978#c1
the last version of kernel which didn't have this problem was the one in Ubuntu 11.04, which is 2.6.38 In the following ubuntu releases I've always had this problem.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-18-generic 3.2.0-18.29
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: nchieffo 1547 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6adc000 irq 47'
   Mixer name : 'Intel Cantiga HDMI'
   Components : 'HDA:111d76b2,10280233,00100302 HDA:80862802,80860101,00100000'
   Controls : 25
   Simple ctrls : 11
Date: Thu Mar 15 23:30:01 2012
HibernationDevice: RESUME=UUID=513e975e-781d-4b0f-9ee0-fc756274eed2
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
MachineType: Dell Inc. Latitude E6400
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-18-generic root=UUID=29359acd-6ed2-4b6b-9678-2238dfa87fa8 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-18-generic N/A
 linux-backports-modules-3.2.0-18-generic N/A
 linux-firmware 1.71
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/13/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A29
dmi.board.name: 0RX493
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA29:bd04/13/2011:svnDellInc.:pnLatitudeE6400:pvr:rvnDellInc.:rn0RX493:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude E6400
dmi.sys.vendor: Dell Inc.

Nicolò Chieffo (yelo3) wrote :
Brad Figg (brad-figg) on 2012-03-15
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :
Changed in linux (Ubuntu):
importance: Undecided → Medium

Ok, I've installed it.
I'll let you know if the situation improves!
Actually I've done a reboot and wifi is working now, but it's not enough to
say the bug is fixed, because sometimes it also worked at first try

Nicolò Chieffo

On Fri, Mar 16, 2012 at 3:06 PM, Joseph Salisbury <
<email address hidden>> wrote:

> Would it be possible for you to run one test. Can you try the linux-
> backports-modules-cw-3.3-precise-generic package from
> https://launchpad.net/ubuntu/precise/+package/linux-backports-modules-
> cw-3.3-3.2.0-18-generic
>
> The amd64 .deb is available from:
>
> https://launchpad.net/ubuntu/+source/linux-backports-modules-3.2.0/3.2.0-18.1/+build/3257429/+files/linux-backports-modules-cw-3.3-3.2.0-18-generic_3.2.0-18.1_amd64.deb
>
> ** Changed in: linux (Ubuntu)
> Importance: Undecided => Medium
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/956519
>
> Title:
> wifi notworking
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/956519/+subscriptions
>

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-19.30

The problem persists with new kernel which installed yesterday.
Actually, do I have to update the backport modules to match my kernel version?
If yes can you give me the correct download link?
Thanks

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Nicolò Chieffo (yelo3) wrote :

Hello again, I already installed the new version of backport modules matching my kernel.
Today the problem was there again, so the backported modules are not a solution.

Can I give you additional logs?

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-precise/

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-upstream-testing
Nicolò Chieffo (yelo3) wrote :

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-precise/linux-image-3.3.0-030300-generic_3.3.0-030300.201203182135_amd64.deb

I downloaded this kernel, in the link you provided me.

Is it possible that the bug is in wpa_supplicant instead of the kernel?

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

I also added in the wpasupplicant package to get feedback if it could be an issue.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
tags: added: regression-release
tags: added: oneiric
description: updated

Nicolò Chieffo, as per http://www.dell.com/support/drivers/us/en/19/Product/latitude-e6400 an update is available for your BIOS (A34). If you update to this following https://help.ubuntu.com/community/BiosUpdate , does it change anything?

If not, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful.

For more on BIOS updates and linux, please see https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette .

Thank you for your understanding.

tags: added: bios-outdated-a34 bot-stop-nagging
removed: kernel-request-3.2.0-19.30
summary: - wifi notworking
+ 8086:4232 [Dell Latitude E6400] wifi notworking
summary: - 8086:4232 [Dell Latitude E6400] wifi notworking
+ 8086:4232 [Dell Latitude E6400] wifi not working
no longer affects: wpasupplicant (Ubuntu)
Changed in linux (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.